Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,068 Views

DZ87KLT-75K: Thunderbolt not working, except display

Hello,

I've been having an issue with Thunderbolt on the Intel DZ87KLT-75K desktop board for a while with an Apple Thunderbolt Display.

As a Mac user primarily, I bought a PC for playing games and doing other Windows-stuff. For my Mac, I already had this display, so I chose a motherboard with Thunderbolt support. I also have a Western Digital Thunderbolt Duo storage device.

The Thunderbolt Display works great - as a display - but the additional ports (webcam, USB, FireWire, Ethernet) aren't working. The Windows device manager shows a "Base System Device" after booting with the Thunderbolt Display connected. After disconnecting and connecting the display again while booted, the Base System Device is gone. The Western Digital Thunderbolt harddisk isn't recognized at all - not when connected at boot time, and not when hot-plugged.

I'm using these parts:

  • Intel DZ87KLT-75K motherboard (with thunderbolt display connected)
  • Intel Core i7 4770K
  • Windows 8.1 Pro (UEFI boot on GPT drive)
  • Nvidia GeForce GTX 780 (with no display connected), used trough Lucid Virtu MVP
  • Apple Thunderbolt Display
  • Western Digital Thunderbolt Duo 4TB

I have tried getting Thunderbolt to work in Windows 7, Windows 8, and Windows 8.1 (all 64 bits) and had no success this far. After some Googling I found https://forum-en.msi.com/index.php?topic=163113.0 this on the MSI forums, but it doesn't look like I can find that option in Intel's Visual BIOS.

It would be great if someone could help me getting this to work. Any help is greatly appreciated.

Tags (1)
0 Kudos
7 Replies
Highlighted
Valued Contributor III
31 Views

How are the devices connected in this configuration? This would be to get an idea of the topology of the devices connected.

Could you please provide the AA number and Serial number of the motherboard you have and the BIOS installed?

What brand and part number of cable is being used in this case?

Please use the Intel® System Identification Utility using the following site:

http://www.intel.com/support/siu_la.htm?wapkw=%28siu%29 Intel(R) System Identification Utility

That will generate an 8 digits code called Report Reference ID. Please let us have that code, this will provide us information on what is being detected on your system.

Highlighted
Beginner
31 Views

Thank you for your response.

The devices are connected trough Apple Thunderbolt Cables. I have tested a few different ways of connecting the devices. I have two thunderbolt cables (one 0,5m and one 2m) and the display itself also has a thunderbolt cable fixed to it. The display also has another Thunderbolt port can, aside from daisy chaining, be used for input. I have verified this using my MacBook.

The following ways of connecting things all produce the same result (display works; everything else doesn't):

PC -> Thunderbolt Cable 0,5/2m -> Thunderbolt Display

PC -> Thunderbolt Display with built in cable

PC -> Thunderbolt Cable -> Western Digital Harddisk -> Thunderbolt Display using either built in or separate thunderbolt cable

PC -> Thunderbolt Display -> Western Digital Harddisk

PC -> Western Digital Harddisk (using a HDMI monitor instead of the thunderbolt display)

I don't have part numbers for these cables, but I have http://obbut.nl/tb05 this 0,5 meter cable and http://obbut.nl/tb20 this 2 meter cable (bought from the Dutch Apple Store). Both cables work fine with my MacBook, with which I'm still using them daily.

The board ID tool outputs the following:

Board model: DZ87KLT75K

Board Version: AAG74721-304

BIOS Version: KLZ8711D.86A.0344.2013.0621.1548

Operating System: Microsoft Windows 8.1 Pro

The Intel System Identification Utility outputs the following number: 0218 9493

The AA number, assuming this is the same as the Product Code, is: BOXDZ87KLT-75K.

I hope this information is sufficient.

0 Kudos
Highlighted
Valued Contributor III
31 Views

Thank you for all this information, let me work with this and further research on this and get back to you.

0 Kudos
Highlighted
Novice
31 Views

I had the same problem with my hardware and windows 8.1.

The Solution was: unmark the Intel thunderbolt controller in Bios and install Asmedia 106x controller in Windows 8.1.

After that Everything works fine even daisychaining up to 5 Seagate 3TB harddrives with Thunderbolt Adapters Stae129.

I hope this helped You

Highlighted
Beginner
31 Views

Is there any news on this topic?

0 Kudos
Highlighted
31 Views

Obbut, with this issue I would recommend you to try using a different display so you can test the thunderbolt devices that are not working correctly when being passed through it.

You may also want to check if those devices have the correct drivers, or they need to be updated.

Most thunderbolt devices are made to work with Apple products as a standard and have Windows drivers made as secondary. So I would also recommend you to check for updates for those devices.

0 Kudos
Highlighted
Beginner
31 Views

I have just built a PC with a thunderbolt ready motherboard. I was having the same issues; my mac formatted thunderbay raid drive, was showing up as a "Base System Device" when I connected through the thunderbolt port on the PC motherboard. I got the chipset CD that came with the motherboard and "Installed All" (instALL) and a Thunderbolt icon appeard on my desktop. I followed the prompts, and now the drive mounts perfectly (after installing MacDrive Pro of course).