Intel® Desktop Boards
Peer-to-peer support only
11480 Discussions

DZ87KLT-75K no boot after BIOS update (0452)


Smooth install (AHCI). Only problem I had (for about a year) until updating to BIOS 0452 was occasional no boot with memory set at 1866. Since updating to 0452, the system would not boot to Windows and none of my HD's (2 mechanical and 2 SSD) appeared as possible choices. Pressing F10 at boot would not do anything, it seemed as if it was broken. Optical drives were showing in Legacy so I would have to put the Windows 8 disc in the drive and let it boot from that to access Windows.

Tried going back to prior BIOS, installation would not initiate. Since I had a lot work to do, I lived with it for a few weeks until I had time to unplug everything, reset it. Tried enabling "Boot to UEFI shell. I can now boot to my Windows SSD drive by pressing F10. I suspect that some of the boot settings may have changed in this version or got reset. What is Secure Boot? Should I enable it? What does Boot to UEFI shell does? Should I keep it enabled or not?

Which settings should I use to boot directly to my (AHCI) C drive?

0 Kudos
1 Reply


Let me help you with this.

Please note that Secure boot, if enabled, BIOS will boot to trusted Operating System images. The Internal UEFI Shell is a command console similar to a DOS environment.

Now if you would like to boot to the AHCI driver you need to have the UEFI shell disabled and if the Operating System was installed on AHCI mode then just make sure it is set as AHCI before booting up. In regards the Secure boot, you can also keep that one disabled and you should be able to boot up without any problem.

Kevin M