Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SGood2
Beginner
1,660 Views

DZ87KLT-75K

Jump to solution

First off, I just want to say how sad I am to hear that the DZ87KLT-75K is going to be Intel's last motherboard. I've owned several over the years, and they've provided me rock-solid stability to the point where I use them until they become obsolete with very few problems.

Just completed a new build this weekend and went to go get the drivers installed for this motherboard for Windows 8.1 Pro 64-bit, and it appears that most of the drivers are already rolled-up into Windows - cool. The three devices I'm having issues with are:

(All showing yellow exclamation mark in Device Manager.)

  • Audio Device on High Definition Audio Bus

Reinstall the drivers for this device. (Code 18)

To reinstall the drivers for this device, click Reinstall Driver.

HDAUDIO\FUNC_01&VEN_10EC&DEV_0899&SUBSYS_80862046&REV_1000\4&3B8CA585&0&0201

Attempting to install drivers (AUD_Win8.1_Win8_Win7_XP_6.0.1.7040) off of Intel site eventually gives:

Realtek High Definition Audio Driver - InstallShield Wizard

Install Realtek HD Audio Driver Failure !!

[Error Code: 0xE0000246]

And that error traces back to the following from Technet:

3758096966 (0xE0000246) Device Installer Not Ready

Cause

A class installer or a co-installer for a service cannot run because a component on which it depends did not run.

  • PCI Simple Communications Controller

This device is not configured correctly. (Code 1)

To find a driver for this device, click Update Driver.

PCI\VEN_8086&DEV_8C3A&SUBSYS_20468086&REV_04\3&11583659&0&B0

Attempting to install drivers for Intel(R) Management Engine Interface (MEI_Win8.1_1.5M_9.5.15.1730_PV) off of Intel site eventually gives:

The setup program failed to install one or more device drivers.

Setup will exit.

(Intel Installation Framework page shows "Installing Driver: Intel(R) Management Engine Interface - Version 9.5.15.1730")

  • SM Bus Controller

Reinstall the drivers for this device. (Code 18)

To reinstall the drivers for this device, click Reinstall Driver.

PCI\VEN_8086&DEV_8C22&SUBSYS_20468086&REV_04\3&11583659&0&FB

Attempting to install drivers for associated package (IDU_3.2.8.089 containing smbus drivers) off of Intel site eventually gives:

An unknown error has occurred.

Setup will exit.

(Intel SMBus window shows "Installing Driver: Intel PCH SMBus Controller - 8C22 (Intel SMBus 2.0 Driver) - Version 6.9.1.1")

The Audio Device is obviously the Realtek, because I had it disabled in the BIOS from the start prior to the Windows clean-installation, and only just enabled it after the second two drivers showed the driver failure in Device Manager.

I'm concerned, based on the errors I've received installing most (90%) of the drivers marked for Windows 8.1 64-bit on the Intel web-site under my motherboard, that I may be missing some crucial main chipset driver, which is holding all of these other drivers and software application packages back.

Here's my hardware configuration:

1) Intel DZ87KLT-75K Motherboard with: AA G74721-305 - BIOS is current: KLZ8711D.86A 2/17/2014 0450

2) Intel i7-4771 (Stock heat-sink and fan from retail packaging)

3) Seasonic X-Series Gold 80 850W Power Supply

4) Kingston Hyper-X 4x 8GB DIMMs (2x 1600 CL10 240-Pin UDIMM Kit - KHX1600C10D3B1K2/16G)

5) Four SSD (500/256/256/128), Two SATA 4TB Seagate drives.

6) XFX R9 280 Black OC Edition Graphics Card

7) Corsair Obsidian 650D with two 200mm fans, and one 100mm fan.

I've ran burn-in tests for an hour or so, and temperatures seem within the happy range on all devices monitored.

Please let me know how I can fix these errors, as I'd rather not put this system into production as my main workstation if I have to rip it apart to replace the mainboard.

Tags (2)
0 Kudos
1 Solution
Kevin_M_Intel
Employee
418 Views

Hi Amarand,

I'm sorry you are having problems with the motherboard but let me help you.

I personally have been testing this board model and I have not encounter any problem yet related to the ones you have.

Can you please try installing the chipset driver for the motherboard? It can be downloaded here:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23061 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23061

If you encounter any problem with the one above, can you try with this INF?

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775

View solution in original post

4 Replies
Kevin_M_Intel
Employee
419 Views

Hi Amarand,

I'm sorry you are having problems with the motherboard but let me help you.

I personally have been testing this board model and I have not encounter any problem yet related to the ones you have.

Can you please try installing the chipset driver for the motherboard? It can be downloaded here:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23061 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23061

If you encounter any problem with the one above, can you try with this INF?

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775

View solution in original post

SGood2
Beginner
418 Views

Kevin,

I was unable to install any drivers at all - every driver failed to install. So I backed things out and installed a fresh copy of Windows. That seemed to fix the driver install issue, but I had a bunch of hard system freezes (where sometimes even the reset button wouldn't respond!). I then decided to move data around and format all the internal SSD units one at a time, convert them to GPT, and make sure they were UEFI-compliant.

After installing all of the Intel drivers (successfully), and getting all of the Windows updates installed, I've only seen one or two hard-hangs, but I'm not sure how I'd go about troubleshooting the issue. I actually saw a red LED amongst the solid bank of green LEDs on the motherboard during one of the hangs, but didn't know how to read them. Any ideas?

Thank you,

--Sean

Kevin_M_Intel
Employee
418 Views

Based on your description it could be related to a problem with the system driver. Have you tried another HDD or ssd?

SGood2
Beginner
418 Views

Kevin,

I ended up resolving the issue with a complete reinstall of the operating system. I did more than just a reinstall: I deleted all the partitions and converted the primary SSD (brand new and tested) to GPT, and made it UEFI friendly. After installing the OS and updating everything, I did the same (moving data, complete format and diskpart clean, MBR to GPT convert) for each drive, and the system seems stable.

All drivers are up to date, all Windows updates have been installed. Although the system seems completely stable, I'm still getting a complete hard-hang (sometimes the reset button won't respond, just an ATX NMI on the power button) when I run Samsung Magician when it's scanning for devices.

As this problem only seems to occur during the execution of this program, I'll report it to Samsung and see what they can do.

Thanks for the assist!

--Sean

Reply