Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,329 Views

DZ87KLT-75k - USB3 front panel issue

I am running Windows 7 64bit on a DZ87KLT-75k / 4770 system.

When plugging an USB device (external hard drive, USB stick, etc...) to either one of the front panel USB 3 ports, the devices are not recognized correctly in Windows. The devices appear in explorer, are read and write accessible, however, the "Safely remove hardware" notification doesn't show, there is no "right click -> eject" option in explorer, and the Hardware "Policies" tab (to optimize for either quick removal or performance) is missing.

This is not the case when plugging to the front panel USB 2 ports, or the back panel USB 3 ports. I have tried with both USB 2 and 3 capable devices and cables.

I am using the 2.5.1.28 USB 3 driver, the problem was also occurring with the previous driver version. Forcing the list of plugged devices to show up using "rundll32 shell32.dll,Control_RunDLL hotplug.dll" also doesn't work. Well it works, but the drives are not listed if plugged in the front panel USB 3 ports.

Could this be due to a driver or hardware problem?

0 Kudos
3 Replies
Highlighted
Employee
4 Views

As you mentioned, this could be a software or hardware issue. In order to test your computer hardware will be to try another USB front panel, if this fails, I am afraid your motherboard requires service.

I recommend, contacting support lines at Intel.

Live Chat support at wwww.intel.com/chat and choose desktop boards line

Allan.

 

0 Kudos
Highlighted
Beginner
4 Views

Unfortunately there is only one front panel USB3 on the board. The 2.0 one I am using is fine.

Is there a known issue with the drivers maybe?

0 Kudos
Highlighted
Employee
4 Views

I am not aware of any issues with front panel and USB 3.0 ports. Try updating computer BIOS or wait for new drivers to see if this will be corrected.

Allan.

0 Kudos