Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AShen11
Novice
1,676 Views

Desktop Board DG41WV: Issues after upgrading to Win 8.1 (32-bit)

I have had this (Desktop Board DG41WV) board for more than two years.

While I was using Win XP, there was never any trouble.

However, after upgrading to Win 8.1 (32-bit), a number of issues have been cropping up.

(1) The driver CD can no longer run - the software loads, but then it says something like 'this system does not have an Indel Desktop board'.

(2) The on-board LAN is not even being read by device manager.

But otherwise, the system seems to be working properly - barring the fact that I cannot use the on-board LAN. (The the LAN signal lights - both green and amber - come on as soon as I turn the UPS power on, even before I power-up the system)

Could this be a software/ driver issue? Or, has my on-board LAN shorted-out?

I see on this page: "Desktop Boards Microsoft Windows* Hardware Quality Labs (WHQL/WHCK) Information" - my board shows a *BLANK* in the Windows 8/ 8.1 column.

Does that mean my motherboard will NOT WORK PROPERLY with Win 8.1?

[I downloaded the 'latest' BIOS from the Intel site - but when I tried to run it, a message said I was 'about to update with the same version' - so I stopped. Should I try updating with that in any case?]

0 Kudos
8 Replies
n_scott_pearson
Super User Retired Employee
228 Views

Aaditto,

The Drivers CD will not run on Windows 8.1. Yes, this is probable true; it was never intended to work on that version of Windows. At the time that the CD was released, Windows 8.1 was a far-off glimmer in the future. But let's be clear, the Drivers CD contains the most recent versions of drivers available at the time that the board was released. By the time that this board and CD were in your hands, the drivers on the CD were likely already out of date. The CD is only provided to allow you to get Windows running. Once running, you are then supposed to get and install newer versions of the drivers from Intel's Download Center web site. Yes, this is a manual download-and-install methodology; the only alternative is going to be Microsoft's Windows Update.

OK, all of that said, the problem you next run into is that, at the driver downloads web page for your board, there are no drivers for Windows 8.1. The last officially-supported O/S for the DG41WV board was Windows 7. All is not lost, however. Windows 8.1 versions of the drivers for many of the silicon components on your board are available from alternate locations. In fact, you should have had these drivers made available to you via Microsoft's Windows Update service. They may not have installed automatically, however; you should run the Windows Update applet on your system and check whether updated drivers are available as optional downloads (i.e. you have to approve them being downloaded and installed).

Next, let's talk about the LAN issue. Like other components, a driver update should have been made available via Windows Update. If, after installing the optional driver packages (as detailed above), the LAN is still not working, you can try to use a later one from somewhere else on Intel's downloads site or you can try to find and download one yourself from Realtek's site. I found one on Intel's site that might work, but no guarantees; it is there for a much, much newer product and might not have support for silicon as old as yours. If you want to try it, here is a link to its download page: https://downloadcenter.intel.com/download/25051/LAN-Realtek-LAN-driver-for-Intel-NUC https://downloadcenter.intel.com/download/25051/LAN-Realtek-LAN-driver-for-Intel-NUC. If it works, great. If it doesn't, you should look for a better alternative on Realtek's web site.

Regarding your "WILL NOT WORK PROPERLY" question, there is no definitive answer. If Intel does not say that they support a particular Windows version, it doesn't mean that it won't work; it just means that Intel is not going to do any testing to find out. Further, because they won't do any testing, they won't explicitly make drivers for that version of Windows available (doing so would imply that it will work with that version of Windows and that would create a support liability for them). In all this, it doesn't say anywhere that it won't work; it just says that you are on your own if you want to try.

Last comment: This board is really, really old. It was released in 2008/2009. It wouldn't surprise me if some of the silicon components - like that for LAN - are starting to fail. It's time to think about getting something newer. Yes, I know; that takes money that you might not have. I can sympathize but I can't really help you there.

...Scott

AShen11
Novice
228 Views

Scott,

Thank you very much for your detailed response.

I had started my post with a brief description of my issue - but now that you have stuck your neck into the quagmire, let me bombard you with a more 'complete picture'!

  • Let me begin with your last point...

     

    I know, it is indeed a rather 'dated' system - but unfortunately, I run a non-funded rural-development organisation, where every penny, literally, punches a hole into the finances - and so, I have to try and see if I can revive this unit to a functional state, before I think of chucking it.

     

    One clarification, when you say "This board is really, really old. It was released in 2008/2009. It wouldn't surprise me if some of the silicon components - like that for LAN - are starting to fail", are you saying that the components are too dated, and therefore there are compatibility issues - or rather, do you mean that the components would have worn-out due to wear-and-tear, after so many years of usage?

     

    If it's the first, then yes of course that's a valid point - but as I said, I still have to give it a shot.If, however, it's the second case - well, we have used this board for just about 18-months or so! That's not a lot of wear-and-tear, is it?There are a lot of computer components, especially the ones which are going obsolete in the 'first-world', which float up at markets in the 'third-world' at much cheaper prices.
  • Now, even though I am not a computer geek at all, I have been fiddling-around with both hardware and software for long-enough (I tend to have the DIY-bug biting-away on an overdrive) to know that driver CD's tend to get backdated.

     

    So, the first thing I did was look for - and try to run - 'updated' versions.I began with trying to do a BIOS update - as the system was refusing to load, every now and then (after a series of power-outs) - and the BIOS screen was not displaying the MoBo details (it still isn't) - but showing the processor-details fine.

     

    So I downloaded the 'latest' BIOS from the Intel support-page for my MoBo. When I went to run it - a pop-up said something like 'you are trying to update with the same version' - and I thought it wise to hold-back!

     

  • I am wondering, should I run that 'latest' version of the BIOS I downloaded, ignoring the 'same version' prompt? That cannot harm anything, can it - provided I ensure that there isn't a power failure during the process??!

     

  • Next, I downloaded and tried to run the 'latest' Realtek driver for the MoBo - both from the Intel page, as well as the Realtek page. The driver installation failed - in the exact way that it had failed when I was trying to run it from the CD. Here's what happens...
  • I had tried to load the LAN drivers in the software CD provided with the Mobo earlier - but that had repeatedly failed - with the same issues recurring every time.

     

     

    Now I located my particular LAN (model) controller on the Realtek site - and found that there was a Windows 8/8.1 specific versions of the driver package - which I downloaded.

     

     

    But the exact same issues were repeated when I tried to run this new driver!

     

     

    What happens is this:-
  • The Realtek driver install window opens> 1st screen asks me whether I want to *Install/Repair/Remove* the driver (I have tried both Repair & Install, after Remove)> Installshield wizard starts the process, (the *Remove* works smoothly) copies 'updated files', with a top-note saying *...is repairing Realtek Ethernet Controller Driver* > then it begins to 'search for a Realtek Network controller'...

     

     

    ... AND, DAMN! A new pop-up opens - with the message *The Realtek Network Controller was not found. If Deep Sleep Mode is enabled Please Plug the Cable*

     

     

    [I have, of course, tried with the LAN cable (functional, tested with other system) jacked-in - with the same effect!]

     

     

<...
n_scott_pearson
Super User Retired Employee
228 Views

Ugh, where to start...

  1. I mean both. First, there may be issues where components are so dated that Intel and Microsoft have stopped supporting them. Second, motherboard components degrade over time, even if the board is in a box, on a shelf, and not powered up. Sockets (PCI, etc.), for example, can suffer from both stress relaxation and corrosion. Stress Relaxation - contacts losing their spring - can cause intermittent electrical contact. Corrosion (oxidation) can also cause intermittent electrical contact, but worse can be the buildup of electrical resistance.
  2. Flash can also degrade and, eventually, lose its contents. With a board this old, it may be worth it to take the time to over-install the BIOS, even if it is with the same version. I worry, however, that what you are seeing is corruption in a part of the flash that is not touched by the BIOS install (or over-install) operation, namely that area that contains the board's identification information. If this is corrupted, problems like what you are seeing with the Driver CD and the Board Id tool could occur. The Express Installer program is looking for certain information that identifies the board as being a specific Intel Desktop Board before it will support driver installation. We need to check this out this possibility. In the menu on the main BIOS Setup scene, there should be a selection titled "Additional Information" (unfortunately, I can't remember whether the BIOSs we did for the 4 Series boards had this capability). If its there, select it then write down and send me all of the information that is displayed. If this is what you were referring to with the "BIOS screen was not displaying the MoBo details (it still isn't)" comment, then we may be in trouble already
  3. For a board this old, unless they've dropped support for them, I would expect that Windows Update (if not the Windows 8.1 installation package itself) would have drivers for all of the hardware on your board. Sometimes, in a Windows upgrade operation, if an old driver was there and is removed, a compatible new one isn't installed. The only way to tell absolutely would be to do a from-scratch install of Windows 8.1 and then check to see whether there are any components that didn't have drivers installed for them. Warning: sometimes, driver updates only appear as recommended updates; you definitely need to check all update types.
  4. Finally, many of the newer driver packages, like the one I pointed you to, do indeed indicate Windows 10 support. But, these packages are also the correct and latest ones for Windows 8.1. Just be careful to check that it is not one for Windows 10 exclusively.

I think I addressed everything. Let me know...

...S

AShen11
Novice
228 Views

Thanks a tonne, Scott - you are an angel!

Well, off the top, as far as I can remember, that's where I had not found the MoBo details... the BIOS section called "Additional Information"! I'll check and get back to you.

Oh, okay... here's another (section of a) post of mine, from another help forum...

APPARENTLY, MY BIOS DOESN'T READ MY SYSTEM/ MOTHERBOARD AT ALL!!!

  • In the BIOS menu...

     

    Advanced> Hardware monitoring> (values are being displayed for) Processor thermal margin/ Motherboard temperature/ +5v, +3.3v, +12v/ Processor voltage etc...
  • But, in the menu section...

     

    Main> Additional system information> System information/ Desktop Board/ Chassis Information sections ~ Manufacturer/ Product name/ Version etc ~ ALL SHOW *BLANKS*!

     

    (My MoBo seems to be an 'OEM version' - and I think I read in an Intel support page that 'third-party' modifications may exist in such boards)

     

     

So, that's BAD news, huh?!

 

Here's another thing that has been bothering me...

As soon as I turn on the UPS power, when the MoBo power-LED comes on, (before i hit the system power button) - both the signal lights above and below the LAN port come on - and stay fixed - one amber and one green.

Is that normal?

Ii mean, shouldn't the signal lights come on once the system loads - or, more logically, once the network has a connection?

Would this suggest that the LAN-card is shot?

AShen11
Novice
228 Views

Okay Scott,

I think I'll follow your advise and " take the time to over-install the BIOS, even if it is with the same version"...

[Please do see my earlier update below, before responding to this one...]

However, the Readme file that's packed with the downloaded ('latest') BIOS update has a few points which are worrying me...

  • Your system must be based on an Intel(R) motherboard, 810 chipset or greater>

     

    The fact that my MoBo is an OEM version, where, as per Intel's web notification, 'modifications might exist', would not be a hindrance to the BIOS update so as to wipe out the older BIOS but not be able to load the new one??! 

     

  • Your system must have one of the following operating systems installed:

- Microsoft Windows 98

- Microsoft Windows 98, Second Edition

- Microsoft Windows NT Workstation 4.0 with

SP 4.0 or greater

- Microsoft Windows 2000 Professional

- Microsoft Windows Me

- Microsoft Windows XP Professional

- Microsoft Windows XP Home Edition

 

Note: Intel Express BIOS Update does not support any Microsoft Windows server operating systems.

 

The Windows 8.1 OS is not going to be an issue? 

 

  • TROUBLESHOOTING INFORMATION

     

    ==============================

     

    Here are some of the more common error messages and possible causes and recommended resolutions for those messages.

     

     

    Same BIOS --

     

     

    Error Message:

     

    The BIOS version you are installing is the same as your current system's BIOS. Do you want to continue?  [Which is the exact message I get]

     

     

    Possible Cause:

     

    The BIOS you are trying to update is the same as the BIOS you currently have in your system.

     

     

    Recommended Resolution: Do not perform the BIOS update. If available, get a newer BIOS update from this Intel Web site: http://developer.intel.com/design/motherbd/ http://developer.intel.com/design/motherbd/

     

     

    SO, SHOULD I ACTUALLY GO AHEAD WITH THE OVER-INSTALL - DISREGARDING THESE ISSUES??  ALSO, SHOULD I MAKE A 'BACKUP COPY' OF MY EXISTING BIOS, BEFORE TRYING THE OVER-INSTALL? IN CASE THE NEW ONE DOESN'T LOAD - AND IF SO, HOW CAN I MAKE SUCH A BACK-UP?

 

 

Thanks again,

Cheers!

n_scott_pearson
Super User Retired Employee
228 Views

Sigh! It amazes me sometimes how folks can get off on tangents. I sure wish Intel's documentation was written so as not to be ambiguous and subject to incorrect interpretations. This is what happens when engineers write documentation...

OK, let me start at the beginning and explain a few things...

First, regarding OEM BIOSs...

It's true that Intel, at times, has produced custom BIOS releases for specific boards for specific OEM customers. In most cases, these custom BIOSs were just the standard BIOS with a few configuration parameters (and identification strings) set to specific values and locked so that they cannot be changed. Regardless, whenever Intel has done this, they changed the BIOS identifier so that the BIOS can only be updated with later versions of this custom BIOS (distributed only by the OEM, not Intel). If the board you have is indeed running a custom BIOS, you will not be able to update it using any release of the standard BIOS.

To know whether this is the case, you can send me the BIOS identifier string and I will tell you (or you can do it yourself; read on...) -- or you can simply make the attempt to update the BIOS and it will tell you if it cannot do so because there's an custom BIOS present. Actually, I am pretty sure that you don't have a custom BIOS because your previous attempt to update it would have failed with a message saying incorrect BIOS, not one saying same version as you saw. So, bottom line, I am saying: Yes, try to install the latest BIOS - and force it to do an over-install if necessary.

Next, let's talk about the system information strings (what is displayed in the Additional Information scene in BIOS Setup)...

Intel's BIOSs adhere to a specification called the System Management BIOS (SMBIOS) Specification. This specification details a set of required and optional data structures that the BIOS can (or should) expose (to manageability software) that detail the board and system's hardware, capabilities and identifiers. For our discussion, what's important are the structures that provide information about the BIOS, the board, the chassis and the system. In each of these structures, string fields are maintained that provide specific information:

About the BIOS:

Manufacturer (will be set to "Intel Corp.")

Version (a string of form XXXXXXXX.YYY.ZZZZ.ZZZZ.ZZZZ.ZZZZ, where YYY will be "86A" if its a standard BIOS)

Release Date

About the Board:

Manufacturer (will be set to "Intel Corporation")

Product (in your case "DG41WV")

Version (a string of form "AAXXXXXX-YYY" where XXXXXX is board design number and "YYY" is stepping number)

Serial Number

About the Chassis:

Manufacturer

Version

Serial Number

Asset Tag

About the System

Manufacturer

Product

Version

Serial Number

UUID (the UUID is technically board-specific. In some cases, Intel actually sets this field to a true value in the factory before shipment)

Now, remember that the product Intel is (was) producing is a board. At the point of shipment, Intel will not know anything about the chassis or the system that will ultimately contain that board. Consequently, these strings will be left blank (or set to a placeholder values). Intel provides tool(s) that system integrators can then use to fill in these chassis and system string fields as they design and build their systems. Some integrators are sophisticated and they regularly use the tool(s) to fill in these strings. Others are unsophisticated and they leave them blank. Obviously, for anyone purchasing a boxed board, they are going to be blank as well. In later years, Intel made available a tool (Intel Integrator Toolkit) that integrators and end users can use to set these strings. Note that most of these strings can be set and then locked down so that, for example, an end user cannot wipe out a system integrator's settings.

Summarizing, in most cases, the Additional Information scene in BIOS Setup will display the strings for the BIOS and for the board but the strings for the chassis and for the system will usually be blank. Only in system-level products from sophisticated integrators will these other strings be populated (give or take the few end users who have taken the time to fill them in). In your case, you concluded that, because you saw only blanks in these strings, you had an OEM board. This is definitely not the case.

OK, now I will answer some of your ancillary questions...

Because Intel's on-board (wired) NICs can be used to awaken a system (even from the S5 (off) state), any time that you provide power to the board (and you do so when you plug it into the wall; there is a standby current that is always provided by the PSU specifically to provide power for capabilities like this), the NIC will receive some of this power and the LEDs will light up. Now, the activity LED is supposed to be flashing based upon the amount of traffic occurring on the LAN, even in this off state -- but, because of the persistence time for this LED, it could appear on all of the time if sufficient traffic is happening between other systems on the LAN. Regardless, this is NOT a conclusive indicator for the NIC being broken!

There is no facility provided to make a backup of the BIOS - but, if you need to, you can download previous versions of the BIOS and install them if you don't like a newer one that you have installed. Note, however, that you usually have to use the recovery methodology to install previous versions of the BIOS. There are also some cases (but I don't believe this applies to your board) where, once you install past a certain BIOS version, you cannot install - even via recovery - a version previous to that certain version.

Now some recommendations...

A problem that people run into is that successfully booting their system requires that certain BIOS parameters be set to certain values. For example, if you have the boot mode set to AHCI when you install Windows, you will not be able to boot Windows if this parameter is later changed to (Legacy) IDE. The setting of the UEFI parameter can similarly affect your ability to boot Windows. Now, in some cases, because of the extent of the changes (enhancements and bug fixes) that are included in a particular BIOS update, the installation of this BIOS update will reset some or all of the BIOS Setup parameters to their defaults. If your settings for these parameters were different from the defaults when you installed Windows (or whatever other O/S), this could cause your system to suddenly not be able to boot. You thus need to write down the values for these parameters when you install Windows (or whatever other O/S) so that you can ensure that they are set properly after you install any BIOS update(s).

In a similar vein, if you install a previous version of the BIOS, the settings for some parameters could be corrupted (I could spend hours explaining this -- but won't). It is thus imperative that, if you install a previous version of the BIOS, you immediately go into BIOS setup and (1) use F9 to ensure that all parameters are set to their defaults and t...

AShen11
Novice
228 Views

Hello Scott,

You end your last note saying, "I hope that this is all clearly understood. I took a lot of shortcuts in my explanations to shorten the length of my response (and the amount of time it took me to put it together) -- and I am an engineer and, while I think I am better than most, I admit that I am NOT a trained technical writer."

Well I have been (an artist by training, but) a teacher, as well as a designer and writer for media/advertising for a number of years, and I assure you that I have rarely come across such concise and yet meaningful and understandable technical writing - or just plain communication, for that matter!

By the way, thank you again, for going to all this trouble and bearing with my non-technical keeg ignorance. This repair-attempt is proving to be quite a learning curve for me – thank you for that too!

 

Apologies for the tangential digressions - I am too damned dumb in this department to know which information is relevant and which is not - and so, I am ending up offloading everything I can think of - for you to pick and choose!

Please don't feel 'obligated' to persist with this - I will more than understand if you choose to opt-out of this remote 'tutoring'! (I am totally loving you for your help - but I know you are spending precious time on this, when you really don't need to!)

 

 

In your 'recommendations' you mention (something that I have also been reading in a number other articles, over the past few days)…

"A problem that people run into is that successfully booting their system requires that certain BIOS parameters be set to certain values. For example, if you have the boot mode set to AHCI when you install Windows, you will not be able to boot Windows if this parameter is later changed to (Legacy) IDE. The setting of the UEFI parameter can similarly affect your ability to boot Windows."

 

I see the point.

But is there any possibility that the O/S would load, but functionality (such as the ability to read the LAN card/ load drivers etc) would be hampered, if the BIOS settings have not been brought back to their original specs?

 

Here's why I ask:-

 

[At the moment, my Windows 8.1 O/S loads successfully]

However...

 

(I thought I had mentioned the following to you earlier – I should have – but that was actually in another forum!)

 

My 'troubles' actually started with the BIOS not loading at all – every now and then – with the three-long-beeps memory-fail signal coming on.

 

This started after some of our rural-staff got confused with the new 'start' in Windows 8.1 and repeatedly shut the system down with the UPS power-button, while I was away from the project!

 

And whenever the system did load – which it did, every now and then – the POST screen displayed the CMOS Checksum & Battery Failure errors.

 

I reset the CMOS jumper (a number of times)… checked the RAM (one DD3 2GB installed on one of the two ports) and battery to make sure they were sitting properly… moved the RAM to the other port… checked the battery with a multimeter – (outside the dock) was displaying 3.02V… finally, checked the RAM in a friends computer, where the OS read and displayed it fine!

 

None of this seemed to work.

The system loaded now and then (though always with the checksum error), but failed every now and then too, with the three-long-beeps coming on.

 

Finally, with one of the many rounds of following the same routine –

 

Remove power from the system…

 

Hit the power button to discharge the capacitors…

 

Move the CMOS jumper to the clear position…

 

Remove the battery from the motherboard…

 

Wait for a few hours…

Replace the battery…

 

Check that the RAM & battery are housed properly...

 

Place the jumper back in the normal position…

 

Restore power and boot up…

 

– suddenly, eve...

n_scott_pearson
Super User Retired Employee
228 Views

Aaditto,

Thanks for the praise. Despite being retired now, I spent 21 years at Intel and I still feel an obligation to help customers who used the products that I was involved with. I enjoy doing so. It keeps me off the street (so my neighbors are happy).

Here's my responses...

You said "...I see the point. But is there any possibility that the O/S would load, but functionality (such as the ability to read the LAN card/ load drivers etc) would be hampered, if the BIOS settings have not been brought back to their original specs?"

Well, when you condition the question with "back to their original specs", my short answer is: No, none that I can think of. There are the parameters that I already mentioned (Drive Configuration/SATA Mode & UEFI) that, if not set to the settings that were in place when Windows was installed, could cause Windows to not load (or, in some cases, Blue Screen during load). There are other parameters whose setting causes some feature/device/technology (LAN, Audio, 1394, Serial Port, USB Port, SATA Port, Consumer IR, etc.) to be disabled, but this results in the device not being seen by (not existing within) Windows. There are performance parameters (Clock Multipliers, etc.) that could cause the processor or memory to not function properly/reliably. In all cases, however, it requires changes away from the defaults to cause things to go awry.

Damn, I just thought of one contrary example: I have some memory that requires that the voltage be manually set to 1.7V. If you try to run with the default settings (which set the voltage to 1.5V), the memory will not function reliably and this will cause Windows to not load properly or have random crashes. Now, in this particular case, the problem was that the memory's SPD (configuration data) has a bug in it; it did not tell the BIOS that 1.7V was actually required. This is an example of a bad third-party product causing our board to look bad when it actually isn't.

You said "...Well, it seems like I have already goofed-up in that department!? I don't know whether any of the parameters were different from the Defaults originally!"

If you had them wrong, typically Windows won't start up. I consider it a pretty telling indicator that you have them as they were. I can think of no case where they could be different and you still get into Windows successfully (can anybody else contradict this statement?).

You said: "...My 'troubles' actually started with the BIOS not loading at all – every now and then – with the three-long-beeps memory-fail signal coming on. This started after some of our rural-staff got confused with the new 'start' in Windows 8.1 and repeatedly shut the system down with the UPS power-button, while I was away from the project! And whenever the system did load – which it did, every now and then – the POST screen displayed the CMOS Checksum & Battery Failure errors."

I am not an EE (you EE's out there correct me if I say something wrong). Hard power-offs, if done often enough, can eventually cause physical damage. No one should ever be turning the system off at the UPS; they should be doing so at the system's PSU (i.e. via its power button). I cannot say with any certainty whether or not the appearance of the "Battery Failure" and/or "CMOS Checksum" messages is caused by these hard power-offs. If I ever see either of these messages, regardless of anything else, I replace the CR2032 battery. If you replace the battery and the problem then reoccurs, I would then be concluding that there might have been a hardware failure. The three long beeps is an indication that the BIOS was unable to configure the memory and get it to operate properly. I have seen the odd case where this occurs and there's nothing wrong with the memory or the board, but 99% of the time this is an indication of a problem in the memory. Could it be failing as a result of the hard power-offs? Yes, it's certainly possible. but I cannot say for certain.

You said: "...I found ALL THE VALUES in the 'Additional System Information' section of my BIOS screen were displaying *BLANKS* (Not just the chassis and the system, as it seems you have supposed)."

If the Additional System Information scene has a section in it titled "Desktop Board Information" and the strings are blank, this usually means that the board's flash component has been corrupted. Many Intel tools, in order to identify that it is running on an Intel product, will expect the contents of the Board Manufacturer string to contain sub-string "Intel" (as in "Intel Corp." or "Intel Corporation"). Others expect the Boa...

Reply