Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,061 Views

Disabling onboard audio DZ77GA-70K

Greetings all. Just installed my DZ&&GA-70K board, disabled the onboard audio in BIOS, and Windows 7 64 bit still detects the onboard audio. My Creative X-FI is producing no sound - I suspect (but don't really know) that's the reason. What am I missing? If the hardware is disabled in BIOS, why is Windows still detecting it, and what can I do to completely disable it?

0 Kudos
5 Replies
idata
Community Manager
50 Views

From Windows:

Click the start button and type

computer management

in the search dialog box ( means press the "enter" key).

Click on "Device manager"

Click on the little arrow immediately to the left of Sound, video and game controllers.

what audio devices are listed in this subcategory?

You can unload/inhibit the software associated with any device in this subcategory by right-clicking on the device and selecting "disable" from the menu. Do not select "uninstall" as Windows will detect the device on the next boot and reload the software automatically.

idata
Community Manager
50 Views

Alternately you can go to Control Panel > Hardware and Sound > sound and you should see two playback devices on the playback tab. From here you can choose default playback device. You may need to configure your preferred device.

idata
Community Manager
50 Views

Before I go on... I did get sound to work - it was a bad cable :-p but the fact remains, one would expect the onboard sound to NOT be detected by Windows if it has been disabled in BIOS.

I know how to use Device Manager, and I know I could disable the hardware there... and I did - but why is it even still being detected?

idata
Community Manager
50 Views

Because Windows does detection and initialization of certain devices, like sound, independently of the BIOS during IPL.

idata
Community Manager
50 Views

>>Because Windows does some hardware detection and initialization independently of the BIOS. But, you knew that.<< No, I didn't know that, and that has not been my observation.

Reply