Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
3,412 Views

Dz68db motherboard installation and compatibility

Hi,

I have this issue where I bought a dz68db motherboard and I stalled it correctly I think... I have ddr3 ram from g skill 4 gb and an intel celeron 2.5ghz CPU, with an EVGA GeForce 9500gt series graphics card... Power supply of 750 watts by ULTRA. I configured it all right I think and I turned it on for about 15 seconds and then shuts off... No BIOS, no nothing... Please help me and I don't know what I did wrong I I don't see anything when I turn the system on and when I tried to move the ram, and unplug the unnecessary components, the plug where the psi connects to the motherboard started to smoke up so I turned off the power immediately and unplugged it... Other than that, all looked good... The standby light was on and I am really confused

0 Kudos
10 Replies
158 Views

Hi Danny, Looks fine with respect to compatibility of Board and Proessor. Not sure what is the speed of the memory you are using. Use DIMM 1 slot, if you are using only one stick.

158 Views

Hi Danny, wrt compatibility it is fine. Try using DIMM 1 slot if you are using only one stick. Can you see intel logo once you switch on the system. Thanks, - Ravi

idata
Community Manager
158 Views

 

no... the intel logo did NOT show and my monitor has no signal shown in the screen... the computer would simply turn on, fans run, gueassing processor working, without the graphics card in, and i still didnt get anything... after about 10-15 second later, just like it turned on, it shut down... and now it has smoke as told before...
158 Views

Hi Danny, it is surprise why the smoke ! Please call local Intel Tech Support and get help Immediately.

 

idata
Community Manager
158 Views

none of the help worked but the ram slots were in the wrong slot... i had them in dimm 3. i put it in dimm 1 and it started to smoke... really confused... i go to a technical school and bringing the computer there to get help... i have all the parts and if its the motherboard, what do i do? i bought it off of ebay, and do i talk to the company that sold me the motherboard or do i talk to intel? i dont know who to talk to and i am really hoping its nothing really serious...

idata
Community Manager
158 Views

alright... i found what was wrong.. the outlet was bad and it all works now, but after a little researching, my motherboard is dead... no beeps, no bios, no video, i didnt even get to flash the bios at all... it was a brand new motherboard and is it possible if i get a new motherboard at all? i bought it from ebay and the seller cant take it back because of the 15 day policy... is there anything i can do to get a new motherboard??? i didnt break it... i dont think so anyway...

idata
Community Manager
158 Views

Even when i first got all the parts, and plugged it all in the first time, i still got no beeps so there had to be something wrong with it when i first got it...

ZAgha
New Contributor II
158 Views

Danny just relax & RMA the BOARD

Try not to mention anything about the bad outlet thingy or the smoke thing also. Just tell them you installed everything & it didn't boot. I would also check the cpu if its working also.

As long as there is no physical damage to the board itself they are OBLIGED to replace it.

Everything can be fixed don't worry

I didn't get what you exactly mean by outlet. In the future, be careful of static electricity. Also test the PSU

158 Views

Hi Danny,

Did you get RMA for thsi board. If not please approch your local Intel support center

Thanks,

- Ravi

Reply