Intel® Desktop Boards
Peer-to-peer support only
11479 Discussions

External HDD firmware update made my system unbootable


After updating the firmware of my external HDD WD My Book, my toshiba laptop with a toshibainternal HDD, is no longer able to boot and I can't enter the BIOS either. The internal HDD has three partitions, two with Windows 8 and one automatically created and reserved for the system. This message appears after the toshiba logo leaves the screen:

Intel UNDI, PXE-2.1 (build 083)

This product is covered by one or more of the following pattents

US5,307,459, US5,434,872, US5,732,094, US6,570,884

US6,115,776 and US6,327,625

Realtek PCIe FE Family Controller Series v1,27 (10/31/11)

PXE-E61: Media text failure, check cable

PXE-MOF: Exiting PXE ROM Reboot and Select proper Boot device or Insert Boot Media in Selected Boot device and press a key


If I may, I would like to know how to make my system boot from my internal HDD as before, and if(and why) a firmware update of an external hard drive produced this situation. It seems weird to me but I can't figure out another explanation. I tried to fix the problem with Intel ME FW Recovery Agent but it is not able to connect to the internet (though I have conexion).



  • The system boots from a Live USB with Ubuntu, GRUB is loaded and it allows me to choose windows as the OS. I have two windows installed in two different partitions and I can work on both of them properly. Both the Ubuntu USB and the internal HDD are MBR formated, but Ubuntu has ext4 and Windows NTFS. In the internal HDD the system reserved partition is marked as active (0x80).
  • The pc does not boot from a USB Windows 8 Installer. This is the USB from which I installed the current SO. Using an hex editor, in both the Windows USB and internal HDD, I can see the same message written just before the code of the partition table:
Invalid partition table. Error loading operating system. Missing operating system.
  • BIOS setup was to boot from a HDD first, USB was second, I enabled fast boot, intel ia was enabled (I don't remember the exact name of this option).
  • If I disconnect the internal HDD the system does not boot from the Ubuntu Live USB.

I must say that I strongly believe that before this happened I already have updated all the drivers and restarted the computer after that. But as I did that so many times I think I need to comment just in case I wasn't right, and this may be consequence of a driver udpate. I belive that the last driver I installed was the Intel Managment Engine. What I do know is that the BIOS version was not updated (it was the last version available) and that the Intel Chipset SW Utility was installed.


Technical data:

PC: Toshiba laptop P850-31M

Operating system: two partitions with Windows 8.1 Pro. There is one automatically created partition for the system called "system reserved partition"

External updated Hard Drive: Western Digital My Book 1230 SN: WCC4E1476734

Firmware: updated from default to v1.065 using WDFirmwareUpdater (official)

Processor: 3rd generation Intel® Core™ i7-3630QM with Intel® Turbo Boost Technology 2.0

0 Kudos
2 Replies

I solved the problem. I installed a manufacturer system settings program, which allowed me to acces the BIOS from the operating system (Toshiba S. Then I changed the order of search for operating systems and put the USB first. When I did this I recovered acces to the BIOS as usual. I still couldn't start the system from the internal HDD. Then in BIOS settings I changed the boot configuration from CSM to UEFI and then I changed it again. Everything worked fine again. I have no idea of what the error was nor why it was fixed by doing what I did. I can especulate but I don't know what happened.


Something on the update may have changed the Boot settings but it is good to know it is working now. Thank you for sharing this with the community.