Showing results for 
Search instead for 
Did you mean: 
Community Manager

F2 doesn't work on DH77EB bios update 0089

Hi all,

I'm hoping I can get some help here. I have a fairly standard build, nothing out of the ordinary:

Intel DH77EB

Intel Core i7 3770

Intel SSD 520 240GB

8GB DDR3 1600 RAM (Corsair)

No graphics card

I've had bios version 0075 for a while with no problems whatsoever.

A few days ago, I updated to bios 0089 and the update worked fine, I was able to boot into Windows 7 64-bit without issue. The problem I have is that I can't access bios anymore (by F2 or by holding down the power button). Both F7 and F10 work fine though, I'm only unable to enter the bios.

I reverted back to bios version 0075 and was able to use F2 once again. I thought maybe I had some custom bios options that were creating problems between the 2 bios versions so I reset the bios to default values and attempted the update to 0089 once more. Again, update succeeded, able to enter Windows 7 with no problems, F7 and F10 work but can't enter the bios.

I am now back on bios 0075 and I'm able to enter bios just fine. Surely this is a bug and not a problem with my setup right? I don't know what else I could try?

0 Kudos
6 Replies
Community Manager

Does your F10 ,menu include a 'enter bios' option? If so, does that work?

If you start pressing F2 several times during the showing of the prompts and for at least one press after the prompts disappear off the screen, does that work?

I had this probem on a DX79SR board when a usb device was plugged into a front port, or rear port, can't remember for sure atm.

Community Manager

Pressing F2 only brings me back to the prompt screen after a few seconds of the screen going blank. I think at a certain point the prompts don't come back but continuing to press F2 only results in a blank screen. Last time I tried, I kept pressing F2 for about 2 minutes... once I stop repeatedly pressing F2, the system boots into Windows 7.

And no option to enter bios from F10.

Even if it is a usb device (which I'll try), it seems to me like they broke something since it works in the previous bios. Where is the right place to report bugs so that they fix it in the next release?

Community Manager


Here is the same problem.

I did a Bios update on my DH77EB from 0053 to 0097

The update run to the end of procedure ok, but my

USB-Keyboard has no funktion during the startup (nothing Key is present, no F2,F7,F10)

but when the OS (linux) runs it funktions ok (all Keys at the Keyboard are present)

On Bios 0052 works the Keybord fine and i came with F2 in the Bios Menu

What is the best way to fix this problem ?

Sorry for my english and thanks for any advice you can give me.



Hi Stephane,

I have the same problem.

Updated BIOS to version 97 and from that point onwards F2 has stopped working.

F7 and F10 do work properly.

F2 does NOT.

No response whatsoever, only a blank screen.

Hope Intel engineers solve this soon.




Hi Stephane.

I have F2 working again.

For problem description: see earlier my post.

Solution / work around:

Changed 2 things:

1) monitor with better (more natively supported) resolution.

My guess is the F2 - screen did not `fit' the display I was using, causing a crash.

I also guess this change solved the issue for me.

2) (probably not the solution, but a change I made anyway): changed from hdmi to dvi (?) cable.

I now have the latest BIOS working (00097?. today is november 27th 2012) flawlessly.



Community Manager

bump (also intel 3770, dh77eb bios max at 0071, higher: no F2)