Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,110 Views

HD 4600 HDMI audio disappearing, windows 10, driver issues

Jump to solution

Hi,

I have a htpc that I built for our living room and whenever I turn the TV on/off the HDMI audio disappears from the list of playback devices. It only shows up again if I reboot. It's a huge problem for a htpc.

I had this issue before on windows 8, and the issue was resolved by updating to the latest bios for my motherboard (ga-h87tn). At the time there were a lot of people having this issue, all seemingly resolved with bios updates. However, now that I have updated to windows 10 and the latest drivers, the problem is back.

I've tried a handful of drivers, and only one, a really old one works (v9.18.10.3257), It has some graphical glitches with windows 10, and I can't use it even if I wanted to because windows keeps pushing new driver updates to me, overwriting it. I'm assuming there must be a problem somewhere with the new versions of the driver.

Has anyone had a similar experience with HDMI audio on Windows 10? Any solutions?

My hardware, for reference:

- Gigabyte GA-H87TN (bios v6)

- i5-4570s (HD 4600)

0 Kudos

Accepted Solutions
Highlighted
Super User Retired Employee
17 Views

You've posted this query in the support forum for Intel's Desktop Board products. You will likely get better traction if you post it in the Graphics forum.

My personal take is that, if the problem is happening when the PC is completely awake, then the BIOS likely has nothing to do with the issue. It is not involved in the normal runtime operation of the PC at all; it only becomes involved when the system is transitioning into or resuming from a low power state (S3/S4/S5). If the problem is occurring while the PC is completely awake, the problem is likely within the graphics driver - yet another reason to be looking to the Graphics forum for advice...

...S

View solution in original post

0 Kudos
4 Replies
Highlighted
Super User Retired Employee
18 Views

You've posted this query in the support forum for Intel's Desktop Board products. You will likely get better traction if you post it in the Graphics forum.

My personal take is that, if the problem is happening when the PC is completely awake, then the BIOS likely has nothing to do with the issue. It is not involved in the normal runtime operation of the PC at all; it only becomes involved when the system is transitioning into or resuming from a low power state (S3/S4/S5). If the problem is occurring while the PC is completely awake, the problem is likely within the graphics driver - yet another reason to be looking to the Graphics forum for advice...

...S

View solution in original post

0 Kudos
Highlighted
Employee
17 Views

HDMI audio issues are handled by updating computer BIOS, changing cables, try getting high quality cables, remove and reinstall video drivers as the HDMI codec is available on it.

https://downloadcenter.intel.com/product/81496/Intel-HD-Graphics-4600-for-4th-Generation-Intel-Core-... Downloads for Intel® HD Graphics 4600 for 4th Generation Intel® Core™ Processors

Allan.

0 Kudos
Highlighted
Novice
17 Views

good point, I'm moving this over to the graphics board

0 Kudos
Highlighted
Employee
17 Views

Let us know your findings.

Allan.

0 Kudos