Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11462 Discussions

Help! - Drive not recognized during boot - for DZ68BC BIOS version 28


My configuration:

  • MoBo - DZ68BC Bios Version 28, Rev 402, SATA mode is set to AHCI.
  • Proc - i7 2700k
  • OS - Windows 7
  • Two drives (SSD and HDD) connected to Intel (Dark) Blue SATA III connectors


It was working fine since last two years. In last few months, BIOS Intermittently does not recognize drive having OS on it, ie Solid state drive. The other one ie hard disk drive is recognized okay.

If bios starts working okay, it will work fine during the day. No issues with several boots (shut down and start up). I would shut down the computer at night. However the next morning, the problem will repeat. It will not work for approx. 30 mins and then all of sudden, it will start working.

Tried so far below but did not resolve the issue.

-Completely shut down, removed power cable, discharged any power by pressing power button.

-Reset BIOS (although this does not do anything as I have not done any BIOS changes).

-Swap data cables between the drives, suspecting data cables might be the issue.

-Changed connector between drives suspecting the connector might be the issue.

-Changed connector from intel (blue) to marvell (light blue) however bios will not boot with message that a change was done. Did not go into details as connector does not look like the issue.

-Since the boot works intermittently okay, SSD drive being bad is ruled out. I also did a health check on it and it was fine.

Further option

I want to try upgrading BIOS from version 28 to version 39 whose release notes mention that it contains a fix where Intel has Fixed issue where hard disk drive is not recognized when SATA mode is set to AHCI. However I am not convinced if above will solve the problem.

The biggest question for me is why does it happen intermittently only? And then how the issue disappears, if I wait for approx 30 mins and try again, where it will work okay during the day and then next morning it will not work.

Any help / pointers will be highly appreciated.

0 Kudos
2 Replies
New Contributor III

I would be very careful to upgrade to BIOS 0039. The BIOS 003x series have a lot of problems with the i7 2xxxK CPUs. The problem seems to depend on the CPU type and the board. I have a i7 2600K and lost the option to be able to configure the clock ratio reliable with the 003x series BIOS. I already received a replacement board but the issue remained the same

There is NO option to downgrade from 0039 to 0028!

I would check first if there is a firmware update for your SSD. This could also be the cause.

Another option would be to put the drive mode in RAID in the BIOS. Using a drive in non-raid mode is fine. Intel has just recently released an updated Rapid Storage Technology driver (you problem may also be caused by a not correctly shutdown of your SSD). This is a documented problem of the M4 SSD for example and I have seen this also a couple of times. SSD is gone and it takes 1/2 hour before it can be seen in the BIOS again.


KKM, according to the release notes, this issue should be solved by installing BIOS 0039; however, I would recommend you to install all previous BIOS versions in order to avoid any other issue.

Something very important for you to know is than once you install BIOS version 0035, it will no longer be possible to downgrade the BIOS to version 0028 or earlier.

Which is the behavior of your system if you switch the regular hard drive to the SATA port where the SSD is connected? Could you try the black 3.0 SATA ports just for testing purposes?