Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JSunk
Beginner
1,888 Views

How to enable all 4 SATA ports in a DG43GT chipset mother board

Hi,

I have a desktop with an Intel DG43GT chipset - with a DVD writer and a 320 Gb SATA hard disk.

I removed the DVD writer and connected a new WD 1Tb SATA hard disk and could use it under Windows-7

In the process, discovered that I am unable to activate all 4 (Four) on board SATA ports - only 2 get activated; and so cannot use 2 SATA Hard Disks + 1 DVD Writer, together

I browsed the net and found a couple of BIOS settings and updated them, but still cannot get all 4 SATA ports to get enabled.

Any clues?

thanks

Jeevan

PS: Screen shots of my BIOS are attached.

0 Kudos
6 Replies
AP16
Valued Contributor III
87 Views

You should change the ATA/IDE mode to Enhanced (or Native), cause in Legacy mode you are limited to 4 ATA devices, half of whose can be only IDE devices. Although current Windows installation may not survive such a change in BIOS.

n_scott_pearson
Super User Retired Employee
87 Views

First of all, a side note: *always* enable S.M.A.R.T.; this allows drives to provide predictions for impending failures.

Next, you didn't specifically say what happened when you plugged in both HDDs and the ODD. Do all three devices show up or only two of them? You also didn't say whether you tried using different port combinations. Try using ports 1, 2 and 3 rather than 0, 1 and 2 and see what happens.

...S

JSunk
Beginner
87 Views

Thanks JF.

Thanks Scott,

Will try using the other SATA ports and avoid the ones that currently work, in a couple of days time.

(I broke the plastic portion of one SATA cable and do not have a spare and had to order one on eBay)

thanks

Jeevan

Allan_J_Intel1
Employee
87 Views

Yes, changing SATA modes requires you reinstalling your operating system.

Allan.

JSunk
Beginner
87 Views

Problem resolved.

I just plugged in a new SATA cable (with locking latch) into one of the empty SATA ports and rebooted ... all drives (DVD writer and the 2 hard disks) were auto detected.

In windows-10 (which I did not have to reinstall),

Started "Computer Management" and assigned the DVD writer a drive letter - that's it - everything working as a charm.

thanks

Jeevan

Allan_J_Intel1
Employee
87 Views

Great. I am glad this is working now.

Allan.

Reply