Showing results for 
Search instead for 
Did you mean: 
Community Manager


My Intel DZ77GAL-70k is no longer booting past the INTEL EXTREME BOARD LOGO. It does not even show options for BIOS in bottom left hand of screen. NO USB ports receiving power in any of the connections (on board or case). ALL parts in this pc are brand new. I had windows 7 running successfully for a week or so. Then I left it alone for a week or so because of being busy working. I continued using my laptop and today when I went to turn it on, their is no way I can get past the Intel boot logo screen. i tried to reset my bios with the jumper switching from 1-2 then 2-3 -doesn't work. Hard drive is getting power because I can hear it power up. All fans spin up to full speed upon power up and stay full speed, they do not slow down as they would normally. Please tell me how to RMA this board back to you. Purchased through Intel retail edge. No power in USB suggests bad board? I'm getting E6 showing in the Post Error Code. I had already updated the bios to latest version and had the computer running stable for about two weeks after building it. This is my fourth week of using the PC which again has all new parts and no compatibility issues. Software and drivers were all installed from Intel website.


Dz77GAL-70k / i7 3770k / Corsair AX860 / HD4000 / Mushkin Silverline 2x4GB 1333mhz 9-9-9-24 /

0 Kudos
4 Replies


Unplug the PC and wait a couple of minutes. Now remove the CMOS battery and wait a couple of minutes before replacing the battery. Plug the PC back in a give it a go.

Have you tried the 'back-to bios" button method?

Community Manager

Hello Dave,

thanks for your timely reply. I have not tried to remove the CMOS battery but will give it a go.

and what is the back-to-bios method? When i press the power button, all that happens is the logo shows up and nothing else. I mean honestly what could go wrong after I have successfully flashed the bios? I feel like it is bricked as some people have posted about this Motherboard. The only issue i was having with the board prior to this was getting a steady LAN connection. My connection would cut out anytime it felt like it wanted to. Both the ports were enabled and I tried installing and re-installing drivers for both. Anyways, didn't fix the issue and I also saw that many many many users of the same intel onboard gigabit were experiencing same issues of losing connectivity at random times.

The issue I am having now tells me the board is no longer wanting to boot past power up phase. It sat there on a wooden desk for about a week and no usage. Now that I turned it on, no booting occurs. All that happens is the fans spin to their max and stay at that level and this bloody picture below stays on the screen. my USB connections don't get power because I guess the Motherboard is not loading drivers upon power up. The only things working are HDMI on board, and Gigabit has power. Not even my USB connections on the ATX case are getting power this sucks.

Community Manager

I think dave is refering to the back-to-bios button on the rear i/o panel of the motherboard. It is the white square pushbutton between the E-SATA port and the USB3.0 ports. I don't know exactly how this function works as I have not used it yet.

Regarding the LAN port dropping out. Many people disable the second port in the bios and use only the lower port. This is what I am doing now, I was also having issues with loosing the LAN connection when using the upper port (closest to the E-SATA port).

Good louck getting the board back up.

Community Manager

Had the same thing happen when I flashed my BIOS - I'd guess that your board is bricked.

One thing I've been noticing with this MB is that it does not get along with my 3TB WD My Book USB 3.0 backup HDD. If I have it plugged in, whether to a 2.0 or 3.0 port, via hub or straight to the computer, my MB will not POST - I stick at the splash screen, no options displayed - this is on the last version of the BIOS.

I wonder if you have a similar issue with an external drive that is causing issues?