Showing results for 
Search instead for 
Did you mean: 

Intel D910GLGW & Celeron D 352

I've offered to do a cheap repair of a neighbour's old basic desktop which got trashed by lightening. I bought a 'New', as in old stock, still sealed in the box, combo of an Intel 910GWGL board and a Celeron D 352, 3.2GHz CPU for pocket money prices on that well known web trading site, but can't get the system to go through POST. Board lights are illuminated, CPU fan spins, KB flashes when plugged in and the hard disk spins up, but never does any read/wright. I suspect the MB rather than the CPU because as far as I understand the POST and BIOS should come up with error messages even before the CPU initialises, am I right? The CPU also never warms up also making me suspicious that it is never initialised. If I try and boot with no RAM installed I don't get any warning beeps, so I suspect that the POST/BIOS install isn't even getting that far. A VGA plugged in to the on-board video goes out of standby but never shows anything. I've reset the CMOS by removing the battery. Am I right in suspecting the MB rather than the CPU or am I doing something stupid? The board was, from what I can see, specifically designed for the Celeron D. The PSU is brand new.

0 Kudos
3 Replies
Super User Retired Employee

I remember there being a D910GLDW; is that what you have?

Are you just seeing the keyboard doing something because it received power or are you actually seeing the keyboard lights flash once? If you are seeing the keyboard lights flash once, it is an indication that the BIOS has gotten quite a ways into POST. This tells us that the processor is getting initialized (this actually comes first). In this case, it would point the hairy finger towards the memory subsystem. Whether it is the memory itself or the motherboard is something we can't tell from your description.

I gotta say, this is a really, really old motherboard and processor combination - old enough that the board, even if it has never been used, could be suffering from oxidation issues, etc. Spring tension in connectors could be failing and pins either not connecting or connecting only intermittently. You could try putting a finger on the top of each of the DIMMs and wiggle them back and forth a bit and see if this improves things, but I wouldn't get your hopes up.



Rats!!! Sorry a fat finger typo, yes it is a D910GLDW


I was also wrong about the keyboard (PS2 style). The lights only flash once if the plug is pushed in with the board powered up, the keyboard does not flash if the board is powered up with the KB already installed. I'm still confused why I don't get any POST beeps if I try to boot with no memory installed, is that not early in the POST process?

As you say it is pretty old kit but I wanted to get my pensioner neighbours back with a working PC as cheaply as I could for them. I deliberately bought unused kit rather than something second hand, maybe that was a mistake They are not power users by any means and the repair would have just got them pretty much back to what they had before the thunderstorm. I'm no expert, just know enough to be dangerous, which I guess I am demonstrating well at the moment.

I've tried with both SATA and E-IDE hard disk but with the same result, not that it ever seems to get anywhere near accessing the hard disk.. I'm working with the board stripped down to just the essentials, all USB, sound, CD and everything else disconnected.

Thanks for your help folks, much appreciated.