Intel® Desktop Boards
Peer-to-peer support only
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11461 Discussions

Intel DH77KC No video Problem

idata
Community Manager
1,347 Views

Helly everyone,

so I'm an owner of the DH77KC mainboard, which actually works pefectly fine. Now today, I went to the BIOS and set my settings to default again (I had my own settings for about two months now, also updated firmware during that time, no problems ), because I wanted to switch to Intel's default energy settings.

Now after I switched to default settings, my computer is not booting anymore. The board is giving me the "no video" beeps. Due to the default settings, the BIOS is probably ignoring my graphics card now and my CPU does not support Intels integrated graphics, it's a Xeon cpu.

What am I supposed to do now? I already tried a CMOS reset, but it did not work.

Edit: Beside the default settings, I switched off one thing though before I saved the settings: legacy boot, because I'm using UEFI. But that should have been resetted after I took out the battery or not?

Edit2: I now even tried to fix this Problem with Intels Bios Recovery. I removed the jumper and put the lastest .bio file on a FAT32 formatted 16GB USB drive. But when I turn on my computer and try to update, it still gives me that beep(long),beep(long),pause,beep(long),beep(long) sound. I mean what the heck is going on, I just set my settings to default and now my computer doesn't boot anymore?

0 Kudos
2 Replies
idata
Community Manager
222 Views

Okay guys, I fixed it. Despite of the fact, that I tried everything, I set the jumpers on maintenence mode and I was able to enter the BIOS again... This is ridiculous

Legacy boot was disabled, I'm wondering why disabling legacy boot avoids the board to detect my graphics card (probably a bug) and why legacy boot was still disabled although I have done a CMOS reset.

idata
Community Manager
222 Views

You can't disable Legacy Boot because you have a Legacy graphics. If you want to turn off Legacy Boot you must either use IGP or have a nVidia 600 series card flashed with UEFI bios.

And also, you did not have to use the jumper on motherboard, you can hold down power button for 3-4 seconds and release to get into UEFI settings.

Reply