Intel® Desktop Boards
Peer-to-peer support only
11429 Discussions

Intel DP55WB and Gigabyte r9 280x: Not booting. Compatibilty issue?


Hi all. Just got myself a brand new Gigabyte r9 280x Windforce yesterday. I've been trying and trying hard to get it to work on this board but my system never goes beyond the start up logo. It stays stuck at 5A forever. My previous GPU was a Gigabyte 6950 and it worked perfectly. I don't understand why, for the life of me, this GPU refuses to boot. I've tried the following:

- Removing other PCI Devices

- Removing Old GPU Drivers

- Switching Power Connectors

- Reseating the card several times

- Updating Bios to Ver. 336 (Latest)

I do get a display with the GPU, the startup Intel logo that is. But it just locks up after that. Pushing the BIOS key does nothing but produce beeps. Switching back to the old GPU makes it boot up again without skipping a beat so the current GPU is definitely the culprit. Things I still haven't tried:

-Flashing GPU with New Firmware

-Clearing CMOS

-Trying the GPU on a friend's PC

I'm gonna try doing these things later. Is there anything else you guys think it could be? Thanks in advance.


0 Kudos
0 Replies