Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AJob
Novice
1,207 Views

Intel DQ67EP with i5-2500 DVI-D Dual Monitor Issue

Jump to solution

Hello.

Hoping someone here can help me.

Ive just built myself a computer.

Spec is:

Intel DQ67EP Motherboard

Intel i5-2500 CPU

Mushkin 8 GB DDR3 12800 Ram

OCZ Vertex Plus R2 SSD

Standard ATX PSU

Im wanting to run with 2 monitors (Samsung and Relisys TFTs)

My issue is that both monitors work in the DVI-I port but when I use either monitor in the DVI-D port all I get is a green fuzzy screen,

This happens from when the machine is turned on.

Windows sees the monitor and extends the desktop to it and ive tried changing settings etc with no joy.

 

I have tried different monitors in the port, new PSU, updating the BIOS.

Cant see it being a driver issue.

Miby motherboard of the integrated graphics chip in the i5

Picture attached

Any help is much appreciated.

Alan

0 Kudos

Accepted Solutions
AJob
Novice
49 Views

Hello, Suppler sent me a replacement motherboard and the problem is now cured, thanks for all your help. Alan

View solution in original post

7 Replies
Kevin_M_Intel
Employee
49 Views

Hi alanjob,

I am sorry you are having problems with your system but let me help you.

Based on your description, there are some steps I want you to try:

  1. Test a different cable.
  2. Uninstall the current driver and download the latest at the following link:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23377 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23377

Besides this, you can run the Intel® Processor Diagnostic Tool. This will diagnose the processor and do a stress test to test every single internal component of the processor and in case there is a problem, the result will be displayed. You can download it here:

32 bit:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19791 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19791

64 bit:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19792 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19792

AJob
Novice
49 Views

Hello

I have tried replacing the cable/monitor and reinstalled drivers.

This happens before the driver even loads.

I have run the Diagnostic Tool and everything passed ok.

I have however sourced a cpu so ill update when I get to try it.

Alan

AJob
Novice
49 Views

Hello

Installed the new CPU, same issue so must be a problem with the motherboard.

Does anyone else run this board and have dual displays using the dvi ports?

Alan

Kevin_M_Intel
Employee
49 Views

We can discard the processor for now but have you tired a BIOS update?

Here is the latest:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22122 https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22122

AJob
Novice
49 Views

Hi, yes bios update was done. Alan

AJob
Novice
50 Views

Hello, Suppler sent me a replacement motherboard and the problem is now cured, thanks for all your help. Alan

View solution in original post

Kevin_M_Intel
Employee
49 Views

You are welcome. I am happy to hear your problem is solved.