Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SCarl1
Beginner
889 Views

Intel DX48BT2 + AMD R9 270 won't boot

As it says in the title, my DX48BT2 won't start with a R9 270 (not a 270X). Everything is connected properly. I have an 850W power supply.

When powering on, the system will display: "98% of system memory tested OK. Press ESC to skip memory test." Pressing ESC does nothing.

If I press F2 quick enough, I can get into the BIOS setup, but the display doesn't draw correctly (goofy overlapping text).

I've flashed to the newest BIOS, cleared the CMOS (removed battery), tried the second x16 slot, and still gotten nowhere.

Now, the system has been and still does work perfectly fine with an older AMD HD7770 card installed. Memtest86 comes up with no errors.

Amazingly, the R9 270 works perfectly (stress tested!) in an even OLDER board, a D945GTP with a netburst Pentium D!

I'm at a loss and would appreciate any help!

0 Kudos
1 Reply
Kevin_M_Intel
Employee
17 Views

Hello Shazbot,

This could be a compatibility issue between the components you have. My recommendation is update the BIOS to latest version, in case you have a old version:

https://downloadcenter.intel.com/download/18302/BIOS-Update-BTX3810J-86A- https://downloadcenter.intel.com/download/18302/BIOS-Update-BTX3810J-86A-

Another good step would be looking for firmware updates for this video card. The power supply you have should be enough for the power requirements but just in case, try another power supply.