Intel® Desktop Boards
Peer-to-peer support only
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
11360 Discussions

Intel DX58SO UEFI boot fatal for ssd or second harddisk attached

SCodd
New Contributor I
1,010 Views

The dx58so works fine with uefi boot and windows 7 64 bit professional.

but now that I want to add ubuntu 13.04 (uefi boot signed by microsoft) on a SSD then the system cvan not boot anymore.

Perhaps the board has problems with ssd but nope, I removed the SSD and a second harddisk partitioned by ubuntu (swap and /temp)

was still attached and still no boot, windows can simply not start.

Another thing that I've noticed, if AHCI is enabled in the bios, after a reboot, the bios switches back to IDE.

And as soon when the second harddisk is removed so just the harddisk that contains windows is still used, then windows can start again.

The ssd is a patriot pyro 60GB

the second harddisk, no matetr which one, simply not allowed to add cause windows can't boot again.

even if I select the boot menu and the windows boot manager , windows can't simply not start.

Second harddisk removed and windows is back.

Weird board

0 Kudos
1 Reply
Jose_H_Intel1
Employee
120 Views

Hello Sergei,

It is possible that the Linux* installation modified something in the Windows* bootloader/MBR.

Please note that the operating system will not boot if you change the SATA controller mode (IDE, AHCI, RAID) after the installation. If this is not the case you may also consider a BIOS update.

Reply