Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FPedi
Beginner
1,289 Views

Intel DX58SO2 socket b & modern graphic cards: Radeon Rx560 etc

Hello everyone ! I have been struggling to get a Sapphire RX560 4GB working with this board -DX58SO2- but I have no luck so far; it seems it cant recognize it.

On my first install of the card with a legacy bios I couldnt even get the system to post. The famous no post, no beep, no signal whatsoever issue that drives people

crazy.

I used the old card again (Radeon 7770 Ghz edition) and flashed the latest 920 bios version from windows. Then tried again and my-oh my- the system boots ! I log to windows normally but the card was identified only as Standard Vga. I say no biggie, lets update the drivers . Next step : Install Raddeon drivers, being super excited that my i7-920 rig will continue to triumph for a few more years , being prompted by the system to reboot...aaand BLACK SCREEN.

Once system enters Windows7, black screen and signal goes off. Computer is still running though, you can still hear all the Windows 7 sounds. No matter what I do, the result always the same,

black screen whilst windows still running. I can only enter windows 7 in safe mode, where the RX560 is listed as Standard Vga.

So has anyone else tried with newer graphic cards ? Is it a drivers issue ? Is it an incompatibility issue because of the old motherboard ?

Am I the only one still struggling on a DX58SO2 ?

Some useful information : I have an UEFI install of Windows 7 and 16gb of RAM (4x4) installed. I also tried with legacy on another volume & a clean install, same results : Black Screen when Win7 loads.

0 Kudos
3 Replies
AlHill
Super User
79 Views

Very likely an incompatibility.

Your board: https://www.intel.com/content/dam/support/us/en/documents/boardsandkits/desktop-boards/X58/DX58SO2/D... https://www.intel.com/content/dam/support/us/en/documents/boardsandkits/desktop-boards/X58/DX58SO2/D....…

The old board supports PCIe 2.0 on its x16 slot. The graphics card is likely PCIe 3.0 and claims backward compatibility.

The old board would not know what the future holds, so the manufacturer of the card would have the responsibility to ensure 2.0 compatibility..

This issue has come up many times before. You might see if there is a firmware update for your card, or try and find a card that is really compatible. Perhaps an older card will work for you.

Doc

FPedi
Beginner
79 Views

Current card I am using is also PCIe 3.0 and is working happily than ever before, so it can't be that ! Pcie 3.0 is backwards compatible with pcie 2.0. I agree on the apparent -most likely- incompatibility between DX58SO2 and Sapphire Radeon Rx560, just not about pci . I am genuinely wondering about the other current graphic cards, for example, does a Gtx 1060 works with Intel DX58SO2 ?

Let's hope someone answers !

thanks

AlHill
Super User
79 Views

Just to clarify, I believe it is your particular Sapphire card that is NOT fully backward compatible. If you do have a card that is working and is PCIe 3.0, is it the same manufacturer and model, or not?

I have seen many of these posts, and many of those with the Sapphire card, that have the same issue as you.

Personally, I would not want to run a nice, new PCIe 3.0 card on such an old board. While you may find a card that does work, you will still be running in a degraded mode (PCIe 2.0).

Anyway, good luck on your quest.

Doc

Reply