Intel® Desktop Boards
Peer-to-peer support only
11432 Discussions

Intel DX79SR, UEFI, multiple LUNs

Community Manager

I'm installing Windows 8 Pro 64-bit onto a virtual drive hosted by an LSI MegaRAID 9260-8i RAID controller card installed in an Intel DX79SR motherboard. UEFI is enabled in the BIOS and is being used to install and boot Windows 8 successfully. I run into a problem when I configure a second virtual drive on the RAID controller card. After the second virtual drive is created and the system is rebooted, the UEFI system on the motherboard seems to not be able to find the EFI system partition originally installed on the first virtual drive. I can use the RAID controller BIOS to remove the second virtual drive, which will allow the system to boot normally into Windows.

I suspect that there's a problem using UEFI to boot from the RAID controller when it is exposing multiple virtual drives, which are presented as LUN 0 and LUN 1 in this case. I don't know if this is a limitation of UEFI, a problem with the UEFI implementation on the motherboard, or a problem with the RAID controller card. It seems silly to me that the UEFI system on the motherboard wouldn't enumerate all available LUNs to find the EFI system partition.

Is the Intel DX79SR motherboard able to use UEFI to boot from an EFI system partition hosted on a RAID controller that is presenting multiple LUNs?

Intel DX79SR (BIOS: 0553)

LSI MegaRAID 9260-8i (firmware: 12.12.0-0124)

UPDATE: I've been using rEFInd 0.6.1 to see if I can gather more information. It looks like the RAID controller is changing device properties depending on if there is one virtual drive or not.

With one virtual drive, the RAID controller is showing a device path of:


With two virtual drives, the RAID controller is showing a device path of:


I'm wondering now if the UEFI system on the board is ignoring PUN1. Is there a way to configure the system to scan all PUNs for an EFI system partition?

0 Kudos
2 Replies
Valued Contributor III

Did you set up a boot flag on first Virtual Drive after creation of second? The LSI WebBIOS is kinda tricky: by default none of Virtual Drives have that flag, and if there is only one VD, controller deal with boot, but if there two or more, system may not boot, even in non-EFI environments.

From the WebBIOS main menu, click the Virtual Drives - double click your first, select 'Set Boot Drive' (make sure right VD is highlighted above), press 'Go' button, then accept changes.

Community Manager

JFFulcrum, thank you for taking the time to help troubleshoot my problem.


I did notice the boot flag option in the LSI WebBIOS. With both virtual drives present, I have tried with it set and unset. Unfortunately, changing the option doesn't appear to change the behavior. So far, the only way I've seen this system boot with UEFI is when the card is only presenting one LUN.


I have no data on these drives, so I'm in a situation where I'm able to completely reset the configuration and reconfigure without a problem. If you have any other troubleshooting ideas for me, please let me know.