Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Rick127
Beginner
136 Views

Intel Z590 Chipset Problems with 'Thunderbolt' USB-C. URGENT PLEASE!

Intel Core i9-11900K and Motherboard ROG Maximus XIII Hero with the Intel Z590 Chipset.  I tried LOADS of times to find out WHY the 2 Thunderbolt USB-C ports are NOT Recognising the Oculus Quest 2 through the Oculus PC link cable?  The Quest 2 worked fine on the previous Asus Maximus VIII motherboard USB-C ports.  Oculus suggested removing the USB Hub and Root controllers, so that they would be re-installed with Win10 re-start.  All the latest chipset drivers from and Asus and Intel are installed.  Nvidia drivers for the RTX3090, are the latest, and WIn10 is the very latest version. The Thunderbolt USB-C ports ARE enabled in the Bios.  Also why am I showing in the Device Manager, six '!' problems?  (3 PCI Devices, 1 SM Bus Controller, and 2 Unknown Device). My previous motherboard showed NO '!' problems.  A brand new Intel CPU and Z590 motherboard and I am having these problems?  Come On, Intel, what is going on?

0 Kudos
3 Replies
n_scott_pearson
Super User Retired Employee
117 Views

Are the TBT ICs the same?

Rick127
Beginner
92 Views

Thanks for reply. I don't have a clue what you mean ''TBT ICs''?  Oculus Tech have suggested from the diagnostic file, that there is a hardware problem, and said they can no longer continue this case? To me that is being too dismissive? I do not not believe it is the fault of the USB cable, as I have tried several other cables.  The two USB-C ports do work with other devices, like portable SSD's. The Oculus USB Link cable DOES charge the Quest 2.  When connecting the Quest 2 and the box appears 'USB device not recognised', I then look in 'Device Manager', and in the list shows 'Oculus Device/ [!] Oculus XRSP Interface'?  The '!' symbol, shows a problem?  I right click on this to search and update driver, but Win 10 says it is the right driver for the device, I have tried a troubleshoot, et. Nothing works. I think it is a driver related conflict, directly associated with the Oculus software.  How can a brand new ROG Maximus XIII Hero motherboard be the problem, when the same USB-C ports work perfectly with other devices?    

n_scott_pearson
Super User Retired Employee
86 Views

Are the Thunderbolt (TBT) chips (integrated circuits - ICs) and the USB-C chips the same on the two motherboards?
Did you take the lazy route and move your boot device from one motherboard to the other (i.e. without reinstalling device driver packages)? If so, time to uninstall these packages and then reinstall. Why? Because if the hardware is different, the drivers might not get updated automatically. The packages appear to be installed, so they don't get reinstalled, but Intel packages -- for LAN (Ethernet), WLAN (Wireless/Bluetooth), Chipset, CPU GFX (graphics), USB-C, TBT (Thunderbolt), etc. -- contain multiple drivers, for different versions of the chips, and and chips that changed may not get their version of the driver installed. Sometime, the driver gets updated because of PnP (Plug and Play) and sometimes they don't. If you reinstall Windows 10, this issue can be avoided.
Hope this helps,
...S
Reply