Intel® Desktop Boards
Peer-to-peer support only
11429 Discussions

Intex Matrix RAID - The volume cannot be rebuilt to the selected hard drive



I am sure I have seen forum answers to this question in the past, but now I can't find it! Maybe been a big cleanup?

DP35DP board with Windows Server 2003. Had a failed RAID1 disk replaced with exactly the same Seagate model, but using Matrix Storage Console 8.8 I can't rebuild the array to the replacement (non-RAID disk). I get the message:

The volume cannot be rebuilt to the selected hard drive due to one of the following reasons:

The hard drive contains system files or is the system hard drive

The hard drive is not large enough to be used for the rebuild action

The hard drive has reported a SMART event

The hard drive has reported a failure

The hard drive is in a different encryption state than the volume.

The replacement disk did have old data on it, but I used Activ@ Killdisk for Windows to wipe it and still no love. I am confident the disk otherwise passes the other tests.

I'm hoping that there is a "supported" way to ensure the disk is clean for rebuild. For example, maybe Killdisk for Windows doesn't get every inch of the disk, and have to use Seatools for DOS or some other non-Windows tool. I've had this problem years ago in the past and cannot remember how I fixed it. I have a feeling it was Seatools for DOS track 0 erase, but I currently have no working DVD and don't think the board supports USB boot. So ideas on what methods I can use before I go pulling the server out of the rack again would be great!

Maybe this is a ROM version issue? I upgraded the Windows Matrix Driver from 7.8 to 8.8 but it had the same issue, so maybe I need to upgrade the BIOS (from memory it is currently 0497 with RAID for SATA v7.6.0.1011)...?

I am lead to believe it is possible to boot into the ROM and convert the RAID disk to a non-RAID, then boot and create a RAID1 again from the original disk in the Matrix Console for Windows, but I worry this will end in tears for the same reason that it doesn't like the disk because it is not clean. I've not seen any examples of people using this method to erase and reuse a second disk from another machine (all have used blank/new secondary disk).

Thanks all!

0 Kudos
4 Replies

Hello Hugga, thanks for joining the Intel Community.

Regarding the issue you are experiencing please check the following article Pag26

Degraded RAID 1 volume will not rebuild after failed hard drive is replaced

Make sure the "new" hard drive you are using is working or is in good condition. In addition, please make sure it has enough space so you can rebuild the RAID.



I appreciate the comments but there is nothing new I haven't already checked.

As I mentioned the disk is exactly the same model as the one replaced and of the drive still in service. The drive is also detected happily in Windows and by the controller and no SMART error has been flagged by the Matrix Console software.

The PDF document only discusses how to manually rebuild since the array does not autobuild after disk replacement. It makes no mention of the error message or the requirements of a "blank" disk.

I appreciate the software is trying to protect against accidental data loss, but to not give a means to force the removal of data is limiting. Surely it is documented by Intel as to what "system files" the test is checking for, and therefore an understanding as to what needs to be done to properly erase the disk for reuse.

Since I have used Killdisk, I expect the MBR has been erased and maybe I need to recreate it (maybe diskpart clean all) which i will try soon.


Problem solved.

For some unknown reason, even though it was exactly the same model drive, the LBA addressing reported slightly less blocks than the source disk, only by 0.01Mb. I found this out using the Seatools for DOS utility and compared the 2 disks looking for differences. I used the "Set Capacity To MAX Native" menu to reset this anomaly and the rebuild worked fine. I don't know what circumstances would have changed this previously but it did come from a different system so maybe something to do with the history of the disk. I am sure other manufacturer's low-level utilities have a similar option so worth checking if you get stuck with this error.

I am also sure that the MBR (track 0) needs to be removed, I think this was my problem last time. But be aware KillDisk for Windows erases the MBR and then writes a new one (as per the bottom of I found a freeware CLI utility that works under Windows too, called MBRWizard that looks very powerful ( and used it to erase my Track 0. I could have used Seatools for DOS as well.

PS I ended up replacing my faulty DVD drive to use Seatools for DOS, but I may have been incorrect earlier about USB boot as I found settings in the BIOS for it.

Hope someone finds this article useful.


Thanks for the information Hugga; I will keep this in my records for future users.