Intel® Desktop Boards
Peer-to-peer support only
11436 Discussions

Limited to No PS/2 Function DH55TC (H55, LPC bus)


The two DH55TC motherboards I own do not recognize PS/2 devices fully.

During POST, with a PS/2 keyboard connected, the two digit Port 80h indicator shows code 98 "resetting mouse" and code 94, "clearing keyboard input buffer". POST takes longer than with nothing plugged into the PS/2 port. Once POST completes, any OS will boot and not recognize any device.

While in POST, with a PS/2 keyboard connected, you can use the function keys to access BIOS setup and boot menu. POST still takes longer than it normally does. If F10 is pressed, the boot menu will load, but the keyboard will not respond. If F2 is pressed, BIOS setup allows the use of the arrow keys, enter, and escape. Cap lock, number lock and scroll lock LEDs on keyboard do no respond. Tab does not work. All the F keys do not work; you cannot use F10 as a quick save and exit. You can move around the setup tabs and select fields, but only manipulate settings with menus with the enter key. You cannot set the time, as none of the numbers or number pad works. Once you arrow key to Save and Exit, the computer reboots with a slow POST, booting into any OS with no keyboard detected at OS.

LPC drivers are in tact. No PS/2 port is shown anywhere in the Device Manager that I can find. It does list HID keyboard drivers. USB keyboards work fine.

BIOS is up to date on both motherboards, as well as chip set and all other drivers

I have not tried to use the communications or parallel port supported by the LPC. Both ports are shown in the Device manager, with their age old typical IRQs assigned.

I've tried a very large number of diverse keyboards. I have tried mice, which do not work either, but I'm only concentrating on keyboards. The motherboard was stripped to bare, tried different RAM, turned off the other ports controlled by the LPC, disabled and enabled USB options, reset BIOS to default and a few others I'm forgetting to mention.

Any ideas? It seems it should be correctable, since the same exact two DH55TC fail exactly in the same manner.

0 Kudos
1 Reply
Super User Retired Employee

If I remember correctly, PS/2 ports are not plug-and-play. This means that, if you have an existing Windows configuration and you add a PS/2-based device and then boot up, you need to have Windows run a scan to "see" and enumerate this device. For Windows 7 (which I presume you are using on these boards; they are NOT supported for Windows 10), go into Device Manager, right-click on the root of the device tree and select Scan for Hardware Changes. This should then add your PS/2 device(s).

Hope this helps,