Intel® Desktop Boards
Peer-to-peer support only
11428 Discussions

Mainboard DZ77BH-55K won't boot with SSD connected


Mainboard Intel DZ77BH-55K stops booting with SSD connected after working for some years

BIOS Version BHZ7710H.86A.0100.2013.0517.0942 - 17/05/2013

I bought this board November 2012 and connected a SSD OCZ Vertex 2 SATA II as a boot device.

In October 2013, nearly a year later, it wouldn't boot anymore, without permitting access to the BIOS.

So I replaced the OCZ-SSD 120GB with a new model Samsung E840 250GB.

Four days ago, after nearly 3 years working properly, the same issue occured again - the mainboard didn't boot with the SSD attached and the BIOS was not accessible, the mainboard LED showing the POST code E6. I didn't manipulate anything in the BIOS near this point of time.

Booting only was possible with the SSD removed and another SATA HDD as a boot device connected.

Interestingly tests with both SSDs on 2 other computers (an Abit-IP35Pro 2008 and a halfway new Medion-Laptop) were showing them working and booting properly.

Aside this problem the board also won't boot with connected external USB devices. To persuade the board into booting I have to remove ALL (seven) external USB devices. For this reason I instructed the BIOS to boot the USB devices after booting into the OS.

Now it asks for the boot device because it doesn't find it by itself, but also the POST shows a way into the BIOS by prompting F2, and F10 for the bootloader, but the the USB keyboard too is not connected at this time, so I cannot answer the BIOS' questions. Thank Heaven I found a grime covered ancient PS/2 keyboard in some corner, so I could resolve the problem for the moment. Permanently though I would prefer a more convenient method to boot the system.

I beg to excuse my somewhat clumsy English, asking for your help:

First, is there some workaround to reintegrate of my SSD into the system as a boot device, and second, is there a way to circumvent the booting of the external USB devices without disabling the USB keyboard/mouse at the same time?

Thanks in advance.

0 Kudos
17 Replies
Super User Retired Employee

When you say that it won't boot from the SSD, what does it do? Does it give any error messages (unbootable device, for example)? If no messages, what happens if you wait? That is, let it sit for two minutes and see what happens.

To fix the issues with USB Boot, do the following:

  1. If not already done, power off and disconnect SATA cable from SSD drive.
  2. Power on.
  3. Using the F2 key, enter BIOS Setup (Visual BIOS).
  4. Click on the Advanced Setup button (on the top row).
  5. Click on the Devices & Peripherals button (also on the top row).
  6. Click on the SATA tab.
  7. Ensure that the Chipset SATA Mode is set to AHCI.
  8. Click on the USB tab.
  9. Ensure that all USB ports are set to Enabled.
  10. Ensure that USB Legacy is checked (enabled).
  11. Click on the Boot button (on the top row).
  12. Click on the Boot Configuration tab.
  13. Ensure that all three Fast Boot options are unchecked (disabled).
  14. Ensure that Boot USB Devices First is unchecked (disabled).
  15. Exit BIOS Setup, saving the settings.
  16. When the BIOS Splash screen appears, power off the system.
  17. Plus the SATA cable back into the SSD drive.
  18. Power On.
  19. Use F2 to enter BIOS Setup (Visual BIOS) again.
  20. Click on the Advanced Setup button (on the top row).
  21. Click on the Boot button (on the top row).
  22. In the Boot Priority section (on the right), ensure that the entry for the SSD is at the top of the list.
  23. Exit BIOS Setup, saving the settings.

Let me know how it acts then...



Dear Scott,

it seems our time zones differ to some extent. Local time in Germany is now: 02:20 PM

I'm very grateful for your very clear instructions, and I apologize once again for the torrent of words I'm bothering you with. The less one masters a language, the more words are needed to explain something.

Some remarks before I get into the matter at hand:

My computer is selfmade.

From the beginning the board wouldn't work as I expected. The unability to boot with USB devices connected, I considered as a normal behaviour; so I didn't give it back to the vendor. I simply disconnected the USB devices before booting, or often I didn't power it off for the night; but that is cost-intensive.

When booting with USB devices connected, the PC often would go into a boot loop - or with luck it would stop and prompt "BIOS has detected unsuccessful POST attempts...", offering to enter the BIOS, but later on it would not bothering whether the answer would be YES or NO, but starting anew and doing this offer again and again and only starting up to the OS after the disconnection of the USB devices.

As a fact the BIOS surprises me often withs prompts never seen before every other morning.

Although, sporadic the BIOS surprised me also by booting happily with all USB devices connected up to the OS for some days.

Once I considered the BIOS not working because of the battery being empty. When trying to change it very carefully, one of the two soldered points broke and now I have to have the board on the power line permanently. I don't know whether this fact is important for a diagnosis.

Some weeks before it finally couldn't boot with the SSD connected anymore, the BIOS prompted to press the ESC button to continue booting, a new prompt, I never saw before. But then it booted up to the OS, although that luck is gone by now.

And now to the matter at hand:

I did as you advised. To carry out all the 23 points I only had to redisable the USB Optimization (point 13) for the USB keyboard to work again and the Video Optimization, because all other points were the current adjustments already.

Where before the PC with the SSD connected froze instantly, whilst prompting a blinking cursor or by showing the splash screen I come to hate, it goes now a step ahead and offers the keys F2, F7 or F10 to press and then freezes, whether I press one of them or not.

As a consequence it is not possible to bring the ssd at the top of the entry list in the boot priority section.

I hope you can find some informations of value within my many words to move forward the matter. I want to repeat, that I'm very grateful for your care, because I'm very unhappy with the now again very slow starting of the OS and the programs from HDD. I would buy a new SSD, since they aren't that expensive anymore, but I'm afraid of damaging it when connecting it with the board, being the third one.

Thank you


Super User Retired Employee

Yea, I am in Pacific TZ.

You definitely shouldn't be seeing a boot loop because of USB devices. If this is still occurring after the changes I suggested, this tells me that there is something else wrong. What USB devices do you have plugged in? (please list them all). I have heard of an issue with large 5TB+ HDDs causing boot problems, but I tried connecting a 5TB drive connected to a DH77DF, which has very similar BIOS, without issue.

I do not like nor do I use the Fast Boot features. I don't boot it often enough to make the ever-so-slight improvement in boot time worth putting up with the negatives that this feature has.

If you are seeing the "BIOS has detected unsuccessful POST attempts..." message, it is a memory issue 99.99% of the time. You may have an unstable DIMM. I suggest that you remove all but one DIMM and see if the issue occurs. Repeat with each DIMM to see if you can isolate a bad one.

Which SATA ports do you have your various devices plugged into?



Dear Scott,

thanks for your answer.

As for the memory dimms, I have only one at 8 GB. I would have to buy a new one, but I doubt that it would work together with the old one. I also have in mind, that sometime next year I will build a new PC, a powerful one, to meet the needs for a VR-system (Oculus Rift or HTC Vive).

The PC boots perfectly with this memory dimm, provided the USB drives aren't connected or they are boot disabled.

After some heavy experimenting with the PC, the reason for my delayed answer, I came up with a workaround that does it for me:

I changed the BIOS to "USB Optimizations" enabled, to have the USB drives out of my way and to avoid interferences with a possibly bad memory dimm, and put the boot device (SATA-HDD) on the top of the boot list.

Now the BIOS doesn't bother about USB devices and goes directly to the boot HDD.

Whenever I have to enter the BIOS, I can do it with the help of my PS/2-keyboard.

Anyway, here is a list of my USB devices:

HDD - external USB 3


Seagate - ST3000DM001-1CH166 3000 GB, SATA/600

Western Digital - My Book 1230 4000 GB

Western Digital - My Book 1230 4000 GB

In a double case two HDD together (removable):

Western Digital - WD15EURS 1500 GB

Samsung - HD642JJ 640 GB

HDD - external USB 2


Initio - SP2014N 250 GB

With this USB-HDD connected the BIOS would always boot from this device, although the SSD was at the top of the Priority List.

USB3-Sticks (bootable)


Intenso Ultra Line 32 GB

SanDisk Extreme 64 GB

All these harddisks/sticks have to be disconnected for the PC to boot. Sometimes it is enough, to disconnect the USB-3-double-case only.

Other USB 2-Devices


DVB-S2-TV-Receiver "DVBSky S960/S860"

Printer/Scanner Epson "Expression Premium XP-720

no name USB-Hub 7 ports

USB-Hub (control from Eizo monitor)

mouse/keyboard-switch 4 ports

These devices can stay connected because they don't interfere (or so I think).

HDD - internal


SATA Port 2: Seagate - ST31000525SV 1000GB SATA/300 Drive C: Win7-x32 boot device.

SATA Port 3: Western Digital - WD30EFRX-68EUZN0 3000 GB SATA/600.

Secondary SATA Port: Seagate - ST332062 0AS 320 GB, SATA/150.

Now, referring to the USB problem, that I'm walking the line of least resistance, this leaves the issue with the SSD to chew on. Do you think this too could refer to a bad memory dimm?

Why stops this SSD suddenly working in this special PC, after 3 years flawlessly slaving away, preventing the PC now from booting, and freezing immediately after Power On.

Thanks for your help


Super User Retired Employee

It's difficult to know what is going on without a lot more information.

First of all, the easier issue. It sounds to me like the reason why you are not able to boot with the USB devices attached is because you have the boot order configuration set up incorrectly. If you ensure that the USB HDDs are in the boot order AFTER (below) the internal SATA HDD (or SSD), the interference should be eliminated. Enabling USB Optimization, as you've seen, has its negatives - but, because of the external USB HUB, enabling USB Optimization probably sped up your boot considerably.

As for the SSD, I can't think of a reason for this (other than out-of-date BIOS, which would be my first reaction). Have you tried connecting the SSD to a different SATA port on the motherboard?



Dear Scott,

With the USB HDDs attached the computer freezes instantly, when showing the splash screen. There is no possibility to enter the BIOS and looking at the boot order.

With the USB Optimization set on disabled,

the boot order is okay. The SATA boot device is on top of the priority list, followd by two other SATA HDDs, but USB HDDs are nowhere to be seen - with the exception of one of the two WD SES devices (WD MyBook) and the printer. Sometimes the list lists also some other USB2 devices, like hubs etc.

When entering the BIOS I seldom see the same picture as at the previous time, because the BIOS sets changes on its own.

With the USB Optimization enabled

and the then necessary PS/2 keyboard attached, the priority list prompts only "no boot device ...".

But with the USB Optimizations the Computer boots perfectly from the internal HDD and with ALL USB devices attached. So I will leave this as it is. You are right, it boots considerably quicker .

Yes, I have tried connecting the SSD to different ports. I changed the cable too, against a high-quality one. Unfortunately that changes nothing.

But I think, your would-be-first-reaction about an outdated BIOS, I'm willing to follow emphatically.

However, to my knowledge the BIOS code is the very latest.

I have the idea, that the programmers tried to implement too much AI into the BIOS, so that it reacts erratic, when confronted with non-standard assemblies of devices. But I'm speculating here about matters I haven't got a clou about.

Sometimes, having made some settings, I find it corrected afterwards or not performed at all.

And no, I didn't forget to save it at exit.

I hate machines trying to be too intelligent to do, what I want them to do.

No, I'm not going to go esoteric, but is it a silly idea, to consider the BIOS becoming forgetful because of the many changes the machine has to undergo over time, every heavy conflict altering or corrupting parts of the code?

If so, could it help to revive the BIOS by installing the code anew?

If not, I believe there is no solution for my, now without the SSD, castrated machine.

What do you think?

Thanks for your answer


Super User Retired Employee

What do I think? I try not to; it keeps getting me in trouble...

As I said previously, there was an issue reported (I cannot remember (old f@rt) if it was with one of the boards or one of the NUCs) wherein having a very large USB HDD plugged in causes problems booting. My gut is saying that there is a good possibility that this is the problem. Since there is absolutely no chance of seeing a BIOS update that fixes this issue, your workaround (enabling USB optimization) may be your only saving grace (and it *does* save on boot time - which, with all of these drives, is likely lengthy).

As for the SSD issue, I have absolutely no idea what to suggest. I have never heard of an issue like this previously, so have no context. I will ask some of the BIOS engineers that I know...



Along with Scott's comments, what BIOS is on your board? Looking at, I see that BIOS 0100 is the latest from 05/2013. Is this what you have installed? Also, have you checked to see if there are any firmware updates for your SSD? I know OCZ has had quality issues with their drive in the past. Also, you might want to replace your SATA cables to see if there may be a damaged cable preventing the drive from working properly.

Are you using the Marvell controller (Grey SATA ports)? If you are, you might want to plug your SSD into the blue SATA ports which run off the PCH instead.

Community Manager

Hello, All:

Thank your for all your feedback in this thread. Much appreciated the time you have taken to post your inputs.




Dear Scott,

calling yourself an old f@rt, is like carrying coals to Newcastle, because, should that good looking man on the photo accompanying your messages be you, referring to your age, you could be my son. I'm a child from the last years of WWII.

With your conclusions about the USB issue we are on the same level. Also I'm tired of crouching and crawling around the floor, lifting heavy computer cases, changing between 3 different glasses depending on the working distance, when unplugging and plugging cables and sending the cpu cooler fan flying around by the tiniest false move.

Permitting myself this slightly off topic post, I want to thank you very much for your kind care about my PC problems, giving myself now into the able hands of MrMitch, you've recommended me into.

Thank you



Dear MrMitch,

thanks for your interest in my PC problems.

Yes, the installed BIOS is the latest: 0100 but from 05/17/2013

BIOS Vendor Intel Corp.

BIOS Version BHZ7710H.86A.0100.2013.0517.0942

BIOS Date 05/17/2013

BIOS Size 8192 KB

BIOS Starting Segment F000h

DMI Version 2.7

Characteristics - supports PCI

- upgradeable (Flash) BIOS

- allows BIOS shadowing

- supports booting from CD-ROM

- supports selectable boot

- BIOS ROM is socketed

- supports Enhanced Disk Drive specification

- supports INT 13 5.25-inch/1.2M floppy services

- supports INT 13 3.5-inch/720K floppy services

- supports INT 13 3.5-inch/2.88M floppy services

- supports INT 05 print-screen

- supports INT 09 and 8042 keyboard services

- supports INT 14 serial services

- supports INT 17 printer services

- supports ACPI

- supports legacy USB

- BIOS Boot Specification supported

- Enable Targeted Content Distribution

from the

No, the SSDs were never connected to the Marvell controller (grey SATA ports). Both ports of the Marvell controller are occupied by two SATA drives.

The SSDs were never connected both at the same time, because I bought the Samsung EVO 840 250GB after the OCZ Vertex2 120GB was damaged.

And yes, I interchanged the SSD's (blue Intel controller) ports and I exchanged the cable with a new one (a high-quality one, so the vendor said).

Both SSDs were organized in 8 partitions, drive C: to J: with the OS on C:, and the other partitions assigned to installed applications (programs) by cathegories. All other devices (drives K: to U:) are used as storage and backup devices only.

From the very beginning (when I had built the PC) the booting was problematic, as the BIOS didn't bother about the SSD being on top of the boot priority list, but tried to boot from my oldest USB2-HDD, being a former boot device and set to "a", the parameter for "active". I didn't know how to change this other than to interrupt the POST with F10 for the bootloader to appear, then selecting the SSD, containing the OS and being active too.

The ability to boot from USB devices was enabled in the BIOS.

Thus I conclude, the USB devices are booted before the SATA devices.

As things are now, the OCZ is recognized by my older PC (Motherboard = Abit-IP35-Pro). But the OS is slowed down and reacts erratic - same as with the OS on my main PC (the one with the problem). An attempt to write an OS on the OCZ with Acronis, reported an "electrical error" of the SSD.

During the many tries to boot the (main) PC with the EVO 840 attached, first drive D:, then drive E: became unreadable and seemed to me to be deleted. That was when I stopped trying to boot with the SSD on the main PC.

The old Abit-PC booted without any difficulties from the SSD Samsung EVO 840's drive C: into the OS. And also the drives D: and E: reappeared.

So the problem cannot lie in the SSD, but in the PC.

I replaced all drivers for the board with the drivers from Intel downloadcenter: MEI, SATA, USB3, INF and STOR. Only to install the BIOS anew I was too chicken.

The drivers changed, but not the problem.

I hope this informations to help bringing some light into the problem. Should you have some more questions, I'd be happy to provide answers as exactly as I can.


Super User Retired Employee

Well, I still look like the guy in the picture (give or take any new wrinkles that have developed in the last 16 months), but am old enough to have retired (though none of this wait-until-you're-65 ballyhoo). I come from a family that doesn't show their age...

Unless you are a gamer and need the high-end graphics (and your age says you aren't ), the new Skylake NUCs (and especially the new NUC6i7KYK) are such a hot little machines that they can replace that honking big chassis under your desk with a tiny one attached to the side (or stuck to the back of your monitor) and still easily outperform it. Just saying...


Super User Retired Employee

Oops, I forgot to mention...

In another posting, a person with a older board (the venerable Skulltrail) reported that, when he upgraded his graphics card, his system stopped seeing his SSDs. This may provide a clue for your situation. Do you have an older graphics card that you could install to see if your SSD then responds?



Hello, All:

Thank you for all your collaboration on this thread.




Geez, Scott,

you really must hate me. Following your wicked suggestion I gutted two computers by interchanging the graphics cards. The wire clasp, fixing the cpu cooler fan, must be the invention of a brain sick primat.

I also disconnected all other HDDs, but all the trouble did nothing good for the SSD to be recognized by the BIOS. Though perhaps it is recognized but not accepted. Why?

Having read your post once again, I should have using my brain before fidgeting with the graphics cards and a thousand cables and screws, since you said the SYSTEM could not see the SSD of this guy, whilst MY SSD is not be seen by the BIOS, the OS having no chance to look at it.

Seeing myself casting an eye covetously on the new GeForce 1080, a new 4K-monitor 32" with HDCP 2,2 and, despite my age, the "Rise of the Tomb Raider" (including cheating like hell (as a single player)), I'd say, time has come to squander my lifetime savings under the mournful eyes of the kinship and no, no NUC. Though, since I'm not an early adopter, I'll wait on, until the childhood ailments of the respective devices are overcome.

What does MrMitch think of the POST being interrupted at E6 (the LED showing on the mainboard)?

At this special point the BIOS must demand an information from the SSD (which contains the OS) and, getting no or not the correct answer, cannot continue the booting; instead showing the options F2, F7, F10 and then freezes.

After 3 years working perfectly: Has the SSD altered the BIOS or has vice versa the BIOS altered the SSD? What does the POST exactly want to be delivered at E6?

Intel's site "boards-and-kits" says in the table "Port 80h POST codes" "E6 Started connecting drivers". What drivers is here spoken of? Does the BIOS already communicate with the OS (like Windows) at this time, or is this another kind of drivers?

By the way, I've changed the BIOS settings once more by disabling USB Optimization and USB Boot.

Now the PC boots with USB devices attached, provided the double-USB-3-case, where I can tuck in 2 USB devices from above at the same time, is switched off.

This in reality is a docking station and a twofold copy dock with a firmware of its own. Its name is "FANTEC MR-CopyDU3".

I've downloaded a new firmware for this device, providing the ability to handle 4K-formatted drives, but I've been warned off, installing this instantly, by the possibility of data loss.

This issue stays under my watchful eyes - a new big HDD is needed for the 2 HDDs in the docking station to be saved temporarily. As a workaround I switch on this HDD-case only when needed.

What's with this irritating posts of some Amy.

Is this the impersonation of Mother Intel, patting the heads of their children "Well done, little ones", or is it a veiled admonition not to spend too much time on this issues? Weird!


Super User Retired Employee

The E6 POST code means that the BIOS is attempting to initialize all of the drivers provided separately. This includes:

  • If an add-in video card is present, its Video BIOS (provided in OpROM on video card).
  • If an add-in video card is not present, the Video BIOS for on-board/on-chip graphics (provided in flash along with main BIOS).
  • If any board/BIOS special features are enabled, their drivers are initialized (also provided in flash along with the main BIOS). For example, enabling RAID causes the RST driver to be enabled and initialized.
  • Any other add-in cards that include OpROMs - disk controllers, LAN/WLAN adapters, etc. - will be initialized.

Seeing this POST code last means that a problem is occurring in one of these drivers. This isn't going to happen with any of the drivers provided in flash with the main BIOS, so I would look at the add-in cards (especially video)...


P.S. If you are looking at making the jump, here's my input: In the past 18 months, I built X99/i7-5960X, X99/i7-5820K and Z170/i7-6700K systems for my boys. The boards were from Asus, MSI and Gigabyte (no loyalty, obviously; I bought what was priced right (on sale)). Once I was to the point of having Windows installed, I had no issues with any of these boards. I did have XMP overclocking issues with all of them and, in two out of three cases, never got the memory to run at their highest supported profile (not without removing half of the DIMMs). I also thought that none of their BIOSs came anywhere near living up to the hype attached to them (read: ignore the crap stated on the boxes).


Dear Scott,

your very informative post got me an epiphany, and I remembered to having read something about a cell refreshing software, because of increasing performance problems of the SSD EVO 840.

So I downloaded this software from Samsung. By running this on my old PC, the software updated the firmware too.

Now I intended to start my post with "Eureka!", cause my (main) computer booted happily with and the OS from the SSD - 3 times! Then it was same as every day.

A call at Samsung Customer Service raised my hope of a gesture of goodwill by exchanging the SSD.

This could be the solution. If not, I do strike my colors. Next time better luck.

It was nice meeting you!

Thanks for all your care and my best wishes, your hints were very helpful