Intel® Desktop Boards
Peer-to-peer support only
11477 Discussions

My intel extreme DZ77GA 70K no post boot or display and my error code display doesnt work seems like it, nothing responds including my USB


I have a GTX960 G1 gaming windforce and i found one of my old cards i wanted to sli them so i plugged the other card in as well which is a 960 windforce, the pc didn't startup once i plugged it in but it worked before this.


Then i removed my old card left the original one in then tried starting it up, nothing not even from the error display, i tried changing the pcie slot didn't help. I moved my ram around to make sure that wasn't it but the thing is it doesn't even boot at all i can see everything seems to be working besides the error code display, there is power to cpu,gpu everything looks normal but nothing responds not even the power button need to hard shut down.


Please help its very urgent.

0 Kudos
1 Reply
Super User Retired Employee

Adding the second graphics card may have caused a failure of some sort. Not seeing POST codes is an indication that the BIOS is not proceeding through POST.


What happens if you press the Back-to-BIOS button?

Have you tried unplugging system and removing the CMOS battery for 15 minutes?