Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,081 Views

No video (HDMI or DVI) from DH87MC desktop board

I have built a PC with an Intel DH87MC board and an Intel i7-4790 CPU. On power up, fans spin up, and the board power led is on, usb ports seem to be functioning, judging by the led light on connected usb keys. However, there is no video on the connected display (ASUS VS247H-P, which works perfectly well with other pc). I have tried connecting via DVI as well as HDMI, in both cases with no success. Also, there is no light in the power led on the case, and the power button does not seem to work (does not turn the system off when pressed). The Case is an Antec Three Hundres Two. I have checked the connection of front panel cables to the board as well as other cable connections and RAM seating.

The lack of monitor video makes it impossible for me to make any changes to bios settings.

Any help would be greatly appreciated.

Best wishes

JeppeArne

0 Kudos
4 Replies
Highlighted
Employee
15 Views

Thanks for joining the Desktop Board community.

It seems to be a problem during integration.

Does the motherboard beep three times without memory?

Did you connect the processor 12V cable?

Make sure you are using straight video cables, no adapters, DVI to DVI or HDMI to HDMI.

Here is more information available to try to sort this out: http://www.intel.com/support/motherboards/desktop/sb/CS-010254.htm Desktop Boards — Troubleshooting System No Boot Issues

Allan.

0 Kudos
Highlighted
Novice
15 Views

@Allan:

You give him correct advice for usual cases of non booting systems, but you completely overlook, that the i7 4790 just isn't compatible to the DH87MC.

@Intel:

Don't you guys think that it's time to give the thousands of series 8 board users the support for haswell refresh CPUs?

Best regards from Switzerland

Pik11 (User of three DH87RL)

0 Kudos
Highlighted
Beginner
15 Views

Thank you for your reply, Allan.

I'm not sure what you mean by integration.

No, I hear no three beeps (actually no beeps at all), neither with or without system memory installed.

Yes, I have connected the 12V processor cable.

Yes, video cables (HDMI and DVI) are straight, and no adapter is used.

I have noticed that the red LED termed "N PROCHOT LED" is on for just a split second, as I turn power on and also asI turn it off. The processor fan runs constantly as long as power is on. Chassis fans (rear and top) do not run at all, when they are set to Low. When they are set to High, the top fan runs, at least for some time, the rear fan does not. Both fans move (very slight jerk) as the system is turned on and off, regardless whether they are set to Low or High.

JeppeArne

0 Kudos
Highlighted
Employee
15 Views

I have just checked the list of compatible processors for your motherboard model and indeed the processor is not compatible for your board. pik11 was right.

Please take a look compatible processor here: http://processormatch.intel.com/Processors/CompatibleProcessors?componentName=DH87MC Compatible Processors

Allan.

0 Kudos