Intel® Desktop Boards
Peer-to-peer support only
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
11360 Discussions

PC fails at POST after installing new Video Card

mmacqueen79
Beginner
642 Views

Hi all,

I'm trying to install a Sapphire Radeon RX 580 on a DP67BG Intel mobo.  Unfortunately it's failing during post and I'm getting the post error EB - Calling Video BIOS.  I'm tried to download the supported drivers and installed it first but unfortunately AMD won't allow me to preload the drivers the AMD Adrenaline software fails because it does not detect the proper video card.  Has anyone dealt with this or am I out of luck?

0 Kudos
1 Solution
n_scott_pearson
Super User Retired Employee
507 Views

This is a compatibility issue and I rather doubt you will get it working. For the past couple of years, I have had little success getting the more-modern AMD graphics cards to work on these older systems. AMD is doing something or expecting something in their Video BIOS that is simply not compatible with the board's BIOS -- or perhaps it has something to do with the backwards compatibility of their hardware (i.e. PCIe 3.x to PCIe 2.x). Whatever this is, no one knows. The board was discontinued and the desktop Boards development group shutdown long before any reports of these compatibility issues were received -- and thus there have never been any BIOS resources to investigate the problem. I will say that folks have had a lot more success with NVIDIA cards, however. I use a GTX 750ti with my DZ68ZV board.

Sorry,

...S

View solution in original post

4 Replies
AlHill
Super User
639 Views

Are you booting legacy or UEFI?

What bios do you have on the DP67BG?

Doc

mmacqueen79
Beginner
584 Views

Here is my BIOS info running UEFI

mmacqueen79_0-1596063771344.png

 

n_scott_pearson
Super User Retired Employee
508 Views

This is a compatibility issue and I rather doubt you will get it working. For the past couple of years, I have had little success getting the more-modern AMD graphics cards to work on these older systems. AMD is doing something or expecting something in their Video BIOS that is simply not compatible with the board's BIOS -- or perhaps it has something to do with the backwards compatibility of their hardware (i.e. PCIe 3.x to PCIe 2.x). Whatever this is, no one knows. The board was discontinued and the desktop Boards development group shutdown long before any reports of these compatibility issues were received -- and thus there have never been any BIOS resources to investigate the problem. I will say that folks have had a lot more success with NVIDIA cards, however. I use a GTX 750ti with my DZ68ZV board.

Sorry,

...S

View solution in original post

mmacqueen79
Beginner
472 Views

No worries, I was thinking the same thing.  There's only so much you can do I'm just happy I have a 9 yo PC that still runs great.

Reply