Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
360 Views

PC fails at POST after installing new Video Card

Jump to solution

Hi all,

I'm trying to install a Sapphire Radeon RX 580 on a DP67BG Intel mobo.  Unfortunately it's failing during post and I'm getting the post error EB - Calling Video BIOS.  I'm tried to download the supported drivers and installed it first but unfortunately AMD won't allow me to preload the drivers the AMD Adrenaline software fails because it does not detect the proper video card.  Has anyone dealt with this or am I out of luck?

0 Kudos

Accepted Solutions
Highlighted
Super User Retired Employee
225 Views

This is a compatibility issue and I rather doubt you will get it working. For the past couple of years, I have had little success getting the more-modern AMD graphics cards to work on these older systems. AMD is doing something or expecting something in their Video BIOS that is simply not compatible with the board's BIOS -- or perhaps it has something to do with the backwards compatibility of their hardware (i.e. PCIe 3.x to PCIe 2.x). Whatever this is, no one knows. The board was discontinued and the desktop Boards development group shutdown long before any reports of these compatibility issues were received -- and thus there have never been any BIOS resources to investigate the problem. I will say that folks have had a lot more success with NVIDIA cards, however. I use a GTX 750ti with my DZ68ZV board.

Sorry,

...S

View solution in original post

0 Kudos
4 Replies
Highlighted
Super User
357 Views

Are you booting legacy or UEFI?

What bios do you have on the DP67BG?

Doc

0 Kudos
Highlighted
Beginner
302 Views

Here is my BIOS info running UEFI

mmacqueen79_0-1596063771344.png

 

Tags (1)
0 Kudos
Highlighted
Super User Retired Employee
226 Views

This is a compatibility issue and I rather doubt you will get it working. For the past couple of years, I have had little success getting the more-modern AMD graphics cards to work on these older systems. AMD is doing something or expecting something in their Video BIOS that is simply not compatible with the board's BIOS -- or perhaps it has something to do with the backwards compatibility of their hardware (i.e. PCIe 3.x to PCIe 2.x). Whatever this is, no one knows. The board was discontinued and the desktop Boards development group shutdown long before any reports of these compatibility issues were received -- and thus there have never been any BIOS resources to investigate the problem. I will say that folks have had a lot more success with NVIDIA cards, however. I use a GTX 750ti with my DZ68ZV board.

Sorry,

...S

View solution in original post

0 Kudos
Highlighted
Beginner
190 Views

No worries, I was thinking the same thing.  There's only so much you can do I'm just happy I have a 9 yo PC that still runs great.

0 Kudos