Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,548 Views

PS/2 Keyboard not working in Windows7 after BIOS update but works in linux

Hi,

My system specs: i5-2320

Motherboard: Dh61WW

RAM: 4 GB

I recently updated my Bios from 0048 to 0099. After update my pc dint start (many users had problem of boot failure after update to 0099). So then i updated it to 0109. Pc now works but since then my PS/2 Keyboard is not working partially.Tried updating to 0111 and 0113(latest at present) but still problem is same

When I start Pc, I can enter Bios menu by pressing the key, but once Bios opens, I cannot use my keyboard (surprisingly, usb mouse works in bios,vich, before update dint used to work.). Same with boot sequence menu,i can enter but cannot select nething as keyboard stops working. If I dont enter Bios or boot menu, I come to a screen where i ve to select the os vich i want to start (I ve windows 7 and ubuntu dual boot options) I can use keyboard to select an option i.e keyboard works at this point. If i go to ubuntu, keyboard works perfectly fine. But if i select windows 7, Keyboard stops working. In device manager, the keyboard option isnt seen only..

if i update Bios, Keyboard will work when it restarts 1st time after bios update, but if I shut down or restart again, It wont work. So,if i want to use a keyboard, I ve to update bios everytime i start pc( doesnt matter even if i install same version of bios).

Also, I tried resetting bios configuration via battery removal, jumper reset method but dint help. Installing windows 7 or windows 8 doesnt work.I already tried it.

Jus after I updated bios,keyboard was detected in bios (pic attached)

But after I restarted pc, Keyboard is not detected (pic).. As u can c, der is no Keyboard detected in device manager.

Sometimes I get such msg (pic) but if i select "restart now", again same problem occurs.

I tried resetting bios configuration via battery removal, jumper reset method but dint help. Installing windows 7 or windows 8 doesnt work.I already tried it.

Please help me to solve this problem.. Thanx in advance.

0 Kudos
3 Replies
idata
Community Manager
188 Views

Hello taral,

Here are our recommendations for this issue:

- Proceed with a BIOS recovery update to latest version 0113:

http://www.intel.com/support/motherboards/desktop/sb/cs-022312.htm Desktop Boards — BIOS update instructions

- After the update is done, reset any customized settings in the BIOS.

- If the issue happens in Windows environment only, you can try a clean installation of the Operating System using the latest drivers from our website:

https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Desktop+Boards&ProductLine... Download Center

- Test with a different keyboard if possible to ensure is not a compatibility issue with it.

idata
Community Manager
188 Views

i tried recovery but it dint help.. dis keyboard works fine with other computers..also it worked before bios update..i found that in system drivers, kernels for keyboard are not working.(pic attached)

when keyboard works, i.e. after starting 1st time after bios update,those 2 services are runnin (pic attached)

is der a way by which i can start them during boot? i guess it would be helpful to solve the problem

Silvia_L_Intel1
Employee
188 Views

Hello Taral,

We recommended you to test a regular keyboard on this motherboard and use it for a day.

If you have the same behavior, you would need to replace the motherboard.

regards,

Reply