Intel® Desktop Boards
Peer-to-peer support only
11479 Discussions

Problems with Intel Desktop Board D2700DC

Community Manager

Hello all,

I have bought an Intel Desktop Board D2700DC, but I didn't get it working.

When I switch it on it always does a single beep (which in my opinion means everything is allright), but I didn't get any video output (on both outputs).

I tried disconnecting every hardware and even tried two diffrent power supplies. But the error still occurs.

When I made an BIOS Flashing, I have had the right video output, but on the next restart (jumper back in normal position) there is no video output as before.

The power supply I have tried, has 800W so I think that must be more than enough.

When I leave all RAM outside, I get the correct "beep-code" for memory error.

My RAM is: Corsair Value Select PC1333

I appologize for my english, its not my native language.

Many thanks in advance.

Best regards



0 Kudos
2 Replies
Community Manager

Hello Sascha,

Here are our recommendations to narrow this issue:

1. Test the system out of the chassis on a minimal configuration. If you have a cooling fan connect it to the fan header to check if you are having any fan activity.

2. Remove the RTC (Real Time Clock) battery and leave it out for 20 minutes. After this period of time, insert the battery back in and turn the system back on; if it displays POST messages, go into BIOS Setup Utility by pressing during the boot process. Once in the BIOS setup utility, press to restore BIOS default settings. Reset any customized BIOS settings. Clear all DMI event logs, which are located in the Advanced/Event Log Configuration section of the BIOS Setup utility. Press to save the new settings and reboot the system.

If the issue still persists, check your warranty options to replace the board.

Community Manager


thanks for your fast answer.

1. I have checked it with minimal configuration. And I have fan activity. The backlight of my keyboard is also active.

2. I took the battery out for 20 minutes. The screen remains still black (I checked the connection to my monitor but it gets no signal). I now tested it only on the DVI-port. Could it be different on the HDMI out?