Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11461 Discussions

RST Raid-1 Degraded then I did something wrong

New Contributor I


Running Win7-64bit, DZ77GA-70K. My RAID 1 volume degraded with a error on drive 1.

Setting the drive to normal did not fix the problem.

I did not have Hot swap enabled before the drive failed,

Reading the RST troubleshooting instructions it looked like all I needed to do was to power down and install a new drive with the exact same model # .

However when I restarted the system I got the BSOD after the windows start screen appears .

I tried the Windows Startup Repair/RecoveryTools/Startup Repair and I dont think that did me any favors because now the operating system is not listed.

During BIOS Boot both drives are normal and however the volume 1 is degraded

Now if I select "start windows normally" check disk will not run indicating it cannot access the drive directly.

When I open Command Prompt the Administrator: x:\Windows\system32\cmd.exe and the Drive is X:\windows\system32>.


More New Info Add:

my RAID-1 is accelerated with a SDD (168GB total with 64GB Cache & 103GB Data Volume) and I assume the system starts the boot process from the SDD and the issue is accessing the HDD Volume that is degraded.

I also tried changing the comand prompt to "C" drive but it states "The system cannot find the drive specified"

Also, Durring BIOS boot the "Rapid Storage Technology - Option ROM" screen now shows: " * accelerated Disk/Volume "

RAID ID = "0" Volumes Name = "RAID Data Volume = 103GB" status = "Normal" bootable = "Yes", Physical Device ID = "0" SDD Cache Disk(0,1).

RAID ID = "1" Volumes Name = "RAID 1 Cache = 64GB" status = "Normal" bootable = "No"

RAID ID = "*2" Volumes = "RAID 1 Volume" status = "Rebuild" bootable = "Yes", Physical Devices " *2 & *3 " the 2ea. 1.8TB HDD's Status = "Member Disk. (2)"

The comment at the bottom: Volimes with "Rebuild" status will rebuild within the operating system.


So before I sink the ship I thought I would ask for help.



Message was edited by: Rodney Moore

0 Kudos
7 Replies

Thanks for coming back to the community.

I see you have a problem with RAID 1 shows as degraded state.

The problem is that you needed to replace degraded disk then access the operating system and let your operating system to rebuild by itself or enter the Intel® Rapid Storage software and modify the RAID volume within rapid storage options.

At this stage, you can try to reset disks to non RAID and recreate structure again, data is still on one of the drives, however, acceleration will not work and you will need to re-accelerate




New Contributor I


Thanks for the reply.

So I should have just Hot Swaped/Pluged the drive even though the Hot Swap was not enabled?

It is always easy to see some of the mistakes after the systen is down.

Could you please provide some basic steps?

Once I can get wWndows back up I can work through setting up the RAID again.

It has been more then a year since I setup the system w/RAID 1 and my documentation is on the system.

That I remember the BIOS SATA will stay as RAID?

Do I need to change the setup in RST (ctrl-I) setup during BIOS boot or just disconnect the SDD and/or second HDD.

Use the Windows Install Disk and Command Prompt to fix the C: MBR or other boot files?

Thanks in Advance for your Help,



Thanks for coming back to the community.

By resetting disk to Non-Raid, you will need to enter CTRL-I (Raid BIOS) and select disk you like to take out of the RAID structure.

You do not need to change SATA status, leave is as RAID.

Since this was RAID 1, there is no need to fix MBR or boot files, windows will boot up.


New Contributor I


Thanks Again.

Foregive me for being overly cautious so before I Reset Disk to Non-RAID in RST ROM, as I don't want to loose the files on either of the disks so I want to ask another couple of questions.

Once I get windows to start I will be much more comfortable.

1) When I enter the Reset RAID Data window there is a "warning: resetting a disk causes all data on the disk to be lost." Is this true for a RAID 1 (mirror)?

Or will the drive still contain the file structure & data files after it has been removed from the RAID?

Also could the drive removed from RAID Volume 1 be swapped back in to replace the non-RAID bootable C:drive that I will be using to start windows, hence either drive can be used to attempt a Non-RAID of my repair windows startup problem?

2) I would seem my system can only booting from the SDD since if I disconnect the SDD the system fails with no bootable drive. When I reconnect the SDD the system boots and if I go into Recovery Tool - Command Prompt - X:\windows\system32\ and enter The device is not ready. Drives D: & E: are my DVD drives.

Is C: not ready caused by the RAID Status = Rebuild?

I get the same C: drive not ready with the Win7(64bit) install DVD command prompt.

Also, when I select "Start Normally" with RAID status = "Rebuild" (both drives still in RAID Volume 1) after the "starting Windows" screen, Check Disk starts & fails with: 'cannot access volume directly' and when CD screen closes the BSOD opens;

BSOD Technical Info: ***Stop: 0x000000F4 (0x0000000000000003,0xFFFFFA801E077B30,


0xFFFFFA810E077E10, 0xFFFFF80003F957B0)

Thanks for your support and patience,



Let's see if you can get this system back and running again.

Please bear in mind the warning message will apply for any other type of RAID. For mirror drives this does not happen. Data files are still on the drives once you reset them to Non-raid.

It is recommended to do backups once in a while, you know, to prevent this type of issues. If your mirror drive was bootable, this it will boot to the operating system.


New Contributor I


I reset Disk to non-RAID (Drive ID # 3 is now "non-RAID Disk) and the RAID ID: 2, Raid-1 Volume 1, Status = Degraded, Bootable = Yes.

I booted the system and with the Windows Error Recovery screen I select "Start Normally" then after the "starting Window" screen the BSOD appears.

Then from the BIOS I changed the boot device sequence from the SDD (RAID ID: 0, RAID Data Volume, Level = Stripe, Strip = 128KB, Size = 103GB, Status = Normal, Bootable = Yes), to the RAID ID # 2, RAID-1 Volume and and after the "starting Window" screen Check Disk starts but "cannot directly access the volume" exits and after a 10 sec. delay with a blank display the BSOD appears.

I started the system Recovery Tools and it immediately indicated corrupt files and recommends Check Disk.

I cancel through the errors and enter Command Prompt:


Volume in Drive C: is System Reserved


Volume in Drive D is RAID Volume 2


Volume in Drive E is Win7 Programs (includes Windows folder)


Volume in drive F is RAID Data Volume 1

However, I could not get past the BSOD............


Edit to this reply:

Before the disaster the System Reserve partition did not have a drive letter and the Win7 Programs was C: and D: was RAID Volume 1, F: Raid Volume 2, so as you can see the logical drives are all mixed up.

Also, when I start System Recovery Options again it now searches for a Windows installation and wants to repair the problem it found:

name: {Bootmgr}

Startup options will be added:

name: Windows Recovery Environment (recovered)

Path: Recovery\97836fb3-xxxxx-xxxx----xxxxxxx\winre.wim

Windows Device: Partition=E: (614400MB)

A copy of current boot config date saved as: c:\boot\BCD.backup.0001

Also, also, if I disconnect the SATA port 3 drive, the non-RAID drive, that is no longer part of the RAID-1 Volume and reboot all the logical drives in Command Prompt show as: "device is not ready" when I change to C:, D:, E:, F:???

While the CMOS BIOS & RST ROM :SDD and RAID-1 Volume remain the same status as with SATA port 3 drive attached, this is the most confusing of all the issues so far.

I have no desire to REPAIR the startup problem with the system folder in E: and/or with all the other logical drives swapped around for all the confusion that will create once Windows opens!!

I anticipate the logical drive letters could be changed in command prompt if they were available however why would I get a Not Available with the 180GB SDD and one 1.8TB HDD attached to the RAID!

Anyway, after 30 years of casual non-professional PC system building/configuration experience from the IBM Blue double floppy IBM-DOS system to my current Intel DZ77GA-70K w/Win7(64bit) I think this will be the last time I try System Recovery Options: Startup Repair.


Thanks Again,


Message was edited by: Rodney Moore

New Contributor I

I got my RAID back up yesterday.

So, after a long relationship with the Systems Recovery Options - Startup Repair - Command Prompt - DiskPart, Bootrec commands and not getting anywhere with changing the drive letters, such that I setup the Systems Reserve partition without a drive letter and the Win7 partitions assign to drive letter C:) just to have the next boot attempt change them back to the way they were (all mixed up).

I changed my strategy:

This started out as a hardware problem so I should change the hardware to see if that was the solution.

1). I had already taken the second drive out of the RAID-1 Volume and RAID status was back to Degraded (instead of Rebuild from adding the new drive).

2). I deduced the System was booting from the RAID Cache (SDD) so I needed to remove the Acceleration of the RAID in order to regain control over the system boot process using only the HDD-Disk 0.

Well that did it.

After disabling the Acceleration in the RST-ROM, I pulled the port cable and the system boot process changed and went directly onto the Startup Repair process and after analyzing the problem it suggested I allow changing the Win7 partition to E:. I knew that was not correct or what I wanted so I selected no and the boot continued with the Starting Windows screen and then into Login Screen.

Once I logged in I checked Disk Management, all was normal so I opened RST and I added the replacement drive to the RAID Volume and rebuilt the Volume.

After 5-6 hours the volume was rebuilt and I rebooted with the SDD port cable connected and re-enabled the Acceleration.

Boom I'm Done

What I take away from this exercise is to disable the Acceleration (SDD cache) when attempting system startup repairs!!

I anticipate once the boot record got hosed on the SDD the system kept booting from the Cache and no matter what I or the Start Repair utility did with the MBR, BCD, Bootmgr on Drive 0 the Cache would re-Sync the HDD boot record to the Cache values and that keep the system from booting normally.

Allan thanks for your suggestion as they got me started.

Also, over the years I have tried a bunch of back-up utilities and hardware.

IMHO, all but a few have been difficulty to use, maintain and the good stuff is expensive and becomes obsolete quickly as the system storage size dramatically increases.

That is 20 years ago the first workstation with SCSI drives I built had a couple of 1GB drive and they cost a mint (like $1k each) and the HP 24Gb backup DAT drives were also expensive.

The only way I successfully maintained back-ups for years was to manually copy my personal and system config files to a spare drive on my system.

However, that is no longer feasible due to the number and size of my personal files so I'll need to select a good back-up utility and maybe a NAS.