Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BF_
New Contributor II
1,007 Views

Renesas USB3 driver causing a lot of Registry activity (DZ68BC)

For anyone who's installed this driver, do you happen to see a stream of Registry access ever 3 seconds with Process Monitor? It's pretty blatant here, and it's clear that it's tied to USB3 because of references such as "NUSB3\ROOT_HUB30" and since the access stops when the driver is uninstalled. Both versions that I've tried (2.1.28.0 and its predecessor) show the problem (I never tried earlier ones). Note that I don't actually have any USB3 devices yet or I'd hook one up to see if anything changes.

Svchost.exe is the process doing the accessing. This particular one is responsible for DCOM Server Process Lanucher, Plug and Play (which I'm guessing is the one involved here), and Power. I can't believe this is intentional behavior.

0 Kudos
1 Reply
BF_
New Contributor II
83 Views

I discovered that it was the Renesas startup app -- nusb3mon.exe -- that was responsible for this.

According to the http://www.station-drivers.com/telechargement/nec/divers/RENESAS%20uPD720201%20and%20uPD720202%20Dri... manual for it, the app is only used in two situations:

1) A USB3.0 capable device is connected to a port on the USB3.0 Host Controller via a USB2.0 hub or USB 2.0 cable.

2) A Lack of bandwidth for Super Speed (SS) periodic transfers (Isochronous and Interrupt) for a port on our Host Controller was detected. This is only for super-speed periodic devices. To produce this situation, multiple super-speed isochronous devices are required. (Currently there are no SS isochronous devices.)

Reply