Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
9,698 Views

Right Click on Desktop causes Delay because of igfxsrvc.exe

Hello,

the process igfxsrvc.exe is apparently part of the Intel Common User Interface and in use/started when I perform a right click on the desktop which causes an annoying delay of about 2 seconds while opening the context menu.

What is that process for?

Can I disable it or is there another way to avoid the delay?

OS: Windows 7 64 bit Home Professional

Graphics Driver: 15.31.17.64.3257

Motherboard: Intel DQ77KB (processor i3 3220)

Tags (1)
0 Kudos
47 Replies
Highlighted
Valued Contributor III
188 Views

The igfxsrvc module or igfxsrvc.exe is part of Intel(R) Common User Interface for our Intel® Graphics Media Accelerator or Intel® HD Graphics drivers, this allows you to get access to the graphics driver user console.

How much delay are you seeing in the system and how did you determine that this is related to the video drivers?

What troubleshooting steps have you done at this point to try to resolve this issue?

 

 

0 Kudos
Highlighted
Beginner
188 Views

Hello,

Diego_Intel schrieb:

The igfxsrvc module or igfxsrvc.exe is part of Intel(R) Common User Interface for our Intel® Graphics Media Accelerator or Intel® HD Graphics drivers, this allows you to get access to the graphics driver user console.

How much delay are you seeing in the system and how did you determine that this is related to the video drivers?

 

The delay is about 2 seconds. I opened the Windows TaskManager and observed the tasklist while doing a right click on the desktop and I saw igfxsrvc.exe starting in this time. Then I closed igfxsrvc.exe and repeated the procedure with the same result.

And if I remember correctly, the delay did not occur before I've installed the driver.

 

 

What troubleshooting steps have you done at this point to try to resolve this issue?

 

I've posted my message here, that's it.

 

 

regards, Christoph

0 Kudos
Highlighted
Novice
188 Views

i have your problame same!

0 Kudos
Highlighted
Novice
188 Views

hey men! u can solve this problem of a difficult way! go to this address in registry: HKEY_CLASSES_ROOT\Directory\background\shellex\ContextMenuHandlers

and delete this folder and value "igfxcui" and after this your right click menu worked very well !

Highlighted
Beginner
188 Views

@azetrom:

Aaaaaaah, what a relief! Thank you!

Of course it was still nice, if Intel fixed the issue.

0 Kudos
Highlighted
Valued Contributor III
188 Views

What this has caused is that it removed the access to the Intel(R) Graphics and Media Control Panel. You may use it as a temporary fix in this case. From my side, as soon as I have an update on a permanent fix, I'll let you know.

0 Kudos
Highlighted
Beginner
188 Views

Hello Diego_Intel,

the installation fails with the error message "Your system does not match the requirements." (freely translated). I think it is because I have HD2500 graphics on my i3 3220 and the driver is for 2nd generation chips with HD2000/3000 graphics.

But thanks for your fast reaction anyway, I feel sorry for it doesn't work for me.

regards, Christoph

0 Kudos
Highlighted
Valued Contributor III
188 Views

Good point Leviathan, sorry for not carefully checking that before. Could you please try this one instead?

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23405&keyword=3345&DownloadType=Driv... Download Center

0 Kudos
Highlighted
Beginner
188 Views

This one worked!

Regarding your effort I feel sorry to state, that the delay is still there and annoyingly long.

0 Kudos
Highlighted
Valued Contributor III
188 Views

Thank you, I have forwarded your feedback for further research. We'll keep you posted.

0 Kudos
Highlighted
188 Views

Hi everyone,

First off I would like to say that if you have tried the above work-around, you'll notice that you lose the ability to navigate to the Intel Graphics Control Panel from the right-click desktop menu. If you would like to restore this functionality, simply re-install the driver (you do not need to uninstall the existing driver to re-install over it).

However, you can still access the Intel Graphics Control Panel by doing the following;

  • Using the program file that was added upon installation, you can find this in your Programs menu or via search
  • Pressing Ctrl+Alt+F12
  • Start -> Run -> gfxuiex.exe

At this time I would also like to inquire with those of you who still have the issue with slowness. Specifically I would like to ask if you still see the same issue after doing the following;

  1. Start -> Control Panel -> Device Manager
  2. Right click the Intel® Display Adapter -> Uninstall -> Select checkbox for 'Delete the driver software for this device.'
  3. Reboot
  4. Repeat steps 1-3 until the Display Adapter shows as "Microsoft Basic Display Adapter"
  5. Re-install the latest driver from the Intel® Download Center for your product

Do you still have the slowness when accessing the context menu? The above steps are for removing all of the existing driver files. It might be possible that if you have installed multiple drivers over the course of your operating system installation that there could be interference. I personally do not have any hard drives with OS's that have been installed longer than a month or so, and thus I am not experiencing any latency when accessing the context menu. I have checked on Windows* 7 32 & 64, Windows* 8 64 and Windows* 8.1 64 - this has not been an issue for me.

Let me know if the above steps resolve your issue or not

Thanks!

-Nic

0 Kudos
Highlighted
Beginner
188 Views

Hello Nic!

Thank you for your backup plan for accessing the Intel Graphic Control Center! Also there is a link in the Windows Control Panel.

I have tried your suggestion but it was quite frustrating, to be honest and in the end it did not solve the delay issue.

1.There is no "Intel Display Adapter" in my Device Manager. I executed your advices for "Intel HD Graphics" under the item "Graphic Card" instead.

2. The current graphic driver from Intel causes a security conflict with Windows: Whenever I start a Windows session several pop ups appear asking for permission for several Intel programs.

So deinstalled this driver, right clicked on the zip I have downloaded and opened properties in order to set this downloaded file to be considered trusted in the section "General", unzipped it, installed the driver but the same problem occured.

But there was ONE bright moment and perhaps the crucial hint. After I've installed the latest Intel driver and was prompted to reboot to finish the installation, Windows showed a message that the "Desktop Manager" was deactivated. And at this point, there was no delay although the Intel items were shown in the context menu! But after the reboot I had the delay problem again.

So, thanks for your work anyway, I hope my feedback is useful to you.

0 Kudos
Highlighted
188 Views

Hi Leviathan,

You were seeing error messages when installing our driver? Can you tell me specifically what they said or provide screenshots (only do the screenshots if they are in English please!). Additionally, have you tried using the Manual Driver Installation method to install the driver? Simply uninstall the driver again until you are back to the Microsoft Basic Display Adapter, and then follow these instructions; http://www.intel.com/support/graphics/sb/CS-033915.htm Graphics — How to manually install a driver in Microsoft Windows* 7

Thanks!

-Nic

0 Kudos
Beginner
188 Views

Hi Nic,

I have installed the driver manually but this did not fix the delay issue. There were no warnings this time.

The warnings (not error messages) only asked me whether I trust the manufacturer of the software and at the beginning of these several pop ups I had to grant administrator rights. This happened after I've installed the driver by executing "setup.exe".

I had this issue with Intel's USB 3.0 driver before and it was solved by "trusting" the source of the downloaded zip file. For this I had to right click on the zip, open "Properties" and click the button next to the warning "This file is downloaded from the internet...".

0 Kudos
Highlighted
188 Views

Hi Leviathan,

Sorry for the delayed response. It would appear that it is expected behavior that there be a minimal amount of lag on the right click context menu - since it does in fact start the igfxsrvc.exe. However, even after testing this in house with various systems (3rd gen, 4th gen, on Windows* 7 and Windows* 8.1), the lag was extremely minimal. Usually less than 2 seconds, and that was only for the first/initial right click, after that it was not visibly laggy. To top it off, it would appear that this issue was addressed a long time ago with the same work around we provided to you. http://www.intel.com/support/graphics/sb/cs-003927.htm Graphics — Removing The Right-Click Desktop Menu

Let me know if you have any questions.

Thanks,

-Nic

0 Kudos
Highlighted
Beginner
188 Views

http://www.windowspasswordsrecovery.com/windows-boot Windows Boot Genius can help us fix many pc problems! Such as pc freezing, crashing, BSOD, black screen, etc.

0 Kudos
Highlighted
Employee
188 Views

Thanks for sharing this information.

0 Kudos
Highlighted
Beginner
188 Views

I also experience long delay when I right-click on desktop on latest intel drivers 10.18.10.3496

Problem wasn't present when I had installed graphics driver provided from Windows Update. However, using driver from Windows Update I had http://vip.asus.com/forum/view.aspx?board_id=1&model=Z87-PRO&id=20130911061614945&page=1&SLanguage=e... "High Definition Audio Device" (with the yellow flag) listed in Device Manager, but installing 10.18.10.3496 from Intel fixted yellow flag issue in Device Manger. Now I have to deal with annoying right-click delay.

I tried deleting igfxcui from regedit, but it made no difference regarding delay as suggested. Intel context menu was still present. I tried deleting "igfxDTCM" in HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\ and that fixed lag and removed Intel context menu. Is it OK to delete "igfxDTCM" entry? Is there any better workaround?

When will Intel fix this annoyance?

My computer has Intel HD 4600 graphics.

0 Kudos