Intel® Desktop Boards
Peer-to-peer support only
11478 Discussions

SATA ports on my DP67BG


I have one blue SATA with 2 ports working, but my 2 other black SATA  with 4 ports do not work.

Is there any software installations, or any configuration on the bios to get theese 4 ports working ?

0 Kudos
12 Replies
Super User Retired Employee
What BIOS version are you running?
What O/S are you using?

My bios version is 7/17/2012
My OS is Windows 7 Enterprise

Super User Retired Employee

Ah, BIOS 2209.

Send us a snapshot of what Device Manager looks like when you first open it. Are there any entries in Device Manager that have yellow exclamation marks on them? Are there any unresolved entries/unknown devices?

Have you installed the INF Update package?

Please download and run the Intel System Support Utility for Windows and have it save the report to a file. Then, using the Drag and drop here or browse files to attach dialog below the edit box for the body of your response post, upload and attach this file to the response post.




I hope I have understood what you are asking for, and I do appreciate your effort.

Summary view.PNG

Detailed view.PNG

Device manager.JPG

Super User Retired Employee

So, first of all, I am seeing a potential issue. What I need you to do is, from power on or reboot, use F2 key to enter BIOS Setup. Then, scroll down and select the Advanced System Information option. Scroll down to the end of the information list. At or near the end of the list is an entry that displays the ME firmware version. If this is set to or is blank, then the ME is not operating. This is bad. Amongst other things, it means that a portion of the processor and chipset initialization is not being performed. If this is the case, then you need to reinstall the latest BIOS version, but this time using the jumper-based BIOS Recovery process. This process is documented here: Intel Desktop Boards BIOS Recovery Instructions. Further important information is available here: Updating the BIOS to Support 3rd Generation Intel Core Processors. I can provide step-by-step instructions if you like - but check the ME state to see if this is necessary first.

To ensure that the latest SATA driver and optimal driver configuration is running, I suggest that you reinstall the Chipset Device Software (a.k.a. INF Update) package. I have attached this package as a ZIP file. Extract it to a temporary folder. Open a Command Prompt Window and then change directory to the temporary folder. Execute the package install using command line: "SETUP -OVERALL" (which causes all files to be reinstalled). Reboot when this is complete. Finally, delete the temporary folder.

Next thing I see is that you are missing some USB drivers. I have also attached the package for installing these drivers. Like above, extract the ZIP file to a temporary folder and then execute Setup.exe. Reboot when this is complete. Finally, delete the temporary folder.

Aside: You can combine these two processes so that only one reboot is necessary.

Let me know how it goes and whether it recovers the SATA functionality...



You are very helpful, but I am still very nervous. Can I perhaps destroy the pc ? Are there any posibilities to save the old bios for safety as a backup ?
You said "..scroll down and select Advanced "  There are no such selection in my bios.

Super User Retired Employee

There *is* such an entry in your BIOS. It will be Advanced System Information, Additional System Information or something similar to that. 

To make it as simple as possible, here are my step-by-step instructions for performing BIOS Recovery:

  1. NOTE: Read these instructions completely before starting. Follow all instructions EXACTLY.
  2. On some other Windows-based PC, make sure that you have the .BIO file for the BIOS release you wish to install.
  3. Insert a 32GB or smaller (the smaller the better) USB 2.0 flash drive into the PC. Do not use USB 3.0 flash drives (most are not compatible). It is also best if you use a flash drive that has an access LED that you can watch.
  4. Format this USB flash drive using the Windows Format applet. Select to install the FAT32 file system (NOT vFAT, NOT exFAT; FAT32 only). You must also specify that the Quick Format option be Disabled (unchecked).
  5. NOTE: If FAT32 is not offered as a choice by the Format applet, your flash drive is too big; use another.
  6. Copy the .BIO file into the root folder of this USB flash drive. This should be the only .BIO file in the root folder of the USB flash drive.
  7. Properly eject the USB flash drive. Do not just yank it out. Do this from File Explorer or using the Safely Remove Hardware and Eject Media System Tray applet.
  8. Power off the Desktop Board system.
  9. Remove the yellow BIOS Configuration jumper from the board. It will be the only yellow jumper; the rest will usually be black.
  10. NOTE: Remember the pins that this jumper was plugged onto; you will need this information later.
  11. Plug the USB flash drive into one of the black USB 2.0 ports on the back panel of the board. Do not use blue or yellow USB 3.0 port. Do not use any front panel USB ports.
  12. Power on the system.
  13. The BIOS Recovery process should start automatically. You should see a progress report on your main monitor.
  14. NOTE: If you do not see a progress report displayed on a monitor, do not power off the system for at least 15 minutes. While it is rare, it is possible for the process to proceed without an onscreen display; you must give it ample time to complete, just in case.
  15. When the BIOS Recovery process is complete, you will be asked to power off the system. Do so.
  16. Restore the yellow BIOS Configuration jumper to the pins it was on previously. This should be across pins 1 and 2 of this (three pin) header.
  17. Remove the USB flash drive from the back panel of the board.
  18. Power on the board.
  19. Immediately begin pressing the F2 key, over and over (approx. once per second) until you see the BIOS Setup (or Visual BIOS) screen displayed.
  20. Verify, using the BIOS version string, that the BIOS installed properly. Stop if it isn't.
  21. Press the F9 key (followed by the Y key) to reset of the BIOS configuration.
  22. Press the F10 key (followed by the Y key) to save the BIOS Configuration and exit BIOS Setup.
  23. Once screen is cleared (goes black), begin pressing the F2 key, over and over, until you see the BIOS Setup screen displayed.
  24. Make any changes to the BIOS configuration that you desire (for example, disabling NUMLOCK) or that you require (for example, setting Boot Order, enabling UEFI, etc.).
  25. Press the F10 key (followed by the Y key) to save the BIOS Configuration and exit BIOS Setup.
  26. Test.

Hope this helps,



Hello! I'm a local computer tech who's worked on Grandpa's computer. Managed to find the ME firmware version, which appeared to be So that one seems OK.
I still tried to re-install BIOS 2209 by moving the jumper as described, but the system then went into a boot loop with nothing on the display (running for ~20 seconds, shutting down for a few seconds, repeat). I shut down, put the jumper back and made it into BIOS setup. Used F9 to load default values and saved. Still not able to recognize any SATA devices on the four black ports, they do not even appear in BIOS setup.

Super User Retired Employee


What kind of flash drive did you have plugged in? Smaller than 32GB (preferably 8GB or smaller), right?

Was it properly low-level (i.e. Quick Format option disabled) and high-level (FAT32) formatted?

Was the .BIO file the only one in the root folder?



It was a 32Gb flashdrive used, and it was properly formatted according to your description.
The only file on the flashdrive was the file you sent to me.

My local helper is the best one can get, and he have a lot of experience in updating bios.

I do not know why this did not work, perhaps there is something wrong with the main board ?

Super User Retired Employee

Depending upon what BIOS is on it currently, it is possible that it simply cannot handle a flash drive that large.

You *have* reported that the SATA ports are not working properly, so the possibility is there that the board is starting to fail. Maybe it is time to upgrade to something that is not so old...



I'm sorry to inform you that the problems is not solved. I have contacted the best data specialist here, and informed him about your effort.
You can see his answer as a new member, "Leknes", on this forum.

There are no new SATA ports available, and the problem still exist.

Again, thank you for the effort, and you may contact "Leknes" for further information.