Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,583 Views

Three Beeps upon booting DH87RL board and no video

I have just started my first build. I have everything set up and plugged in, but when I attempt to boot I get three beeps. From what I have read this is a RAM issue. I have followed the troubleshooting steps: tried every DIMM slot, cleaned the gold plates, and reseated over and over again. On top of that, I cannot get any video to load, both with or without my EVGA 750Ti graphics card plugged. Therefore I can't test the ram or update the bios very easily. I am attempting to use an 8 GB kvr16r11d4/8hc Kingston RAM and I do not have any others lying around to try as this is my first build. Does anybody have any suggestions? I am very new and need some helpful advice to get this thing working.

0 Kudos
3 Replies
Highlighted
Employee
1 View

This might be the memory itself, the BIOS on the computer or even the memory controller hub on the processor. I would recommend checking with your place of purchase to see if you could return the memory. I have checked memory specifications and meets the requirements.

Please see the list of compatible memory linked below:

http://www.intel.com/support/motherboards/desktop/db-dh87rl/sb/CS-034215.htm Intel® Desktop Board DH87RL — System Memory

Allan.

Highlighted
Beginner
1 View

It was the memory! Took it down to a little place down the street called "Geeky Clean PC" and dropped it off. An hour later they called telling me that it was the RAM causing the issue and that when they swapped it out for another stick they had on hand it booted up fine. Glad to know that I actually managed to hook everything up right on the first try! Amazon Prime is sending a new Kinston HyperX 8GB so it should be up and running by this time tomorrow. Thanks anyways!

Highlighted
Employee
1 View

Good to hear the board is working with different memory.

Enjoy..

Allan.

0 Kudos