Intel® Desktop Boards
Peer-to-peer support only
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11463 Discussions

UEFI Motherboard Entries

GHann
Beginner
1,331 Views

Hi all

I sure this has been covered somewhere....

I have a DQ67SW board used in a system running Debian 7.1 . Somehow I managed to get it to boot using UEFI.

I updated to the latest BIOS, now it will no longer boot under UEFI. strangely when I removed the drive and added another blank hard drive, I still saw the debian entry as a boot option. Where does this come from and how can I get rid of it?

Thanks...

BuggyCode

0 Kudos
5 Replies
GHann
Beginner
150 Views

In addition,

I did try and clear the Bios and reset to factory settings.

Kevin_M_Intel
Employee
150 Views

Hello BuggyCode,

I am afraid to say that Linux Support is limited on Intel® products.

Have you tested the motherboard using a Microsoft* operating system version?

GHann
Beginner
150 Views

Hi

CMOS has been cleared, even battery removed and booting from a Microsoft OS is not an option in this case.

Thank you

GHann
Beginner
150 Views

Hi

Little sad to see that in many such questions are answered by "Limited" or "No" Linux support. I gathered that....

I my case Microsoft is not a option - sorry....

Any way I managed to solve the issue - here is what was done.

The CMOS, Factory reset and battery removal - all did not remove the UEFI boot entries. I can sort of see why, however, why is there no option within the BIOS to remove unwanted entries?

Anyway, once I had built the Debian 7.1 system, and ensuring it was booting use UEFI, it was just a matter if running, (as root)

modprobe efivars

and run the efibootmgr command to remove the offending entries.

This can also be done using live Ubuntu disk and as far as I can rememberer the Debian live disk worked as well - as long they are booted using UEFI. I did this be ensuring that UEFI boot option was selected in the BIOS, and the boot device is selected from the UEFI options.

AEsta1
Novice
150 Views

try to clear CMOS bios memory, and manage to boot without loader(i.e. a livecd) and reinstall GRUB bootloader on EFI partition. configure it to boot with debian

as kevin says, try to ensure that there is not another issue booting a Microsoft OS (i.e.Windows 7)

Reply