Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FRehm1
Beginner
1,276 Views

USB 2.0 working as 1.1 Win 7 Intel DG41RQ

HI,

i am running Windows 7 64bit on Intel Desktop DG41RQ

i have updated BIOS to latest and have latest drivers installed.

Problem is all flash drives are running at USB 1.1 when i plug in any flash drive i get notification from windows "this device can perform faster"

This problem is related to windows 7 before that i was using windows XP and my USB was running at 2.0 because of this i think its a driver related issue.

i tried reinstalling windows but problem still remains. i searched for the solution everywhere nothing came up to fix this issue.

i'm tired of using my flash drives at speed of snail 900kb/sec read rate.

my flash drives works fine on my laptop at full speed.

0 Kudos
4 Replies
n_scott_pearson
Super User Retired Employee
19 Views

With 4 Series chipset and Windows 7, support for USB 2.0 ports is provided by the Microsoft standard USB driver. What you need to have installed is the latest Chipset INF Update package (here is a link to the latest version available for your board: https://downloadcenter.intel.com/download/10884/Chipset-Intel-Chipset-Device-Software-for-Discontinu... https://downloadcenter.intel.com/download/10884/Chipset-Intel-Chipset-Device-Software-for-Discontinu...). This package provides the configuration data that the Microsoft driver needs in order to operate these ports properly.

...Scott

FRehm1
Beginner
19 Views

Thanks for the reply but this didnt solved my problem i installed this driver problem remains the same and i checked the previous inf driver i was using is the same INF_allOS_9.1.2.1008_PV

any other suggestion how do i trouble shoot ?

n_scott_pearson
Super User Retired Employee
19 Views

I am not sure what to suggest. I have seen a similar problem where I plugged a USB 3.0 flash stick into a USB 3.0 port, yet got the "This device Can Perform Faster" message and the flash stick runs at USB 2.0 speeds. I never found a solution to this problem (and couldn't make it occur consistently)...

Sorry I have nothing to suggest...anyone else?

...S

IUman
Honored Contributor II
19 Views

Hello cool.dexter,

I would recommend going to Device Manager, find the Universal Serial Bus list, expand it by clicking the + sign. Now starting at the bottom, uninstall each USB device that the PC will allow. Reboot and wait for Windows to detect USB and reinstall drivers.

Run Windows Update and I would suggest you to replace the USB cable with a new one.