Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DSepe
Beginner
1,046 Views

Unable to BIOS Update DX79SI to SI0650P.BIO

Hi, I run out of things to try, and need some help. I'm not able to update my Intel DX79SI Motherboard. When I use the BIOS update utility (press F7 at boot) I choose the bios file then hit enter to confirm. The power to motherboard cuts out and it's off for about 10 seconds then it bootsup normal but with old bios version. I never see the prompts and progress bars where the bios is getting updated. I try to boot using USB and try the dos process and different USB sticks, it's always the same. Power cuts out after I hit enter to confirm. I remove the memory and try with one memory module, change all to default in BIOS, disable onboard RAID, it's still the same.

My current configuration.

DX79SI running all BIOS defaults on bios version 0553

i7 3930K (running default clock 3.2Ghz)

16Gb DDR3 Memory Corsair Dominator 2400 (running default clocks) 4 modules

Nvidia GTX590

Running RAID 0 on motherboard using two Intel SSD's

(water cooled CPU/GPU)

Any help greatly appreciated.

Thanks!

0 Kudos
0 Replies
Reply