Intel® Desktop Boards
Peer-to-peer support only
11436 Discussions

Unable to access bios settings with f2

Community Manager

DZ77GA-70C. I must have enabled fast boot along with disallowing usb support in the bios, I have tried moving the jumper to the 2-3 spot without success, it just tells me to put the jumper back into its normal position and reboot. I have also tried removing the cmos battery, also without success. Is there anything else I can do to reset my bios? Would finding a ps/2 keyboard and booting with that allow me to get back into my bios settings? Thanks for the help.

0 Kudos
2 Replies

Hello SadieC,

Another troubleshooting step that you can try is a BIOS update to the next version based on what you have. In order to determine which is your current BIOS version within Windows you can run the command "msinfo32.exe". In order to do that you can enter that on the search bar that is on the start menu. Once you are there please copy the BIOS Version/Date that appears there.

Based on that we will be able to find the proper BIOS version for you and provide you with the link for you to download it.

Please let me know if you have any questions in regards of that process.

Warm regards,


Super User Retired Employee

The GA board has a Back-To-BIOS button on the rear I/O panel. Press this button, power on and your system will be booted using BIOS default settings. Then, within BIOS setup, you can either press F9 to reset all settings to BIOS defaults or navigate to the appropriate places and fix the improper settings that you got you in trouble...

My personal opinion: The Fast Boot capability is so fraught with caveats that I just won't use it.