Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11463 Discussions

Unable to install USB network adapters (DP55WB, win 7 64bit)



I have spent the last 4 days trying to solve a very persistent problem. You are my last resort before I do a clean install.


Win7 64-bit Home Premium SP 1 OEM

Intel DP55WB, latest chipset, latest BIOS

16 gb ram

I'm not posting from my own machine, so sorry for being a bit unspecific. I can post more accurate specs later.


Have been using wired broadband without problems. Last summer I was also using USB WLAN adapter (A-link Wnu(m) 11n), which shows up as Realtek 8188CU in device manager) and have previously used mobile broadband without problems. However, recently I moved, and don't have access to a wired broadband anymore, I was trying to install a Huawei E353 dongle. The process was as follows: mass storage devices installed properly after which the autorun from the dongle started installing "Remote NDIS based device" which failed. This showed in the device manager as "Code 10 the device cannot start". This device apparently uses only windows drivers.

After this I tried the dongle on my wife's laptop which has Win 7 64-bit Enterprise version, 4 Gb of Ram. Installed correctly and gave internet access in about 7 seconds after plugging in the device. My wife on the other hand has a Huawei e586. I tried this on my machine and the results were similar: mass storage installs correctly, but some networking component always fails.

After this I tried installing the WLAN adapter I used last summer to connect with my wife's E586, but now this install also fails.

Every other USB device works fine, but anything related to networking fails. Also all three of these network adapters work perfectly on my wifes laptop. I was planning to do a clean install of win 7, but decided to ask here first.

Probable causes:

Since these devices have worked the previous summer, something done in between might have affected. Last winter I did a BIOS update, and also upgraded from 4 Gb of 1066Mhz RAM to 16 Gb of 1333Mhz. I can't remember in which order, but neither operation produced visible problems.

I did find a similar problem ( where the problem was narrowed to generic usb hubs. I checked, and my device manager shows two generic usb hubs and two root hubs, but apparently the root hubs control the generic hubs, thus connecting all external ports to the generic hub. I don't understand anything about this, but the abovementioned thread provided no solution. Also, my wife's laptop's device manager shows only root hubs, so this might be the issue.

Troubleshooting measures so far:

Uninstalling practically every device in device manager (yes, even the hidden disconnected ones), including usb controllers/hubs.

Deleting the file supposedly containing usb driver history (which windows recreates, when you plug in a new device, can't remember the name).

Tried installing in safe mode.

Tried installing without keyboard attached and uninstalled the related composite device

Ran sfc /scannow without errors.

Ran chkdsk /f without errors.

Ran Memory diagnostic tool without errors.

Ran Tsskiller anti-rootkit utility, which quarantined ANPD64.sys (what is this anyway? Event logger has issued with this all the time...)

Tried truncatememory to limit memory to 4gb.

Using driver verifier, which only crashed on Intel desktop utilities, which I promptly uninstalled. After that a few crashes by ntoskrnl.exe and once by ndis.dll (I can provide dump files later, if necessary)

And probably many more I can't now remember...

So if you can propose possible causes or remedies I could attempt, I would be very grateful. I'm all prepared for the clean install, but I'm not confident that it will solve this problem.



1 Solution

Installed BIOS version 319 (back from 336). Problem solved.

View solution in original post

3 Replies

Did clean install of win7, problem was not solved. I'm rolling back BIOS next. Hard to imagine that a problem due to anything but the BIOS could "survive" this long.

Looks like I'm chatting alone here, but that's nothing new.



Installed BIOS version 319 (back from 336). Problem solved.


I created an account just so I could say THANK YOU for this! I was suffering the same issue and your answer resolved my problem (unable to install USB network adapters on DP55WB), as well. Thank you!!