Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11463 Discussions

Unusual issue with onboard USB



Using an Intel motherboard that simply identifies itself to auditing software as "Intel Chiefriver". (Single board PC used in an industrial enclosure)

The audit software identifies the following chips/drivers for USB2/3

  • Intel (r) 7 series/C216 Chipset family USB enhanced host controller (1e26)
  • Intel (r) 7 series/C216 Chipset family USB enhanced host controller (1e2D)
  • Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)

We have a mouse, Keyboard and a USB lead to a data collector, plugged into the USB ports.

Randomly, intermittently, the link to the Data collector drops out.

The mouse/Keyboard are fine.

It could take seconds to drop out, minutes or hours.

If all we do is move the USB items to a USB 2.0 non powered hub on the back of the same Pc's USB ports, it becomes very reliable.

The system runs Windows 10.

Any ideas what's going on?

The USB hub is multi TT (multiple transaction translator) so there are controller chips per port on the hub.

The device that drops out is USB 3. (The hub makes it communicate at USB2).

It does not matter if we plug into the USB 2 or 3 at the rear of the PC, the same symptoms occur.

I have to wonder if it's some buffer problem at the PC USB that the hub mitigates as it needs to share the resources over the multiple ports and hence artificially slows the data streams down (millseconds maybe).

I also have to wonder if the connection from the hub to the PC negotiates to an acceptable USB 2 level, the ports on the hub to the device also negotiate to an acceptable USB 2 level, but the device direct to the PC, maybe they are not negotiating correctly ?

We tried a shorter USB cable (As admittedly this was 5m, and too long), same issue.

We tried a Powered USB 3.0 hub (it actually got worse) - however I am not sure the powered hub supports multi TT and we all know USB hubs can be cheap or expensive and all have different features.

We have also tried a USB 1 port isolator (protects from ESD and over voltage).

I did note that the application in use was pushing the CPU to over 90% utilisation (With everything else that was running) and knowing that this may affect USB, I tuned the apps and turned off services on the PC and got it down to 50% at peak, the problem still happens.

The USB drivers were dated 2006/Microsoft for the USB2, and 2016/Microsoft for the USB3.

I have tried monitoring the USB ports using USBlyzer and "free usb analyser". Are there any tools for logging and diagnosing these things people can suggest ?

I hope someone out there might be able to give us an idea what to try next to isolate this issue as the USB hub might not be suitable for long term use in this application.

We have tried the usb-iso olimex isolator (full speed USB2) - USB-ISO Olimex LTD | Development Boards, Kits, Programmers | DigiKey

We have used a Four Port Industrial USB 2.0 Hub UH104 (which works much better but not perfect) - Four Port Industrial USB 2.0 Hub UH104

We have used a mbeat 4 port USB hub - Stick 4-Port USB 3.0 Hub - mbeat (Very reliable and almost perfect)


0 Kudos
2 Replies
Super User Retired Employee

It sounds like you have one of the old Customer Reference Boards (CRBs), in this case one that combines a 3rd generation (Ivy Bridge) Intel Core, Pentium or Celeron processor with a 7 Series (Panther Point) mobile Intel HM76/QM77 Express chipset (codename Chief River = Ivy Bridge + Panther Point).

To support this configuration, you need to have an appropriate Intel Chipset Device Software package installed (this package was previously known as the INF Update Utility). This package, in addition to other things, installs INF files that optimally configure the operation of many Microsoft drivers (including that for USB 3.0). You can download the latest release here: Download Intel® Chipset Device Software (INF Update Utility).

Now, presuming the chipset package is installed, one of the most common reasons for devices to disconnect is because the power being supplied to them is not stable or is borderline insufficient in what it supplies. I would check into this first.

Hope this helps,



Thank you very much for your answer. I will jump on this and see if this improves things. Awesome response - Thankyou