Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,170 Views

Why doesn't the sound driver install?

I have an Intel desktop board model # D510MO. Board number is AAE76523-404. It's running Windows 7 Ultimate 32 bit. I can't install sound drivers on it. The Intel driver update utility doesn't produce anything. I've downloaded the correct drivers from Intel download, but they don't work. It goes through the installation process, reboots, then there's no audio device installed. I've installed the chipset driver and updated the bios.

Tags (1)
0 Kudos
11 Replies
Highlighted
51 Views

Hello Blufx, thank you very much for joining the Intel community.

 

Please let me know which is the current BIOS version installed on your system?

 

Are you trying to install the following drivers from our web site?

Please let me know,

0 Kudos
Highlighted
Beginner
51 Views

I thought I had fixed it but the problem returned on next reboot.

0 Kudos
Highlighted
Beginner
51 Views

Yes, I'm installing drivers from the web site for this particular board. I run the driver update tool, it finds nothing. Neither does MS update.

0 Kudos
Highlighted
Highlighted
Beginner
51 Views

Thank you Sylvia,

I will try to do that tonight. 

0 Kudos
Highlighted
Beginner
51 Views

I rolled back the BIOS, then installed the driver. When finished there was still no audio device installed. I restarted the computer, entered setup and disabled audio. I reinstalled Windows 7. I copied the driver to desktop, restarted and enabled audio in setup. When Windows started I then installed the driver. It says the driver installed successfully, but when I hover over the speaker icon, it still says there's no audio device installed

0 Kudos
Highlighted
Employee
51 Views

Hi blufx,

Please go to device manager and check to see if there is an error for the audio device. You can also go to the system BIOS and verify that the audio device is enabled.

0 Kudos
Highlighted
Beginner
51 Views

hansb_intel Please read the post right above your suggestion. There's no device manager error because there's nothing installed. I stated I disabled audio in bios, installed Windows, then enabled audio in the bios before installing the driver.

 

0 Kudos
Highlighted
Employee
51 Views

Hi blufx,

Please try the steps suggested in the following article:

Desktop Boards

Audio Drivers Do Not Install

http://www.intel.com/support/motherboards/desktop/sb/CS-034207.htm http://www.intel.com/support/motherboards/desktop/sb/CS-034207.htm

0 Kudos
Highlighted
Beginner
51 Views

Let me again direct you to my post that you first replied to. I said the driver installed and even confirms that the device installed correctly. but you can hover over the speaker icon and it says there's no audio device. Neither is there one in the device manager. And none of it applies to the page you sent me to. I'm not getting any error. those drivers won't work with Windows 7, and I've already followed the last step 3 times.

0 Kudos
Highlighted
Employee
51 Views

Hello blufx,

There is a possibility that the audio port is not being detected by Windows because of a physical problem. As a last step you can try installing another operating system and install the proper driver again, and if you experience the same issue you may need to get your motherboard replaced (if is under warranty).

Please let me know your findings.

Best regards,

marving_intel

0 Kudos