Intel® Desktop Boards
Peer-to-peer support only
11381 Discussions

dh61ww: memory corruption without nomodeset



I own an assembled DH61WW PC, bought near the end of 2012. I am aware that the chipset has been discontinued. I am only looking for an explanation to the cause of the issue.

The problem is described here

On 20Feb2018, I again ran the sha256sum test on a 2GB file (with archlinux Feb18 ISO running from a usb stick) - the sum is different at every invocation.

'dd' was used to create a file /tmp/zero of ~1GB zeroes. Upon running hexdump on it, certain bits were found to be set at certain intervals. For instance, the MSB of bytes xxxxxe20 and yyyyye20 were on. Upon giving the system some time, and then reading again from /tmp/zero showed even more bits affected but always at zzzzze20 and similar addresses. I believe that if I had restarted the system and repeated the tests, a different regular offset would have appeared to have been affected.

If the kernel is booted with 'nomodeset' option, the problem goes away. That led me to believe that the mechanism by which the GPU steals memory from the RAM might be faulty, or that the BIOS or the motherboard itself has faults. IIRC, the last kernel that worked (without my changing any defaults) with this system was 4.8. That said, I do not believe that the kernel is at fault - since windows too was affected similarly.

Edit0: I had also tried changing the size of the memory the GPU steals from RAM to no effect. Nvidia GeForce 7600 GT was also installed and made the primary graphics card for the system - towards no improvement.

Can anyone provide some idea of possible causes?

Thank you.


Message was edited by: linuks zone

0 Kudos
2 Replies
Super User Retired Employee

Yea, your system is 6-7 years old and reaching the age where failures will start to occur naturally. Have you tried replacing your memory (even if only temporarily) to see if this makes a difference?



That I have not tried, although the (single) dimm was made to switch slots, and memtest (duration about half an hour) ran without errors. I will purchase a new module, test it out and report back. If nothing else, the system will have more RAM. The only inconvinience I experience because of this problem is the inability to run redshift (which needs DRM enabled, and which I used to run successfully on this same system before the problem appeared).