Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rshaa
Beginner
477 Views

dh77eb bios update gets stuck

i own a dh77eb board and it seems to have something wrong with its bios, so i tried updating it to the latest version by all three ways: through the windows utility, .BIO and recovery. the windows utility refused to start saying that it cannot run on legacy boards, the .BIO file just froze the computer when i tried to flash it and when i set the board to recovery mode it just turned the fans to 100% continuously and displayed nothing.

does anybody have a fix for this?

0 Kudos
1 Reply
n_scott_pearson
Super User Retired Employee
112 Views

What you need to do is reinstall the latest BIOS using the jumper-based BIOS Recovery Process. During this process, follow these additional rules:

 

  1. Use only USB 2.0 flash disks. DO NOT USE USB 3.0 flash disks!
  2. This must be done at least once to every USB flash disk used: On a Windows-based PC, use the standard Format tool to reformat this flash disk with the FAT32 file system and do so with the Quick Format option disabled. DO NOT USE Linux- or MACOS-based PC to do this! Resulting File System MUST BE FAT32. If FAT32 is not offered as a choice in the format tool, then the flash drive is too big and cannot be used. Quick Format option MUST BE disabled. If you are unsure if this has been done to a particular flash disk, then do it (again)! I apologize for this taking so long to run, but it is absolutely necessary!
  3. Plug the flash disk into a black USB 2.0 port on the rear panel of the PC. DO NOT USE blue USB 3.0 ports! DO NOT USE yellow charging ports! DO NOT USE front panel USB ports!

 

Let me know how it goes,

...S

 

Reply