Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KPari2
Beginner
1,481 Views

dh77eb seems to be bricked by incompatible bios version update. or not?

Hello.

Recently I got semi-"dead" DH77EB motherboard which fails to pass through the POST with all components installed and powered on properly. Though if to remove memory units, beeper on the motherboard starts to beep properly informing that those components are not installed.

MB has no mechanical injuries. Electrical circuits were tested and work properly as well. Tried to boot it up with Intel Core i7-2600K CPU, 2 or 1 Corsair CMX4GX3M2B1600C9 memory units (single-channel and dual-channel modes) and nVidia GF GTX560 videocard. But the black screen is the only thing i see.

I tried to perform BIOS recovery procedure (according to the manual) with jumper off using FAT32 formated 128MB usb pen-drive (yep, still have one) with the sole .BIO file on it. Tried different bios versions from download section on Intel's website but no luck. When I power on the system, CPU fan starts to spin, led on my usb pendrive blinks once, then blinks several more times, then i leave everything as it is for ~half an hour (though update shouldn't take more than several minutes in my oppinion), power off (diconnecting the wires from MB, put the jumper back to it's normal position, power on. And only black screen once again.

Actually, the earliest version of BIOS available for dh77eb is 0053. According to this document (http://downloadmirror.intel.com/20951/eng/DH77EB_TechProdSpec06.pdf http://downloadmirror.intel.com/20951/eng/DH77EB_TechProdSpec06.pdf) the earliest BIOS revision for AA -303 is 0041. While the AA-number's last digits on the MB i have are -300.So i guessed I need to try at least 0041 BIOS but didn't manage to find it anywhere on internet (several available links seemed to be broken).

Are there any chances to get 0041 (or earliest) BIOS so i could try it on?

Thanks in advance.

0 Kudos
2 Replies
n_scott_pearson
Super User Retired Employee
127 Views

Have you tried clearing CMOS? Unplug system from wall and remove CR2032 battery from board for 15 minutes.

idata
Community Manager
127 Views

Hi Nayre,

 

 

The available BIOS files start with version 0053. If motherboard is fine the version 53 or 63 should work. I suggest you to use memories of DDR3 1333MHz at 1.5V.

 

 

Try with the Recovery BIOS Update method after removing the CMOS battery and wait 30 minutes at least then, plug battery in.

 

 

Recovery BIOS Update Instructions for Intel® Desktop Boards

 

http://www.intel.com/content/www/us/en/support/boards-and-kits/000005630.html http://www.intel.com/content/www/us/en/support/boards-and-kits/000005630.html

 

 

Regards,

 

Mike C
Reply