Intel® Desktop Boards
Peer-to-peer support only
11430 Discussions

dz77bh-55k updating bios to most recent.


Hi all. I recently bought (2 weeks ago) a brand new DZ77BH-55K to breathe some new life in to my old rig. I'm using an i5 2500k, 8g (2x4g) adata 1600 ram, Silicon Power 240 ssd, and a Seagate Barracuda 1TB Hdd. I have read numerous horror stories of bios updates gone wrong and I wish to avoid these problems. I started updating the bios from 0057 by updating each new bios one at a time in the order of release. I am now stuck at 0083 with this error message: Flashing image for Intel Management Engine Firmware [Failed]. I read in a post on this site a person with a similar problem was advised to install 0083 then to update to the most recent. at the time of the post it appears 0087was the most recent, now however there is 0100. Can anyone tell me the best way to get my bios from 0083 to the most recent? thanks in advance

3 Replies

Hello again all. I just wanted to add some information in hopes that one of you fine gentlemen could help me to proceed. I am using the F7 feature to apply my bios updates, and did so successfully until I reached 0083. As well I stated in the 1st post this is brand new, from Newegg Canada, But it is end of life. I did not know this at the time of purchase. So Intel support is completely unavailable to me. All I really want to know is the safest way to apply bios updates, and possibly which updates to skip over. I appreciate any and all input. Thanks


Hi again. So, although no one here chimed in, I would like to update this post.. I successfully updated the bios to 0100 from 0083. For those folks who get this board (because Newegg has stock still) here is the best way for updating to most recent bios on a DZ77BH-55K

1. If you have 0057 should download 0070 bio, 0083 bio and 0100 boi , and save them to PC.

2. use a non boot usb and put the 3 bio files on it

3 restart your pc and press F2 to enter bios. load bios defaults and exit saving changes *note(you may want to save your profile before loading defaults)

4 on restart press F7 which opens the flash utility, select your usb device and start flash using 0070 1st,

5.if this has worked repeat F7 flash method until you reach 0100.

If you should have the same error I did reset your bios to defaults and try again.

Thanks to the community, I hope someone finds this helpful.


Thank you for your feedback. Additional BIOS update procedures are on the link below.

BIOS Update Instructions Desktop Boards — BIOS Update Instructions