Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1596 Discussions

CMake Configuration is broken on DevCloud

ArmyXn
Beginner
4,213 Views

I have a project that relies on CMake to build CUDA/ROCm/oneAPI binaries. While CMake can successfully find all the necessary oneAPI components (i.e. IntelDPCPP, oneDPL, MKL) on other systems after running:

source /opt/intel/oneapi/setvars.sh

It fails miserably on DevCloud with the following error:

$ CC=icx CXX=icpx cmake -S . -B build
-- Setting build type to 'Release' as none was specified.
-- The CXX compiler identification is IntelLLVM 2023.0.0
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/bin/icpx - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found OpenMP_CXX: -fiopenmp (found version "5.0")
-- Found OpenMP: TRUE (found version "5.0")
-- The SYCL compiler is /glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/bin/icpx
-- The SYCL Flags are -fsycl
-- The SYCL Language Version is 202001
-- Found IntelDPCPP: /glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/include (found version "202001")
CMake Error at CMakeLists.txt:68 (find_package):
  By not providing "FindoneDPL.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "oneDPL", but
  CMake did not find one.

  Could not find a package configuration file provided by "oneDPL" with any
  of the following names:

    oneDPLConfig.cmake
    onedpl-config.cmake

I tried to load oneDPL with 'module load dpl/latest' to no avail. Any idea how I can fix this?

 

Cheers,

Armin

0 Kudos
33 Replies
JaideepK_Intel
Moderator
2,998 Views

Hi,


Thank you for posting in Intel Communities.


In order to reproduce your issue from our end, could you please share a sample reproducer and the exact steps to reproduce your issue.


Thanks,

Jaideep



0 Kudos
ArmyXn
Beginner
2,990 Views

Just copy and paste the following in a file named CMakeLists.txt

 

cmake_minimum_required(VERSION 3.21...3.26)

project(Test LANGUAGES CXX)

find_package(IntelDPCPP REQUIRED)
find_package(oneDPL REQUIRED)
find_package(MKL CONFIG REQUIRED)

 

 

Then use the following commands to see the errors:

 

module load cmake
CC=icx CXX=icpx cmake -S . -B build

 

 

0 Kudos
JaideepK_Intel
Moderator
2,979 Views

Hi,

 

Good day to you.

 

We can see that the paths to MKL and oneDPL are not loaded properly. One possible workaround is exporting those paths. Please run the below commands.

export oneDPL_DIR=/opt/intel/oneapi/dpl/latest/
export MKL_DIR=/opt/intel/oneapi/mkl/latest/

Then use the following commands.

module load cmake
CC=icx CXX=icpx cmake -S . -B build

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards,

Jaideep

 

 

0 Kudos
ArmyXn
Beginner
2,967 Views

Hi Jaideep,

 
Thank you for your reply. While the workaround solves that problem as I had tried it before, I get the following warning during the configuration later:
CMake Warning at perf/CMakeLists.txt:4 (add_executable):
  Cannot generate a safe runtime search path for target benchmarks_oneapi
  because files in some directories may conflict with libraries in implicit
  directories:

    runtime library [libtbb.so.12] in /glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/lib/intel64/gcc4.8 may be hidden by files in:
      /glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest/lib

  Some of these libraries may not be found correctly.
And then when I try to build using 'cmake --build build' I get:
/home/u171514/nvoy/perf/benchmarks_oneapi.cpp:3:10: fatal error: 'sycl/sycl.hpp' file not found
#include <sycl/sycl.hpp>
You cannot reproduce this using the CMakeLists.txt file that I provided before cause it requires the complete codebase. But obviously, there is something wrong with the way the whole oneAPI framework is set up on the DevCloud.
 
Cheers,
Armin
 
 
 
 
 
0 Kudos
JaideepK_Intel
Moderator
2,922 Views

Hi,


Good day to you.


One possible workaround:

Inside CMakeList.txt, if there is any INCLUDE_DIR, please add -I /opt/intel/oneapi/compiler/2022.1.0/linux/include/.


If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!


Thanks,

Jaideep



0 Kudos
ArmyXn
Beginner
2,912 Views

There's no INCLUDE_DIR in my CMakeLists.txt file. But I guess I've found the source of the problem. On other systems, there's only one IntelDPCPPConfig.cmake file in /opt/intel/oneapi folder:

$ find /opt/intel/oneapi -name IntelDPCPPConfig.cmake
/opt/intel/oneapi/compiler/2023.0.0/linux/IntelDPCPP/IntelDPCPPConfig.cmake

But on DevCloud the same command returns:

$ find /opt/intel/oneapi -name IntelDPCPPConfig.cmake
/opt/intel/oneapi/intelpython/python3.9/envs/2023.0.0/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake
/opt/intel/oneapi/intelpython/python3.9/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake
/opt/intel/oneapi/intelpython/python3.9/pkgs/dpctl-0.14.0-py39h8ea5824_17/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake
/opt/intel/oneapi/compiler/2023.0.0/linux/IntelDPCPP/IntelDPCPPConfig.cmake

 

The other files in /opt/intel/oneapi/intelpython folder overshadow the right one in the /opt/intel/oneapi/compiler folder. IMO, intelpython folder must be moved from /opt/intel/oneapi to /opt/intel. Can you do that?

 

Cheers,

Armin

0 Kudos
JaideepK_Intel
Moderator
2,882 Views

Hi,

 

Good day to you.

 

We assume intel python is not installed on your machine because of that you are unable to view below paths.

/opt/intel/oneapi/intelpython/python3.9/envs/2023.0.0/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake
/opt/intel/oneapi/intelpython/python3.9/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake
/opt/intel/oneapi/intelpython/python3.9/pkgs/dpctl-0.14.0-py39h8ea5824_17/lib/python3.9/site-packages/dpctl/resources/cmake/IntelDPCPPConfig.cmake

 

One work around for your issue is.

 

Copy the below statement in Makefile: 

INCLUDE_DIR=/opt/intel/oneapi/compiler/2022.1.0/linux/include/

 

Now, while building the target include the path as below:

Example:

$CC <options> -I $INCLUDE_DIR 

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards,

Jaideep

 

 

 

 

0 Kudos
ArmyXn
Beginner
2,840 Views

If I wanted to use Makefile to build my project then I used one. It relies on CMake to build and CMake configuration is broken on DevCloud as the title of this ticket clearly says. And no, the issue is not resolved yet.

 

0 Kudos
JaideepK_Intel
Moderator
2,792 Views

Hi,


Good day to you.


The Dev team is working on this issue internally, and in the meantime, we are providing workarounds.

One suggestion while running the cmake command is that instead of using icpx, you can use "icpx -fsycl," i.e.


module load cmake

CC=icx CXX="icpx -fsycl" cmake -S . -B build


Thanks,

Jaideep



0 Kudos
ArmyXn
Beginner
2,749 Views

Using CXX="icpx -fsycl" prevents CMake to detect OpenMP support by the compiler and breaks configuration early with the following error:

CMake Error at /glob/development-tools/versions/cmake/3.21.2/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find OpenMP_CXX (missing: OpenMP_CXX_FLAGS OpenMP_CXX_LIB_NAMES)
Call Stack (most recent call first):
  /glob/development-tools/versions/cmake/3.21.2/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /glob/development-tools/versions/cmake/3.21.2/share/cmake-3.21/Modules/FindOpenMP.cmake:544 (find_package_handle_standard_args)
  CMakeLists.txt:65 (find_package)

So, far I had a little bit of progress with the following commands:

export CMAKE_PREFIX_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpl/latest/:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/latest/
CC=icx CXX=icpx cmake -S . -B build
cmake --build build -j 8

Using the above commands I can successfully build unit tests. But when it comes to building the benchmarks I get the following error:

 *** No rule to make target '/tmp/build/80754af9/snappy_1649923748780/_build_env/x86_64-conda-linux-gnu/sysroot/usr/lib/librt.so', needed by 'perf/benchmarks_oneapi'.  Stop.

I don't have any of these hassles on other systems. Any idea how can I fix that?

 

 

0 Kudos
JaideepK_Intel
Moderator
2,731 Views

Hi,


Good day to you.


To understand your issue better, The dev team is asking for sample reproducers or any github repos you are referring to.


Thanks,

Jaideep



0 Kudos
ArmyXn
Beginner
2,665 Views

Here's the repository on GitHub:

 

https://github.com/arminms/one4all

 

The instruction is already included but you can use the following commands on DevCloud to build for oneAPI:

git clone https://github.com/arminms/one4all.git
cd one4all
module load cmake
CXX=icpx cmake -S . -B build-oneapi -DONE4ALL_TARGET_API=oneapi
cmake --build build-oneapi -j

 

Cheers,

Armin

0 Kudos
JaideepK_Intel
Moderator
2,577 Views

Hi,


Sorry for the delay, still we are working on this internally and get back to you with an update.


Thanks,

Jaideep


0 Kudos
ArmyXn
Beginner
2,566 Views
0 Kudos
ArmyXn
Beginner
2,439 Views

Any updates? It's been over a month since I've been waiting to build a program on DevCloud. Is it possible to install Singularity/Apptainer on DevCloud so I can build it using oneAPI Singularity image?

 

Thank you,

Armin

0 Kudos
JaideepK_Intel
Moderator
2,425 Views

Hi,


I hope you are doing well.


1 issue so far that we have found is that to get a clean build, you need to unset all the Intel Python paths however the compile still fails. Can you share with us the full output of your "env"?


Thanks,

Jaideep


0 Kudos
ArmyXn
Beginner
2,409 Views

Here it is:

CONDA_SHLVL=1
LD_LIBRARY_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/../lib/intel64/gcc4.8:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/rkcommon/1.10.0/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray_studio/0.11.1/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray/2.10.0/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/openvkl/1.3.1/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/oidn/1.4.3/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//libfabric/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//lib/release:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0/slib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ispc/1.18.1/lib/lib64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ippcp/2021.6.3/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/embree/3.13.5/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/gdb/intel64/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/libipt/intel64/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/dep/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/x64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/oclfpga/host/linux64/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/compiler/lib/intel64_lin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ccl/2021.8.0/lib/cpu_gpu_dpcpp
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
CONDA_EXE=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest/bin/conda
DAL_MINOR_BINARY=1
FPGA_VARS_ARGS=
SSH_CONNECTION=10.5.0.46 56188 10.9.0.2 22
LESSCLOSE=/usr/bin/lesspipe %s %s
OCL_ICD_FILENAMES=libintelocl_emu.so:libalteracl.so:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/x64/libintelocl.so
LANG=en_US
ADVISOR_2023_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0
VT_MPI=impi4
IPPROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0
CLCK_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2
DPCT_BUNDLE_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpcpp-ct/2023.0.0
DAL_MAJOR_BINARY=1
ACL_BOARD_VENDOR_PATH=/opt/Intel/OpenCLFPGA/oneAPI/Boards
CONDA_PREFIX=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest
VT_SLIB_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0/slib
FI_PROVIDER_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//libfabric/lib/prov:/usr/lib64/libfabric
EXIT_STATUS=1
_CE_M=
INTEL_PYTHONHOME=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/dep
CLASSPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//lib/mpi.jar:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0/lib/onedal.jar
XDG_SESSION_ID=202128
MODULES_CMD=/usr/lib/x86_64-linux-gnu/modulecmd.tcl
USER=u171514
FPGA_VARS_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/oclfpga
CMPLR_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0
ENV=/usr/share/modules/init/profile.sh
QUARTUS_ROOTDIR_OVERRIDE=/glob/development-tools/versions/oneapi/2022.3.1/intelFPGA_pro/19.2/quartus
CCL_CONFIGURATION=cpu_gpu_dpcpp
PWD=/home/u171514
DNNLROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp
CCL_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ccl/2021.8.0
HOME=/home/u171514
CONDA_PYTHON_EXE=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest/bin/python
GDB_INFO=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/documentation/info/
CMAKE_PREFIX_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/..:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp/../lib/cmake:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/IntelDPCPP
SSH_CLIENT=10.5.0.46 56188 22
CPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/../include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ippcp/2021.6.3/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpl/2022.0.0/linux/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpcpp-ct/2023.0.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dev-utilities/2021.8.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0/include:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ccl/2021.8.0/include/cpu_gpu_dpcpp
INTELFPGAOCLSDKROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/oclfpga
BASH_ENV=/usr/share/modules/init/bash
DALROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0
DPL_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpl/2022.0.0
_CE_CONDA=
NLSPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/lib/intel64/locale/%l_%t/%N:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/compiler/lib/intel64_lin/locale/%l_%t/%N
TMPDIR=/home/u171514/tmp
LIBRARY_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/../lib/intel64/gcc4.8:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//libfabric/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//lib/release:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ippcp/2021.6.3/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ipp/2021.7.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/compiler/lib/intel64_lin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2/lib/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ccl/2021.8.0/lib/cpu_gpu_dpcpp
IPPCRYPTOROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ippcp/2021.6.3
SETVARS_COMPLETED=1
VT_LIB_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0/lib
LOADEDMODULES=
IPP_TARGET_ARCH=intel64
DAALROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0
DIAGUTIL_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vtune/2023.0.0/sys_check/vtune_sys_check.py:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpcpp-ct/2023.0.0/sys_check/sys_check.sh:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/sys_check/debugger_sys_check.py:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/sys_check/sys_check.sh:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0/sys_check/advisor_sys_check.py:
INTEL_LICENSE_FILE=/opt/intel/licenses:/home/u171514/intel/licenses:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2/licensing:/opt/intel/licenses:/home/u171514/intel/licenses:/Users/Shared/Library/Application Support/Intel/Licenses:/usr/local/licenseserver/psxe.lic
CONDA_PROMPT_MODIFIER=(intelpython-python3.9)
SSH_TTY=/dev/pts/2040
IPPCP_TARGET_ARCH=intel64
MAIL=/var/mail/u171514
VT_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0
TERM=xterm-256color
SHELL=/bin/bash
VT_ADD_LIBS=-ldwarf -lelf -lvtunwind -lm -lpthread
APM=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0/perfmodels
SHLVL=1
LANGUAGE=en_US:
PYTHONPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray_studio/0.11.1/lib:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0/pythonapi
VTUNE_PROFILER_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vtune/2023.0.0
MANPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0/man:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0/man:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/embree/3.13.5/share/man:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/documentation/man:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/documentation/en/man/common:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2/man::
MODULEPATH=/etc/environment-modules/modules:/usr/share/modules/versions:/usr/share/modules/$MODULE_VERSION/modulefiles:/usr/share/modules/modulefiles:/glob/module-files/development-tools:/glob/module-files/intel-oneapi-components:/glob/module-files/intel-oneapi
LOGNAME=u171514
XDG_RUNTIME_DIR=/run/user/173528
ONEAPI_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi
MKLROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0
CPLUS_INCLUDE_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2/include
MODULEPATH_modshare=/glob/module-files/intel-oneapi:1:/glob/module-files/development-tools:1:/usr/share/modules/$MODULE_VERSION/modulefiles:1:/etc/environment-modules/modules:1:/glob/module-files/intel-oneapi-components:1:/usr/share/modules/modulefiles:1:/usr/share/modules/versions:1
INSPECTOR_2023_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/inspector/2023.0.0
MODEL_ZOO_VERSION=2.9.0
PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vtune/2023.0.0/bin64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray_studio/0.11.1/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray/2.10.0/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/openvkl/1.3.1/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/oidn/1.4.3/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//libfabric/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0//bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/bin/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/itac/2021.8.0/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ispc/1.18.1/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/intelpython/latest/condabin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/inspector/2023.0.0/bin64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/embree/3.13.5/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpcpp-ct/2023.0.0/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dev-utilities/2021.8.0/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/gdb/intel64/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/lib/oclfpga/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/bin/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/linux/bin:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/clck/2021.7.2/bin/intel64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0/bin64:/glob/development-tools/versions/oneapi/beta05/inteloneapi/intelpython/latest/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/u171514/.local/bin:/home/u171514/bin:/bin:/glob/intel-python/python2/bin
TBBROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/..
VTUNE_PROFILER_2023_DIR=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vtune/2023.0.0
MODULESHOME=/usr/share/modules
CONDA_DEFAULT_ENV=intelpython-python3.9
PKG_CONFIG_PATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vtune/2023.0.0/include/pkgconfig/lib64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/vpl/2023.0.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/tbb/2021.8.0/env/../lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/rkcommon/1.10.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ospray/2.10.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/openvkl/1.3.1/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/oidn/1.4.3/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mkl/2023.0.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ippcp/2021.6.3/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/inspector/2023.0.0/include/pkgconfig/lib64:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/embree/3.13.5/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dpl/2022.0.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dnnl/2023.0.0/cpu_dpcpp_gpu_dpcpp/../lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/dal/2023.0.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/compiler/2023.0.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/ccl/2021.8.0/lib/pkgconfig:/glob/development-tools/versions/oneapi/2023.0.1/oneapi/advisor/2023.0.0/include/pkgconfig/lib64:
INFOPATH=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/debugger/2023.0.0/gdb/intel64/lib
I_MPI_ROOT=/glob/development-tools/versions/oneapi/2023.0.1/oneapi/mpi/2021.8.0
LESSOPEN=| /usr/bin/lesspipe %s
BASH_FUNC_module%%=() {  _moduleraw "$*" 2>&1
}
BASH_FUNC_switchml%%=() {  typeset swfound=1;
 if [ "${MODULES_USE_COMPAT_VERSION:-0}" = '1' ]; then
 typeset swname='main';
 if [ -e /usr/lib/x86_64-linux-gnu/modulecmd.tcl ]; then
 typeset swfound=0;
 unset MODULES_USE_COMPAT_VERSION;
 fi;
 else
 typeset swname='compatibility';
 if [ -e /usr/lib/x86_64-linux-gnu/modulecmd-compat ]; then
 typeset swfound=0;
 MODULES_USE_COMPAT_VERSION=1;
 export MODULES_USE_COMPAT_VERSION;
 fi;
 fi;
 if [ $swfound -eq 0 ]; then
 echo "Switching to Modules $swname version";
 source /usr/share/modules/init/bash;
 else
 echo "Cannot switch to Modules $swname version, command not found";
 return 1;
 fi
}
BASH_FUNC__moduleraw%%=() {  unset _mlre _mlIFS _mlshdbg;
 if [ "${MODULES_SILENT_SHELL_DEBUG:-0}" = '1' ]; then
 case "$-" in
 *v*x*)
 set +vx;
 _mlshdbg='vx'
 ;;
 *v*)
 set +v;
 _mlshdbg='v'
 ;;
 *x*)
 set +x;
 _mlshdbg='x'
 ;;
 *)
 _mlshdbg=''
 ;;
 esac;
 fi;
 if [ -n "${IFS+x}" ]; then
 _mlIFS=$IFS;
 fi;
 IFS=' ';
 for _mlv in ${MODULES_RUN_QUARANTINE:-};
 do
 if [ "${_mlv}" = "${_mlv##*[!A-Za-z0-9_]}" -a "${_mlv}" = "${_mlv#[0-9]}" ]; then
 if [ -n "`eval 'echo ${'$_mlv'+x}'`" ]; then
 _mlre="${_mlre:-}${_mlv}_modquar='`eval 'echo ${'$_mlv'}'`' ";
 fi;
 _mlrv="MODULES_RUNENV_${_mlv}";
 _mlre="${_mlre:-}${_mlv}='`eval 'echo ${'$_mlrv':-}'`' ";
 fi;
 done;
 if [ -n "${_mlre:-}" ]; then
 _mlre="eval ${_mlre}";
 fi;
 eval `${_mlre:-}/usr/bin/tclsh /usr/lib/x86_64-linux-gnu/modulecmd.tcl bash $*`;
 _mlstatus=$?;
 if [ -n "${_mlIFS+x}" ]; then
 IFS=$_mlIFS;
 else
 unset IFS;
 fi;
 if [ -n "${_mlshdbg:-}" ]; then
 set -$_mlshdbg;
 fi;
 unset _mlre _mlv _mlrv _mlIFS _mlshdbg;
 return $_mlstatus
}
_=/usr/bin/env

 

0 Kudos
JaideepK_Intel
Moderator
2,310 Views

Hi,

I hope you are doing well.

 

We assume there is an issue with your sample. When we are trying to build the sample, it's showing errors as below, attaching a screenshot for reference.

JaideepK_Intel_0-1682491547420.png

 

Thanks,

Jaideep

 

0 Kudos
ArmyXn
Beginner
2,268 Views

Hi Jaideep,

 

There's no issue with the code. I can build it flawlessly with version 2023.0.0 and 2023.1.0 of oneAPI installed on my laptop and several other HPC clusters. That's all because of faulty configuration during CMake config phase. Would you please kindly install Singularity/Apptainer as a module on DevCloud so I can build it with the container version of oneAPI?

 

Thank you,

Armin

 

0 Kudos
JaideepK_Intel
Moderator
2,238 Views

Hi,


Good day to you.


The dev team is working on CMake config, and sorry to say this, but there is no singularity available currently in devcloud, and there are currently no plans to implement it going forward.


Thanks,

Jaideep


0 Kudos
Reply