Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous101
Beginner
290 Views

Can't connect: Protocol mismatch

Hello,

  I followed the recipe to connect to devcloud through my pre-installed cygwin environment, but I can't get into devcloud. When I run the "ssh devcloud+proxy" I end up with the terminal blocked and when I hit return, ssh shows "protocol mismatch" and then I have to kill it through CTRL+C.  Any idea on what might be wrong and/or how to fix this?

Thanks

 

--

$ ssh -v devcloud+PROXY
OpenSSH_8.1p1, OpenSSL 1.1.1d  10 Sep 2019
debug1: Reading configuration data /home/xyz/.ssh/config
debug1: /home/xyz/.ssh/config line 257: Applying options for devcloud+PROXY
debug1: Executing proxy command: exec nc -x proxy-ir.intel.com:1080 devcloud.intel.com 22
debug1: identity file /home/xyz/.ssh/devcloud-access-key-42705.txt type -1
debug1: identity file /home/xyz/.ssh/devcloud-access-key-42705.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug1: Authenticating to devcloud.intel.com:22 as 'guest'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:A43Fccb1iM4pDwsT5OgjszJYHAJdaMmA4fV2hf1HmVo
debug1: Host 'devcloud.intel.com' is known and matches the ECDSA host key.
debug1: Found key in /home/xyz/.ssh/known_hosts:70
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /home/xyz/.ssh/devcloud-access-key-42705.txt  explicit
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
debug1: Next authentication method: publickey
debug1: Trying private key: /home/xyz/.ssh/devcloud-access-key-42705.txt
debug1: Authentication succeeded (publickey).
Authenticated to devcloud.intel.com (via proxy).
debug1: Local connections to LOCALHOST:4022 forwarded to remote address c009:22
debug1: Local forwarding listening on ::1 port 4022.
debug1: channel 0: new [port listener]
debug1: Local forwarding listening on 127.0.0.1 port 4022.
debug1: channel 1: new [port listener]
debug1: channel 2: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: proc
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Remote: Forced command.
SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3

Protocol mismatch.

debug1: client_input_channel_req: channel 2 rtype exit-signal reply 0
debug1: client_input_channel_req: channel 2 rtype eow@openssh.com reply 0
^Cdebug1: channel 2: free: client-session, nchannels 3
debug1: channel 0: free: port listener, nchannels 2
debug1: channel 1: free: port listener, nchannels 1
Connection to devcloud.intel.com closed.
Transferred: sent 2712, received 2628 bytes, in 14.6 seconds
Bytes per second: sent 185.7, received 180.0
debug1: Exit status -1

 

Tags (1)
0 Kudos
3 Replies
ChithraJ_Intel
Moderator
290 Views

Hi,

We tried connecting Devcloud through the Cygwin environment and it's working fine for us. Could you please follow the below steps.If you have done already,skip that step.

Step 1: Download CYGWIN: 64 bit version from https://www.cygwin.com/   and run the setup with the --no-admin option. 
For more information on installation, please go through:  https://devcloud.intel.com/datacenter/learn/connect-with-ssh-windows-cygwin/installation      Note: If you have installed it already, skip to the next step.
Step 2: Open the Cygwin Terminal and set up SSH tunneling as described below for connecting to Intel AI Devcloud.

  • Download and save the SSH access key for Linux/macOS to the folder ~/Downloads/ on your computer and remove the ".txt" extension from the key name. Create the directory ~/.ssh, unless it already exists and copy the key file devcloud-access-key-XXXXX to ~/.ssh.       
     mkdir -p ~/.ssh
     mv ~/Downloads/devcloud-access-key-<user> ~/.ssh/
  • Create a config file in ~/.ssh folder. For that add the following lines in ~/.ssh/config file.
    Host devcloud_proxy
    User uXXXXX
    HostName c009
    Port 4036
    IdentityFile "<path to>/.ssh/devcloud-access-key-XXXXX"
    ProxyCommand ssh -T devcloud-socks-proxy
    
    Host devcloud-socks-proxy
    User guest
    Hostname cluster.colfaxresearch.com
    IdentityFile "<path to>/.ssh/devcloud-access-key-XXXXX"
    LocalForward 4036 colfaxserver:22
    ProxyCommand nc -x proxy-us.intel.com %h %p 
  • Connect to devcloud:

      ssh devcloud_proxy

Hopes this helps. Please feel free to reach out to us if you have any issues.

 

 

 

ChithraJ_Intel
Moderator
290 Views

Hi,

Could you please confirm whether you are able to connect Devcloud through Cygwin with the solution provided.

ChithraJ_Intel
Moderator
290 Views

Hi

We are closing this case by assuming that your issue got resolved. Please feel free to raise a new thread if you have any further issues

Reply