Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mohammed_F_Intel
Employee
357 Views

Connecting to devcloud using cygwin fails with cyggssapi_krb5-2.dll not found error

Getting below error during ssh with cygwin

C:/cygwin64/bin/ssh.exe: error while loading shared libraries: cyggssapi_krb5-2.dll: cannot open shared object file: No such file or directory
 

Tags (1)
0 Kudos
6 Replies
ChithraJ_Intel
Moderator
357 Views

Hi Mohammed,

Thanks for reaching out to us.

The steps to connect Devcloud through Cygwin environment are explained in the link: https://software.intel.com/en-us/forums/intel-devcloud/topic/856458. Could you please go through the thread and let me know whether you are following the same steps or not. If not, please follow the same steps and let us know if you have any issues.

Mohammed_F_Intel
Employee
357 Views

Hi Chithra,

Thank you; however, it didn't help. Please have a look the details below (sensitive pieces of information are marked with XXXX)

 

$ cat config
Host devcloud_proxy
User uXXXX
HostName c009
Port 4036
IdentityFile "/home/XXXX/.ssh/devcloud-access-key-XXXX"
ProxyCommand ssh -T devcloud-socks-proxy

Host devcloud-socks-proxy
User guest
Hostname cluster.colfaxresearch.com
IdentityFile "/home/XXXX/.ssh/devcloud-access-key-XXXX"
LocalForward 4036 colfaxserver:22
ProxyCommand nc -x proxy-us.intel.com %h %p

$ ssh devcloud_proxy
C:/cygwin64/bin/ssh.exe: error while loading shared libraries: cyggssapi_krb5-2.dll: cannot open shared object file: No such file or directory
 

$ ssh -v devcloud+PROXY
C:/cygwin64/bin/ssh.exe: error while loading shared libraries: cyggssapi_krb5-2.dll: cannot open shared object file: No such file or directory
 

$ ssh localhost
C:/cygwin64/bin/ssh.exe: error while loading shared libraries: cyggssapi_krb5-2.dll: cannot open shared object file: No such file or directory
 

$ ssh
C:/cygwin64/bin/ssh.exe: error while loading shared libraries: cyggssapi_krb5-2.dll: cannot open shared object file: No such file or directory
 

 

 

 

 

ChithraJ_Intel
Moderator
357 Views

Hi Mohammed,

Please follow any of the below methods to load the missing libraries:

  1.  a) Try to add the line export PATH=/cygdrive/c/cygwin64/bin:$PATH (or export PATH=/usr/bin:$PATH) to your .bashrc for one time setup.  or
     b) run the command in cygwin terminal export PATH=/cygdrive/c/cygwin64/bin:$PATH (or export PATH=/usr/bin:$PATH) , before connecting to devcloud.
  2. Run cygcheck /usr/bin/[yourbinary] (example cygcheck /usr/bin/ssh). It will tell any libraries/packages that couldn't find. So,if it returns cyggssapi_krb5-2.dll not found on the system, try to install the package. You can use apt-get to install the package:

           sudo apt-get install -y libgssapi-krb5-2

        3. Try re-installing Cygwin by following the link: https://devcloud.intel.com/datacenter/learn/connect-with-ssh-windows-cygwin/installation and make sure to install the correct versions of SSH + SSL.

Hopes this helps. Please let us know if you face any issues.

Mohammed_F_Intel
Employee
357 Views

Hi Chithra,

Thank you. cygcheck shows missing packages. However, unable to install it with apt-get, as apt-get doesn't exist in cygwin environment .

 

$ cygcheck /usr/bin/ssh
C:\cygwin64\bin\ssh.exe
  C:\cygwin64\bin\cygcrypto-1.1.dll
    C:\cygwin64\bin\cygwin1.dll
      C:\windows\system32\KERNEL32.dll
        C:\windows\system32\ntdll.dll
        C:\windows\system32\KERNELBASE.dll
    C:\cygwin64\bin\cygz.dll
cygcheck: track_down: could not find cyggssapi_krb5-2.dll
 

 

$ sudo apt-get install -y libgssapi-krb5-2
-bash: sudo: command not found


$ apt-get install -y libgssapi-krb5-2
-bash: apt-get: command not found
 

Mohammed_F_Intel
Employee
357 Views

It is fixed now. I searched for libgssapi_krb5_2 in the setup process for cygwin. This package was marked as skip—probably a good idea to add to the documentation to enable this one. 

ChithraJ_Intel
Moderator
357 Views

Hi Farooq,

Thanks for the confirmation. We are closing the case. Please feel free to raise a new thread in case of further queries.

Reply