Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sbhendig
Employee
195 Views

Connectivity Issue - unable to Connect

We are having connectivity issue on Windows and Linux. Any help would be highly appreciated.

1. Windows
I installed Cygwin, a bash emulator for Windows. I followed instructions to run an automated configuration to setup the SSH keys so I could SSH into Devcloud. I ran their script, but when I tried connecting to devcloud, it timed out. I thought it could be due to proxy, so I configured proxy per their instructions and tried SSHing into devcloud.proxy per their suggestion in the instructions, but this errored saying no such host is known. I tried getting off proxy and SSHing in. I connected and added it as a known host, but then I got "amr\\mmauck@devcloud: Permission denied (publickey,gssapi-keyex,gssapi-with-mic).", and was unable to get into Devcloud. This seems to indicate it doesn't like my public key. I tried configuring for VSCode and connecting with that. It began to connect, but I received a non-existent pipe error. I tried connecting a few more times in case there was a race condition or timeout, but the error persisted.

2.
Next, I tried connecting on a Linux machine. I used their automated configuration setup, which seemed to initialize everything correctly. I then set the proxy variables in the ssh config. Finally, I ran ssh devcloud.proxy, but I got the following error:
nc: read failed (0/3): Broken pipe
This Linux machine was on company network so I could not try without proxy. I then tried setting the ServerAliveInterval to 120 in the ssh config. I got the same broken pipe error. I then tried additionally setting ServerAliveCountMax to 5. I also tried setting TCPKeepAlive to yes. This did not fix it.

 

thank you

sbhendig

0 Kudos
4 Replies
Gopika_Intel
Moderator
175 Views

Hi,

Thank you for posting in Intel Devcloud forum. From what we understood you were configuring ssh using automated configuration in both windows and linux. We suggest you to try the manual configuration by referring “Option 2: Manual Configuration” in the same links you’re referring. See if you still get the error. And about Automated configuration setup, we’re trying it from our end, and we’ll get get back to you.

Links mentioned:

For Linux/MacOS : https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/

For Windows(cygwin): https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-windows-cygwin/

For Windows(VScode): https://devcloud.intel.com/oneapi/documentation/connect-with-vscode/

Regards

Gopika


Gopika_Intel
Moderator
154 Views

Hi,


As discussed over email please try out the methods we'd suggested. See if the error persists.


Regards

Gopika


sbhendig
Employee
144 Views

thank you for all the help. Please go ahead and close the ticket. Appreciate your help alot

Gopika_Intel
Moderator
135 Views

Hi Shwetha,

 

Thank you for the confirmation. We are no longer monitoring this thread. For further queries and issues please raise a new thread. We’d be glad to help you.

 

Regards

Gopika


Reply